Will AiMesh solve this problem

  • ATTENTION! As of November 1, 2020, you are not able to reply to threads 6 months after the thread is opened if there are more than 500 posts in the thread.
    Threads will not be locked, so posts may still be edited by their authors.
    Just start a new thread on the topic to post if you get an error message when trying to reply to a thread.

Preskitt.man

Regular Contributor
I have two routers RT-AC86U as a primary router and an RT-AC68U as an AP. The 86U is in the front of the house, the 68U in the back. Admittedly, there is some overlap in signal. Roaming assist is disabled on the 86U and set to -65dbm on the 68U. The two routers are interconnected via Cat 5 cabling. Both routers are set for the same SSID on 5GHz and also same SSID on 2.4 (but distinct from the 5GHz SSID). For 95+% of what I do, this setup works beautifully. Most devices other than our phones are stationary. When I walk from one side of the house to the other, the phone will transition from one router to the other, and even if I am on WiFi calling (which I am most of the time), the calls do not drop.

So, here's the problem. I have my phone (a Samsung S20) set to gave WiFi enabled, connected to the 5GHz signal. A have WiFi calling enabled on the phone. WiFi calling has a sub menu which can be set to WiFi Preferred or Cellular Preferred. I have it set to WiFi Preferred. However the way the phone works, it seems to desperately want to connect via Cellular. This is fine for when I leave the house and don't have WiFi, but for reasons that I can't definitively explain, even inside the house, the phone will switch from WiFi calling mode to Cellular calling mode. Due to the poor cellular signal in the house, when this happens, incoming calls will often go straight to voice mail or connected calls will drop. The ideal solution would be for the phone to stay on WiFi preferred as long as there is a WiFi signal and reconnect to WiFi calling when reacquiring a WiFi signal. I have worked with Sprint/T-Mobile on this and bottom line is they have no solution.

So, I did get to thinking, maybe this transition is the cause of the problem. By example, If I am in the back of the house, and have WiFi calling connected, it will stay that way "forever". It's after walking to the front of the house - there comes a point where the phone decides the 86U is a better signal and it switches over. Or vice versa if I am walking to the back of the house. I am theorizing that it is during this ever so brief transition period that the phone decides - oops, no WiFi and switches to Cellular and stays there. So, I am wondering, would switching over to AiMesh solve this issue or not? Obviously, there will still come a point where the phone transitions from the 68U to the 86U (or vice versa), but maybe with AiMesh, this transition is more elegant.
 

OzarkEdge

Part of the Furniture
I have two routers RT-AC86U as a primary router and an RT-AC68U as an AP. The 86U is in the front of the house, the 68U in the back. Admittedly, there is some overlap in signal. Roaming assist is disabled on the 86U and set to -65dbm on the 68U. The two routers are interconnected via Cat 5 cabling. Both routers are set for the same SSID on 5GHz and also same SSID on 2.4 (but distinct from the 5GHz SSID). For 95+% of what I do, this setup works beautifully. Most devices other than our phones are stationary. When I walk from one side of the house to the other, the phone will transition from one router to the other, and even if I am on WiFi calling (which I am most of the time), the calls do not drop.

So, here's the problem. I have my phone (a Samsung S20) set to gave WiFi enabled, connected to the 5GHz signal. A have WiFi calling enabled on the phone. WiFi calling has a sub menu which can be set to WiFi Preferred or Cellular Preferred. I have it set to WiFi Preferred. However the way the phone works, it seems to desperately want to connect via Cellular. This is fine for when I leave the house and don't have WiFi, but for reasons that I can't definitively explain, even inside the house, the phone will switch from WiFi calling mode to Cellular calling mode. Due to the poor cellular signal in the house, when this happens, incoming calls will often go straight to voice mail or connected calls will drop. The ideal solution would be for the phone to stay on WiFi preferred as long as there is a WiFi signal and reconnect to WiFi calling when reacquiring a WiFi signal. I have worked with Sprint/T-Mobile on this and bottom line is they have no solution.

So, I did get to thinking, maybe this transition is the cause of the problem. By example, If I am in the back of the house, and have WiFi calling connected, it will stay that way "forever". It's after walking to the front of the house - there comes a point where the phone decides the 86U is a better signal and it switches over. Or vice versa if I am walking to the back of the house. I am theorizing that it is during this ever so brief transition period that the phone decides - oops, no WiFi and switches to Cellular and stays there. So, I am wondering, would switching over to AiMesh solve this issue or not? Obviously, there will still come a point where the phone transitions from the 68U to the 86U (or vice versa), but maybe with AiMesh, this transition is more elegant.

You'll have try it to find out. No one can tell what your pesky client will do.

AiMesh 2.0 and Roaming Assistant may help.

My install notes cover the basics. You should disable Smart Connect and use different SSIDs per band as you are doing now. And set fixed, least congested, non-DFS channels. Depending on how far apart your nodes are, you may need to raise (less negative) the 2.4 Roaming Assistant RSSI threshold to say -55.

Install the latest released firmware or the RC2-9 beta firmware, reset, and configure from scratch. Don't configure the remote node/AC68U... just add it in place from within the root node/AC86U webUI.

AiMesh 2.0 will sync guest WLANs across both nodes.

OE
 

Preskitt.man

Regular Contributor
Thanks for the guidance. Are you recommending the Merline 386.1-beta2 software or the official ASUS release? Or do Merlin on the primary node and ASUS code on the mesh? I would also presume, whichever versions you do recommend, install the releases on the system in its current configuration, then do the AI Mesh changeover.
 

OzarkEdge

Part of the Furniture
Thanks for the guidance. Are you recommending the Merline 386.1-beta2 software or the official ASUS release? Or do Merlin on the primary node and ASUS code on the mesh? I would also presume, whichever versions you do recommend, install the releases on the system in its current configuration, then do the AI Mesh changeover.

I do not use Asuswrt-Merlin, so that is your call.

If Asuswrt, I would install the latest released firmware or the RC2-9 beta firmware (whichever you feel most comfortable with... all are linked in my notes), reset, and configure from scratch as noted earlier.

As I see it, the current network is going to be recommissioned, so it doesn't matter how you do it as long as you install the firmware, reset the firmware, and configure the root node only from scratch.

.386 firmware introduces support for 802.11k/v.

OE
 
Last edited:

lucluke

Occasional Visitor
I have two routers RT-AC86U as a primary router and an RT-AC68U as an AP. The 86U is in the front of the house, the 68U in the back. Admittedly, there is some overlap in signal. Roaming assist is disabled on the 86U and set to -65dbm on the 68U. The two routers are interconnected via Cat 5 cabling. Both routers are set for the same SSID on 5GHz and also same SSID on 2.4 (but distinct from the 5GHz SSID). For 95+% of what I do, this setup works beautifully. Most devices other than our phones are stationary. When I walk from one side of the house to the other, the phone will transition from one router to the other, and even if I am on WiFi calling (which I am most of the time), the calls do not drop.

So, here's the problem. I have my phone (a Samsung S20) set to gave WiFi enabled, connected to the 5GHz signal. A have WiFi calling enabled on the phone. WiFi calling has a sub menu which can be set to WiFi Preferred or Cellular Preferred. I have it set to WiFi Preferred. However the way the phone works, it seems to desperately want to connect via Cellular. This is fine for when I leave the house and don't have WiFi, but for reasons that I can't definitively explain, even inside the house, the phone will switch from WiFi calling mode to Cellular calling mode. Due to the poor cellular signal in the house, when this happens, incoming calls will often go straight to voice mail or connected calls will drop. The ideal solution would be for the phone to stay on WiFi preferred as long as there is a WiFi signal and reconnect to WiFi calling when reacquiring a WiFi signal. I have worked with Sprint/T-Mobile on this and bottom line is they have no solution.

So, I did get to thinking, maybe this transition is the cause of the problem. By example, If I am in the back of the house, and have WiFi calling connected, it will stay that way "forever". It's after walking to the front of the house - there comes a point where the phone decides the 86U is a better signal and it switches over. Or vice versa if I am walking to the back of the house. I am theorizing that it is during this ever so brief transition period that the phone decides - oops, no WiFi and switches to Cellular and stays there. So, I am wondering, would switching over to AiMesh solve this issue or not? Obviously, there will still come a point where the phone transitions from the 68U to the 86U (or vice versa), but maybe with AiMesh, this transition is more elegant.

Try:
1) Update both routers to 386.xxxx either stock or Merlin, factory reset (after updating), I'd suggest same SSID for 2.4G and 5G (so that clients can roam freely), disable Universal Beamforming and Airtime Fairness.
2) Enable AiMesh 2.0 with Ethernet Backhaul Mode (386.xxxx either stock or Merlin)
https://www.asus.com/support/FAQ/1044184/
3) Wireless - Professional (2.4G only) -> Tx power adjustment -> Power Saving (to reduce overlap)
4) Roaming assistant (both bands) ->Enabled -> -80 dBm
5) Administration -> System -> Enable Reboot Scheduler -> Yes -> Day(s) to Reboot -> Mon -> 4:00 (to automagically fix any AiMesh issues)


Source: Tested on 2 AC68Us with FaceTime and Wi-Fi Calling on iOS.
 
Last edited:

rlj2

Regular Contributor
I have two routers RT-AC86U as a primary router and an RT-AC68U as an AP. The 86U is in the front of the house, the 68U in the back. Admittedly, there is some overlap in signal. Roaming assist is disabled on the 86U and set to -65dbm on the 68U. The two routers are interconnected via Cat 5 cabling. Both routers are set for the same SSID on 5GHz and also same SSID on 2.4 (but distinct from the 5GHz SSID). For 95+% of what I do, this setup works beautifully. Most devices other than our phones are stationary. When I walk from one side of the house to the other, the phone will transition from one router to the other, and even if I am on WiFi calling (which I am most of the time), the calls do not drop.

So, here's the problem. I have my phone (a Samsung S20) set to gave WiFi enabled, connected to the 5GHz signal. A have WiFi calling enabled on the phone. WiFi calling has a sub menu which can be set to WiFi Preferred or Cellular Preferred. I have it set to WiFi Preferred. However the way the phone works, it seems to desperately want to connect via Cellular. This is fine for when I leave the house and don't have WiFi, but for reasons that I can't definitively explain, even inside the house, the phone will switch from WiFi calling mode to Cellular calling mode. Due to the poor cellular signal in the house, when this happens, incoming calls will often go straight to voice mail or connected calls will drop. The ideal solution would be for the phone to stay on WiFi preferred as long as there is a WiFi signal and reconnect to WiFi calling when reacquiring a WiFi signal. I have worked with Sprint/T-Mobile on this and bottom line is they have no solution.

So, I did get to thinking, maybe this transition is the cause of the problem. By example, If I am in the back of the house, and have WiFi calling connected, it will stay that way "forever". It's after walking to the front of the house - there comes a point where the phone decides the 86U is a better signal and it switches over. Or vice versa if I am walking to the back of the house. I am theorizing that it is during this ever so brief transition period that the phone decides - oops, no WiFi and switches to Cellular and stays there. So, I am wondering, would switching over to AiMesh solve this issue or not? Obviously, there will still come a point where the phone transitions from the 68U to the 86U (or vice versa), but maybe with AiMesh, this transition is more elegant.
I rely on wifi calling for work as my cell service sucks at home. Aimesh helps substantially, i still have times calls go straight to VM, but that doesnt seem to have anything to do with router/mesh/repeater,etc
 

Preskitt.man

Regular Contributor
Here's what seems to be my issue. I have a Galaxy S20, with WiFi calling turned on and the sub-option - "Prefer Wifi" (as opposed to "Prefer Cellular". When I am in the rear of the house - in the area primarily covered by the AC68U, with my phone configured as just noted. All is well. If I walk to the front of the house to my office, about 8 feet and 1 wall away from the AC86U, all is still well. Phone has transferred to the 86U (and as noted earlier, both routers used the same SSID on the 5GHz channel with the 68U in the rear of the house set to AP mode). It's when I walk back to the rear of the house; wait a little bit; and then check my phone - the phone is connected to the 68U for WiFi, but the WiFi calling setting has switched to Cellular Preferred, and calling is now controlled by the cellular connection - which is hit or miss. If redo the settings to prefer WiFi calling, all is well again, until I repeat the sequence of events just described.

Other Samsung phone owners have described similar stories. It could be the phone - but both Samsung and T-Mobile deny there is anything wrong. And the fact that the problem is somewhat reproducible in the manner described makes me wonder if in some way it's my home WiFi.
 

Similar threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top