Solved Wired speeds slow with three different ASUS WiFi 6 routers, any fixes?

boxermansr

Occasional Visitor
If you have another router or can borrow a switch, I'd put the switch between your PC and router LAN port. Or between your modem and router WAN port. Disable DHCP on the router that you are using as switch first.

I've seen some routers just not get along with some Ethernet devices that work just fine with other routers. Something in the way auto-negotiation works. Even forcing the speed/mode of the device port didn't help.
I'll see if I can borrow a switch somewhere, but nobody I know offhand has one, and I'm trying, as much as everyone else is, to limit who we interact with. I'll have access to a new, unopened AX88U tomorrow, and I've been reading that I likely want one with the 1.1 version (if that's not right let me know), I don't recall what the build number is on the one that I have at home, and hopefully I'll get a chance to take a look tonight -- and since I stayed up last night determined to get it working and didn't I'm dead tired, LOL.

Worst case I'll report back once I get the new (mine was new too) AX88U tomorrow and maybe by some stroke of luck it'll work. :mad:
 

Grisu

Part of the Furniture
You still have your AC88, let it connected and connect your AX WAN to a LAN of AC router.
Configure AX in router mode everything on default, yes you now will have double NAT, but its only for speed testing.
Is it now full speed with PC connected to AX LAN?

If you get full speed change your config, AX to modem and AC to AX and test on AC again for speed.

And try again with oldest firmware possible for AX from Merlin.

BTW this sounds very similarly even with AC88: https://www.snbforums.com/threads/slow-wan-performance-384-15.63182/
 
Last edited:

boxermansr

Occasional Visitor
You still have your AC88, let it connected and connect your AX WAN to a LAN of AC router.
Configure AX in router mode everything on default, yes you now will have double NAT, but its only for speed testing.
Is it now full speed with PC connected to AX LAN?

If you get full speed change your config, AX to modem and AC to AX and test on AC again for speed.

And try again with oldest firmware possible for AX from Merlin.

BTW this sounds very similarly even with AC88: https://www.snbforums.com/threads/slow-wan-performance-384-15.63182/

Thanks, will try this later this afternoon. I didn’t get a chance to tinker with stuff again last night but will have a new sealed in box AX88U here by the time I get home later this afternoon. Will take it through all the paces - testing first with zero configuration done and see if it craps out speed wise like the others. [emoji1695]


Sent from my iPhone using Tapatalk
 

boxermansr

Occasional Visitor
New router is waiting to be tested in a few hours. It is H/W Version 1.1, MFG year 2020, in Vietnam. I already sent the previous AX88U back, since I didn't want to have two -- if this one ends up working for me, co-worker will let me have it, as he is going to move his AX11000 to the office.

Will be hooking this AX88U up in about 2 hours and hoping that it works. Will try the suggested things here as well, connecting one router to the other, and vice versa -- hopefully I can figure out (or someone else will, LOL) how to get it working.
 

boxermansr

Occasional Visitor
So far speeds are good (on par with what the AC88U was getting) I did a speed test before swapping to the AX and speeds are about the same now on the AX. The only difference I am seeing this time, versus what I saw with the other AX routers is the IP I am being assigned. With the AC router I had a 68.x.x.x IP with the other three AX routers I tried (prior to this AX) I was getting a 24.x.x.x IP. With this AX router I am also getting a 68.x.x.x IP (not sure if that makes any difference, but figured I'd mention it).

So it's either that the IP I got with this router is in the same 68.x.x.x range (whereas the other three AX routers got 24.x.x.x which are also IP's issued by Spectrum/Time Warner), or the update that I did to the Intel 217-V NIC, or the fact that this router is a 1.1 build (I am 99% sure the other AX88U was also a 1.1 and also made in Vietnam, I do know it had a 2019 build date, whereas this one has 2020, also in Vietnam).

I'm going to power everything down and get all my cables/power cords all in order again (made them into a mess so I could test this out) and see if speeds remain. Also, as best I can tell (just did a speed test on my iPhone 11 Pro Max) and was getting well over 650-700 from two rooms away so not sure if this is the whole AX thing or what - I would get 500's or so with the AC in the same room two rooms away so who knows.

Guess I'll let this run through the paces for the weekend and decide if there's any benefit to keeping it, or just giving it back to my co-worker, or giving him my AC so he can keep his AX11000 at home. Decisions decisions.

Thanks for everyone's suggestions -- I either lucked out, or it was the IP for this router being in the same range as the AC one, or it was the intel driver update for my NIC. Nonetheless, so far it all seems to be OK.
 

Udi Burg

Occasional Visitor
I'm having same issue on my RT-AX88U and I read thoroughly this thread, done all what's here and nothing works.
I have 1Gbps Fiber connection and when I connect my laptop directly to the fiber to Ethernet converter I'm getting 980Mbps download.
When I try that through the router I'm getting 500Mbps. Same cables on both tests. Same Laptop.
 

jdpierce21

New Around Here
I was having the exact same issue with my ASUS ZenWiFi AX. Directly connected to my cable modem (Comcast) I would get 975mbps down. But, when I connected via ethernet to the router, the speed test would get about 450mpbs down. I turned off QoS and now I am getting 923mbps via ethernet to the router. My iPhone 12 Pro Max is getting 575mpbs via WiFi. Before, I was doing good to get 200mpbs on my iPhone. I enabled QoS because I work from home, but, it appears ASUS has some issues they need to fix with QoS.
 

dfunked

Regular Contributor
I was having the exact same issue with my ASUS ZenWiFi AX. Directly connected to my cable modem (Comcast) I would get 975mbps down. But, when I connected via ethernet to the router, the speed test would get about 450mpbs down. I turned off QoS and now I am getting 923mbps via ethernet to the router. My iPhone 12 Pro Max is getting 575mpbs via WiFi. Before, I was doing good to get 200mpbs on my iPhone. I enabled QoS because I work from home, but, it appears ASUS has some issues they need to fix with QoS.
Out of curiosity have you found that QoS is actually necessary on a gigabit connection? Just seems a little unnecessary to me unless you've got something going on that frequently saturates the connection.
 

CIR-Engineering

Occasional Visitor
I just want to add don't forget the obvious. I found this thread because I was having a similar issue with an RT-AX3000. Fought with it one night and then the next morning... it was the cable that it shipped with. Yup, bad ethernet cable. Modem is pumping out gigabit speeds now without issue.

craigr
 

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top