Wireless clients connecting to 2.4GHz, when 5GHz is also available

  • ATTENTION! As of November 1, 2020, you are not able to reply to threads 6 months after the thread is opened if there are more than 500 posts in the thread.
    Threads will not be locked, so posts may still be edited by their authors.
    Just start a new thread on the topic to post if you get an error message when trying to reply to a thread.

FunkyBoss

Occasional Visitor
My setup is 2 RT-AC86U routers in AiMesh, ethernet backhaul, taking most of the defaults including the "Dual Band Smart Connect". So it's using the same SSID for both the 2.4GHz and 5GHz bands. I just upgraded to the latest firmware today: 3.0.0.4.386_40451

What I'm noticing though, is that wireless devices, which are connecting to the remote (non-main) AiMesh node, are always connecting to the 2.4GHz band, even though they are literally sitting right next to the router. I notice that most of the wireless devices connecting to the main AiMesh node, are choosing the 5GHz band. Is there something I have configured incorrectly that is making these other devices always use 2.4GHz instead of 5GHz on the remote AiMesh node? Both are newer laptops, a Lenovo and a MacBook Pro, which I know have 5GHz WiFi support. Or is this possibly some ASUS bug where clients are only choosing 2.4GHz on remote AiMesh nodes?
 

OzarkEdge

Part of the Furniture
My setup is 2 RT-AC86U routers in AiMesh, ethernet backhaul, taking most of the defaults including the "Dual Band Smart Connect". So it's using the same SSID for both the 2.4GHz and 5GHz bands. I just upgraded to the latest firmware today: 3.0.0.4.386_40451

What I'm noticing though, is that wireless devices, which are connecting to the remote (non-main) AiMesh node, are always connecting to the 2.4GHz band, even though they are literally sitting right next to the router. I notice that most of the wireless devices connecting to the main AiMesh node, are choosing the 5GHz band. Is there something I have configured incorrectly that is making these other devices always use 2.4GHz instead of 5GHz on the remote AiMesh node? Both are newer laptops, a Lenovo and a MacBook Pro, which I know have 5GHz WiFi support. Or is this possibly some ASUS bug where clients are only choosing 2.4GHz on remote AiMesh nodes?
A new SDK in the recent firmware seems to improve the chipset WiFi signal. I had to raise the Roaming Assistant 2.4 RSSI threshold from the default of -70 to -62 (so far) to fix a similar 2.4 client problem. Worth trying for your issue.

Also, check for laptop WiFi adapter settings that sometimes offer more control over how the laptop connects... like 'keep scanning for a better connection'.

OE
 

FunkyBoss

Occasional Visitor
A new SDK in the recent firmware seems to improve the chipset WiFi signal. I had to raise the Roaming Assistant 2.4 RSSI threshold from the default of -70 to -62 (so far) to fix a similar 2.4 client problem. Worth trying for your issue.
OE, I'm not quite sure what RSSI means, but I did find the setting for each in the "Smart Connect Rules" section. Currently for 2.4GHz, RSSI is set to "Greater -52dBm" and 5GHz is "Less -82dBm".. What do these mean, and is there something here that should change to have it at least try to connect to the 5GHz band? I assume this section is also shared between the main routher and the AiMesh node.
 

OzarkEdge

Part of the Furniture
OE, I'm not quite sure what RSSI means, but I did find the setting for each in the "Smart Connect Rules" section. Currently for 2.4GHz, RSSI is set to "Greater -52dBm" and 5GHz is "Less -82dBm".. What do these mean, and is there something here that should change to have it at least try to connect to the 5GHz band? I assume this section is also shared between the main routher and the AiMesh node.
I said Roaming Assistant, not Smart Connect. It's under Wireless\Professional.

Google RSSI and read about it.

OE
 

OzarkEdge

Part of the Furniture
Gotcha, thanks! I just made that same update on my router, and those clients now seem to be connecting to the 5GHz!
Cool! Hopefully that was it.

WiFi is hard!

OE
 

Similar threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top