Work laptop VPN over home router VPN

in2ndo

Occasional Visitor
So, keeping in mind that even do I am somewhat comfortable with Windows and Mac machines. I'm brand new to VPN's
I just finished activating ProtonVPN on an Asus AX6600 XT8 running its original firmware/software and all up to date. All of my devices seem to be working/connecting correctly. except one.
My work laptop (Windows machine) runs its own software VPN and it won't load the connection page when ProtonVPN is active. It connects to my WiFi but that is it.
Can someone please point me to where I can find a possible way to make this work. I don't have any admin privileges on the work machine.

Thank you
 

Tech Junky

Very Senior Member
2 options....

split tunnel the work laptop on it's own to bypass proton
tether the laptop to a guest network that's not configured to use the proton connection

3rd but less attractive is to setup all of your traffic to funnel through work
 

in2ndo

Occasional Visitor
2 options....

split tunnel the work laptop on it's own to bypass proton
tether the laptop to a guest network that's not configured to use the proton connection

3rd but less attractive is to setup all of your traffic to funnel through work
Thanks for the reply.
I have the work laptop connected to the guest network. and I just noticed the guest network has no internet. If I deactivate ProtonVPN. the guest network recovers the connection. If I connect it to my main network, it works fine. but I would prefer to keep it on my guest network. I don't see why the VPN would disable the guest one do.
 

Tech Junky

Very Senior Member
It's probably the routing changes made by Proton.

If you setup the Guest on a different subnet it should bypass the VPN on the router and allow the work laptop to connect to its own VPN.

Otherwise figuring out which port the work VPN is using to negotiate and setup the connection might need to be port forwarded to the work laptop. Or depending on the router you might be able to put the work laptop in the DMZ and circumvent the Proton connection.

It kind of all depends on how your network is setup and which equipment you're using as to what features / options are available to make things work as you want them to.
 

eibgrad

Part of the Furniture
Another way to have your workplace laptop bypass the Proton VPN is to add route directives that bind your workplace public IP(s) or domain(s) to the WAN.

Code:
route myworkplace.com 255.255.255.255 net_gateway
route 199.199.199.199 255.255.255.255 net_gateway
route 188.188.188.0 255.255.255.0 net_gateway

I provided three examples. The first based on domain name, the second based on an explicit IP, and the last based on a class C network. You add such directives to the router's OpenVPN client custom config field, which most GUIs normally provide (at least I'd be surprised if the oem/stock firmware didn't).

If you don't know what public IP(s) or domain(s) your laptop uses/requires, just ask your network admin. I'm sure they'll be happy to help you since it's probably their security system that is preventing the access, and they'd probably prefer you didn't run the laptop through your own VPN anyway.
 

in2ndo

Occasional Visitor
Thank you for the help everyone. I figured it out. actually found the answer in a different thread about the same issue.
My set up was, 2GHz guest 1 for guest. by default no intranet access. 2nd 2GHz for my iOT devices with intranet access. I flipped them around and made 2GHz guest one, my regular 2GHZ for my iOT and my used to be personal 2GHz the guest one with no intranet access. and for whatever reason. they both work. did the same thing with the 5GHz guest and used the 2nd one instead of the first one . also with no intranet access and problem fixed.
 

Similar threads

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top