x3mRouting lanscript problem

  • ATTENTION! You'll notice a Prefix dropdown when you create a thread. If your post applies to one of the topics listed, please use that Prefix for your post. When browsing the thread list you can use the Prefix to filter the view.
  • ATTENTION! As of November 1, 2020, you are not able to reply to threads 6 months after the thread is opened if there are more than 500 posts in the thread.
    Threads will not be locked, so posts may still be edited by their authors.
    Just start a new thread on the topic to post if you get an error message when trying to reply to a thread.

reweman

New Around Here
hi. i try to use lanscript and made as tutorial said but its not working. all devices are connecting trough vpn fe. cellphone has c1 and my pc c2. c1 is going on vpn on boot and c2 is when i start it manually. but on router restart they are all connected to vpn. what do i do wrong?
 

Xentrk

Part of the Furniture
hi. i try to use lanscript and made as tutorial said but its not working. all devices are connecting trough vpn fe. cellphone has c1 and my pc c2. c1 is going on vpn on boot and c2 is when i start it manually. but on router restart they are all connected to vpn. what do i do wrong?

1) verify that policy rules are enabled on the OpenVPN Client Screen

1609639388718.png


2) Each LAN client requires a static DHCP IP address assignment in the LAN > DHCP Server screen. This is the source of the file the /jffs/scripts/x3mRouting/x3mRouting_client_rules file. Rerun /jffs/scripts/x3mRouting/x3mrouting_client_config.sh if you need to create a new file or change the lease assignments.

3) Next step is to run x3mrouting_client_nvram.sh script. The VPN client will bounce to activate the assignments. You can type the command "ip rule" at the command line to verify.

Let me know how it goes.
 

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top