Xfi won't properly reserve IP address for device; printers show as unconnected

  • ATTENTION! As of November 1, 2020, you are not able to reply to threads 6 months after the thread is opened if there are more than 500 posts in the thread.
    Threads will not be locked, so posts may still be edited by their authors.
    Just start a new thread on the topic to post if you get an error message when trying to reply to a thread.

Mike Rubin

Occasional Visitor
My knowledge of networks is pretty rudimentary, so I probably won't understand a highly technical explanation of some LAN behavior that baffles me completely. Posting this here, though, because Comcast hasn't a clue.

I just switched from a third party router to the Comcast xfi gateway. I hate that there's no network map, that only MAC addresses rather than common language names show on the connected device list, and that I can't change host names in the edit dialogues, but I am getting better connection speeds than before. It is extremely helpful that I was allowed to change the LAN address to what I had with the old router (to 192.168.0.x from 10.0.0.x), as some devices with static IP addresses joined the network at the expected addresses immediately. All told, the gateway is working okay with two exceptions:

(1) I tried re-reserving at the same IP addresses the MAC addresses of devices that I previously reserved on the old router but that don't have interfaces that allow them to be assigned static IP addresses. I am having a problem, though, with one device, a cabled Sonore microRendu audio streamer, which keeps reverting to the same DHCP-assigned address. With my old router, it was at 192.168.0.6, but now it's only reachable at 192.168.0.246, even after the IP reservation dialogue in the gui tells me it has saved 192.168.0.6 and the connected devices list shows this particular device at that address.

I have disconnected the device from the network and, after ten minutes or so, can tell the gateway via the phone app to "forget this device," but it always comes back on at the same 192.168.0.246 address. My old router would allow me to disconnect and forget a device instantaneously, but this one doesn't seem to do that, and "forget this device" definitely doesn't work. (I note that others posting in the Comcast forums have had the same issue and there's been no solution posted other than to try "forget this device." There must be something one can do to make "forget" a useful option.)

Despite both the xfi web interface and the phone app showing the device at 192.168.0.6, it's only pingable at 192.168.0.246. Its own interface and Fing both show it that address rather than the one I tried to reserve.

What's also weird is that another Sonore product that uses the same internal boards as this one has been able to retain the address the xfi gateway reserved.

(2). My two printers definitely are connected to the network as I have been able to print off to them from my computer and can ping them, but the router interface, the Xfinity webpage, and the Xfinity app all show them as disconnected. It isn't a big deal because they are working okay, but how can I get them to be recognized as connected?

I appreciate your help.
 
Last edited:
Similar threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top