ZenWifi XD4 Don't Work Don't Buy!

  • ATTENTION! As of November 1, 2020, you are not able to reply to threads 6 months after the thread is opened if there are more than 500 posts in the thread.
    Threads will not be locked, so posts may still be edited by their authors.
    Just start a new thread on the topic to post if you get an error message when trying to reply to a thread.

AnnieBody

Regular Contributor
Hi all.
Last year I purchased an ASUS RT-AX58U router with the intention of using this with XD4 nodes for whole house WiFi.
Because of delays in rolling out XD4 (ASUS blame Covid) I have only just been able to get my hands on the XD4 devices.
DO NOT MAKE THE SAME MISTAKE!
The first set of three I purchased had one router and two wireless repeater nodes.
I first set these up a stand-alone wireless system in accordance with the ASUS website instructions to see what I needed to so to use Aimesh.
This worked fine. Easy to use and setup. If you want to replace all your equipment then I would recommended this system, but ONLY if you don't have more than one ethernet device.

I then tried to setup the router as an AP to work as a backhaul connection with my existing router.
You can, but the gui doesn't allow you to change the IP address in this mode from 192.168.50.1 so it will not work with my existing network using 192.168.1.nnn.
To get over this you have to configure it as a router, change the IP address then change the IP address.
It now works with my existing router, sort of!

When trying to add the two wireless nodes I get all sorts of problems:
1. After each attempt the node would show green in the AiMesh list then disconnected.
2. The first one only got a wireless connection after five attempts and even then advised the signal was weak even though WiFi Analyser app had it 10dbm greater than my router.
3. Some repeated attempts dropped out the XD4 AP connection. Frustratingly, this has to be setup from scratch each time.
[I don't know why as according to ASUS published data the wireless node should be linking to my RT-AX58U router]
4. Under no circumstance was I able to add the second wireless node. Again with the AP connection regularly dropping out.
5. The RT-AX58U AiMesh gui does not list any of the devices in the Clients List. The XD4 does. I have no idea why?
6. ASUS provide reasons for the failure but they don't make any sense!
For instance if the device was not powered up then how does the gui first find it, then initially connect to it?

Even though they still worked as a stand-alone system ASUS technical support advised returning the devices as 'possibly faulty'.

On my second attempt I decided to purchase three routers as single devices in the hope that the router worked and the repeater node had the problems.
I have exactly the same issue.
Each one can be setup as an AP backhaul.
This time whatever node I configure as AP I cannot get one of the other devices to connect to AiMesh as a wireless device.
ASUS support have again advised returning them as 'possibly faulty', and have subsequently refused to acknowledge any further replies and questions from me.
It should also be noted that despite getting an email response in my email, you have to reply to then using the website login, which you can never do as the 'send' button does nothing!

I have since discovered that using reset on the node doesn't always work!
Resetting a node will result in either a flashing blue or continuous blue light depending upon how many times you want to press reset.
You also have to press reset at the right time or it will be ignored!
I have also discovered that trying factory reset from the gui will not work as whatever node I connect using the default address 192.1.68.50.1 the ASUS popup now advises the node is in AP mode when it clearly is not.
I use default address loosely as the ASUS Device Discovery doesn't always find the nodes and if it does advises tou cannot configure it as it is on a different subnet to my PC. It's not!
It appears that ASUS cannot determine the device's correct configuration.

I have greatly shortened the many hours of trying different things attempting to get a working system.
It appears to me that by getting a stand alone XD4 system working ASUS have failed to correctly apply the same principles to using these nodes with another of their routers listed as AiMesh compatible.
It is also clear that ASUS have no interest in getting the wireless devices working individually nor as an AiMesh system.
I have purchased an ASUS router with the intention of having whole house WiFi which I cannot have.
I have no doubts that ASUS will in time have to come up with a working solution, after all, their adverts are making statements they cannot meet; however, I have zero confidence this will actually happen and when.

My advice is not to make the same mistake as me.
Be patient and if you really want whole house WiFi with an AiMesh compiable router steer well clear of ZenWifi XD4!
 

AnnieBody

Regular Contributor
I found over 27 obvious software flaws, some minor which have escaped logical testing and some because they can never have been tested with the RT-AX58U router and XD4 devices.
The worst one is that when using the RT-AX58U AiMesh to connect to a XD4 node as a wireless repeater, the screen reports success, but the devices drop their WiFi after a few seconds.
As they no longer have WiFi they will never be able to connect to other AiMesh devices.
If you reset them you get a flashing blue mode which indicates they are attempting to join to AiMesh, but with NO WiFi signal will never be able to!
If you then connect them to your network you cannot access the gui as they are now configured as wireless devices with no wired capability!
So you have no factory reset option.
Tried this twice and both are now BRICKED!
ASUS are, as usual, not responding.
 

AnnieBody

Regular Contributor
I have found a way of factory resetting without the gui.
What a pity Asus wouldn't direct me or offer any assistance.

In accordance with ASUS policy, the website at:
https://www.asus.com/support/FAQ/1039078
details an incorrect procedure. Maybe one day ASUS will be able to get something right!

The XD4 does not have a power button as described! Instead I found that the following worked:
1. Power off the repeater.
2. Press and hold the 'WPS' button while powering on.
3. Keep pressing the 'WPS’ button until the led turns off.
4. Turn off the repeater.
5. Wait for thirty seconds
6. Power on the repeater.
7. Wait for it to settle to a continuous blue with a WiFi signal.

NOTE: The repeater has been factory reset to the default IP address 192.168.50.1.
 

fdisker

New Around Here
My experience with the XD4 system has been extremely positive, although unlike you I'm running them as a stand alone system (1 router, 2 nodes connected via wired backhaul). The system supports 10 wired devices and almost 40 wireless devices (when the kids are home). All wireless devices seamlessly roam between the nodes as we move through the house. Throughput of my wireless AX devices is strong. I have a PC using an ASUS wireless AX adapter that pushes over 900mbit to a wired pc in the basement. I got the system on sale for 229 and couldn't be happier with it.
 

AnnieBody

Regular Contributor
As I have stated, the XD4 devices will ONLY work in the configuration you are using.
However, if you review the advertised functionality of AiMesh components advertised on ASUS websites you will see that they make statements regarding the list of devices that are AiMesh compatible. My router being one of them, which is why I purchased it.
Apparently, at the moment, you cannot use any of the devices listed as AiMesh compliant in an AiMesh configuration. It appears that you will not be able to until ASUS are able to write working software.
I would be interested to know how your devices are connected, as one of the problems I found was that the XD4 in stand alone wireless router mode cannot find any wireless devices due to the software not having a client list tab for wireless devices. If I run my RT-AX58U router then I have many wireless devices, if I then swap to the XD4 in wireless router mode it has none. I get the same thing for three separate XD4 routers.
Would you be willing to change your configuration (using the latest firmware) to a stand alone wireless router (with no AiMesh nodes connected) and confirm if you still have your wireless devices connected to it in this configuration?
 

fdisker

New Around Here
I can test that configuration for you but it's not something I can do now. I'm an IT professional who works from home so no network changes during business hours. Due to the amount of streaming by the wife and kids I'd need to wait until the house is empty so it may be several days until I can test. I'll post back here when it's done.
 

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top