Access modems behind ASUS router (Dual WAN)

  • ATTENTION! As of November 1, 2020, you are not able to reply to threads 6 months after the thread is opened if there are more than 500 posts in the thread.
    Threads will not be locked, so posts may still be edited by their authors.
    Just start a new thread on the topic to post if you get an error message when trying to reply to a thread.

matt002

Occasional Visitor
Hello all,

I am having a problem which I cannot understand in regards to DUAL WAN on my ASUS AC88U Router.

I have two LB2120 4G modems. They run together feeding into a dual WAN setup on my ASUS router.

Now both connect to the router fine, working in load balancing mode on the ASUS router and providing internet, however I am unsure on the IP settings. I basically want to be able to view both LB2120 modem interface pages right from the ASUS router. However, I can only ever access one of the modems at a time. The other has to be off or disconnected, they cannot both be on simultaneously.

LB2120 Modem One = IP: 192.168.5.1. Subnet: 255.255.255.0

LB2120 Modem Two = IP: 192.168.4.1 Subnet: 255.255.255.0

ASUS Router: IP: 192.168.1.1 Subnet: 255.255.255.0 Gateway: 192.168.1.1

If I turn off one of the LB2120, I can always access the other by typing in the modem IP. If both are on at the same time, only one is ever accessable, not both. I thought having changed the IP's so they dont conflict outside the subnets, this would work.

Both LB2120 are set in bridge mode and connected via LAN cables to the dual WAN ports on the ASUS router.

Any ideas or advice please?



Matt
 

eibgrad

Very Senior Member
Just out of curiosity, try placing them on the *same* network, but w/ different IPs (e.g., 192.168.5.1 and 192.168.5.2).

I know, doesn't really make sense since it's over two different WANs, but I'm out of ideas.
 
Last edited:

ColinTaylor

Part of the Furniture
Both LB2120 are set in bridge mode...
Taking this at face value it would imply that the router doesn't know specifically how to reach either of those devices and will therefore always try to use the default route.

So my understanding (because I've never tried this) is that you need to create static routes so the the router always knows which interface it needs to use to reach each device. Something like this:

Untitled.png
 

matt002

Occasional Visitor
Hi both

Thanks very much for your replies. I've tried both suggestions to no avail. Same issue as before, can only ever connect to one of them unless the other is turned off.

At a loss, any further ideas?
 
Last edited:

ColinTaylor

Part of the Furniture
Can you post the routing table (System Log - Routing Table) for when both modems are active.
 

matt002

Occasional Visitor
Can you post the routing table (System Log - Routing Table) for when both modems are active.
Hi Colin, thanks for not giving up on me!

IPV4 below, no entries for IPV6.

IPs 94.xxx is WAN 2, 100.xxx is WAN 1


DestinationGatewayGenmaskFlagsMetricRefUseIface
IPv4 Routing table
94.197.217.1*255.255.255.255UH000WAN
100.73.159.1*255.255.255.255UH000WAN
192.168.1.0*255.255.255.0U000LAN
94.197.217.0*255.255.255.0U000WAN
100.73.159.0*255.255.255.0U000WAN
default100.73.159.10.0.0.0UG000WAN
 

matt002

Occasional Visitor
Another point I forgot to mention, I have manually routed my devices to either WAN 1 or WAN 2 in the routing rules, example as follows. Cannot see how this would make much difference though as both WAN connections work perfectly.

192.168.1.1/25allPrimary WAN
all192.168.1.1/25Primary WAN
192.168.1.130allSecondary WAN
all192.168.1.130Secondary WAN


After adding the additional two rules as suggested in your post above Colin, devices on WAN 2 no longer had internet access (nor could both modem interfaces be accessed simultaneously as per my original issue). In other words it just made the situation worse.

Look forward to hearing from you,

Matt
 

ColinTaylor

Part of the Furniture
Your routes don't seem to make sense to me (but I may not be understanding how Asus have implemented this). Static routes define outgoing paths not incoming.

So if I understand what you're trying the achieve in your table above you only need rules 1 and 3. Devices with addresses 192.168.1.1 to 192.168.1.127 go via WAN1, 192.168.1.130 goes via WAN2, and everything else is load balanced between both.
 
Last edited:

matt002

Occasional Visitor
Your routes don't seem to make sense to me (but I may not be understanding how Asus have implemented this). Static routes define outgoing paths not incoming.

So if I understand what you're trying the achieve in your table above you only need rules 1 and 3. Devices with addresses 192.168.1.1 to 192.168.1.127 go via WAN1, 192.168.1.130 goes via WAN2, and everything else is load balanced between both.
Yes - correct indeed.

In actual fact I was merely following the below guide as ASUS load balancing is trash in my experience so far. Hence why I have forced devices to use WAN 1 or WAN 2 to maximise bandwidth.


Do you think that this is causing the modem interface issue then?
 

ColinTaylor

Part of the Furniture
I think that guide is wrong. As a test I suggest that you remove rules 2 and 4 and then verify that it still works as expected.

I'm not sure how you would formulate rules that allow access to the modems that didn't create a routing conflict. Apart from 192.168.1.130 do you have any devices in the 192.168.1.128-254 range?
 

matt002

Occasional Visitor
Hi Colin

Thanks again for your reply.

So removed those rules and all looks fine still, no issues yet so I think you are right there.

Sadly the main issue still exists but I think I understand the logic why now. Correct me if I am wrong?

I am on my PC which is using WAN 1 to try connect to the modem on WAN 2. This fails. I can however access modem 1 fine - makes sense to me. Now when I disconnect WAN 1, my PC has no option but to use WAN 2, and then I can connect to the modem interface. Could that be the reason overall?

One thing to throw that theory out though is when I had dual WAN with ADSL modem & LTE modem, both could be connected to at any time from my PC. The issue seems to have occurred since I use exact same model modems on each WAN connection.

Bit lost for ideas now....

I have a few devices between 192.168.1.128-254. These are all static devices assigned to WAN 2 like the 192.168.1.130 example above
 

ColinTaylor

Part of the Furniture
If your previous modems were actually routers it would make sense that you could access them. But as your current devices are in bridge mode it makes accessing them more difficult.

I think for each "half" of the subnet you would need a rule that explicitly defined the route the other modem. So for example:
192.168.1.1/25192.168.4.1Secondary WAN
192.168.1.128/25192.168.5.1Primary WAN
192.168.1.1/25allPrimary WAN
192.168.1.130allSecondary WAN
Whether this will work or not I have no idea.
 

matt002

Occasional Visitor
Thanks Colin

Will give it a try.

I can actually set the modems to router mode if this would be easier? Reason I havent is dont really know what IP/Subnets etc I should be entering for each. Is this a potential option also?
 

matt002

Occasional Visitor
Sadly didnt work... good suggestion though.

Maybe setting both modems to router mode would be the solution then. Can you give some steer on IP settings if you dont mind advising please? Got to be worth a shot I guess.
 

ColinTaylor

Part of the Furniture
Sadly didnt work... good suggestion though.
:(
Maybe setting both modems to router mode would be the solution then. Can you give some steer on IP settings if you dont mind advising please? Got to be worth a shot I guess.
Assuming your modems will be using the same IP addresses as before I'd guess there shouldn't be any need to do anything special. Just have it like so -
192.168.1.1/25allPrimary WAN
192.168.1.130allSecondary WAN

If that doesn't work then hopefully someone else that has experience with this can help. As I said, I don't use Dual-WAN so I'm having to guess what Asus might be doing behind the scenes.
 

matt002

Occasional Visitor
Hi Colin

Thanks very much, that worked and both modems are now accessable. Only problem is my ASUS DDNS no longer works because I'm in a double NAT environment.

Interestingly when I change the DDNS method to external it says registration successful. However the router is still not accessible through the DDNS link.

Is there any workaround you know of? I've searched the forums here briefly but all the threads I can't relate to.

I use the asus ddns server
 

matt002

Occasional Visitor
Hi Colin

So sorry, bit confused here.

1. Change DDNS method to external in the ASUS router
2. Add DMZ for the router 192.168.1.1
3. Go into the modems WAN1 & WAN2 and add port forwarding.

Stuck on the port forwarding bit. What IP? Presumably in the modem it would be the network assigned IP given to the ASUS? In addition what ports? 80?

Any further detail would be most appreciated. Thanks again for all your help
 

ColinTaylor

Part of the Furniture
What are you trying to access and how?

How consistent are the public IP addresses you are now getting on each of your modems? In post #6 one of your modems had a 100.73.x.x address. This is a CGNAT address so it would be impossible to remotely access your Asus via this modem. You would probably only be able to access the Asus via one of the modems anyway, and I'm assuming that will have to the one configured as the "primary".
 
Last edited:

matt002

Occasional Visitor
Sorry Colin, should have been more specific.

The ASUS DDNS seems to work ok, in that if I type in the DDNS address, it will bring up the modem on WAN2 DNS error page. This means the DDNS is redirecting to my public IP on the primary WAN fine.

This would assume the issue lies in not being able to forward to the ASUS router.

So I setup a port forward on the WAN 2 modem as follows:

TCP / Port 80 / 192.168.4.20 (IP assigned by the modem to ASUS router)

This however produces no result. So the issue is how to get the DDNS to redirect to the actual ASUS router.
 

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top