1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
Dismiss Notice

Welcome To SNBForums

SNBForums is a community for anyone who wants to learn about or discuss the latest in wireless routers, network storage and the ins and outs of building and maintaining a small network.

If you'd like to post a question, simply register and have at it!

While you're at it, please check out SmallNetBuilder for product reviews and our famous Router Charts, Ranker and plenty more!

AiMesh - disable 2.4GHz on nodes?

Discussion in 'ASUSWRT - Official' started by Volfi, Oct 16, 2019.

  1. Volfi

    Volfi Regular Contributor

    Joined:
    Jan 13, 2018
    Messages:
    69
    I would like to disable 2.4GHz Wifi on my node (AC86U). Main router (AC88U) should have it though. Can connect via SSH, and tried this:


    Code:
    wl -i wl0.1 down
    wl -o wl0.1 radio off
    nvram set wl0.1_radio=0
    nvram set acs_ifnames="wl1.1"
    nvram commit
    service restart_wireless
    However, node is not accesible after that.

    wl0.1 = 2.4GHz
    wl1.1 = 5GHz

    Any hints how to achieve this?
    Not sure why, but 2.4GHz devices connected to node do not work very well, disconnect often. Think this is AiMesh bug, but as I cannot solve this firmware bug, at least I tried to switch 2.4GHz on nodes off.
     
  2. Grisu

    Grisu Part of the Furniture

    Joined:
    Aug 28, 2014
    Messages:
    2,690
    isnt wl0.1 first guest on 2.4G?
    nvram set wl0_radio=0 should do it what I can remember.

    Dont know what acs_ifnames="wl1.1" is good for, never used this, better leave it.
    Nor do I know what the first both lines wl -i wl0.1 down and wl -o wl0.1 radio off shall do, let them as previous too.
     
  3. Volfi

    Volfi Regular Contributor

    Joined:
    Jan 13, 2018
    Messages:
    69
    No, wl -i wl0.1 status gives me 2.4GHz Wifi. Also wl0.1_ssid points to correct (2.4GHz) SSID.
     
  4. Volfi

    Volfi Regular Contributor

    Joined:
    Jan 13, 2018
    Messages:
    69
    Actually, you might be right :)
    Doing this simple stuff keeps node connected, and switches off 2.4GHz on it :)

    Code:
    nvram set wl0_radio=0
    nvram commit
    service restart_wireless
     
  5. Grisu

    Grisu Part of the Furniture

    Joined:
    Aug 28, 2014
    Messages:
    2,690
    I know ... only you who didnt believe ;)
     
    Volfi likes this.
  6. Phi Tran

    Phi Tran New Around Here

    Joined:
    May 27, 2019
    Messages:
    5
    Thank you! This works for me. 2.4Ghz seems to give my devices trouble too.
    However, the node refuses to reconnect after a reboot. It seems it needs 2.4GHz to initiate the connection. Does your router work fine after reboot?
     
  7. Grisu

    Grisu Part of the Furniture

    Joined:
    Aug 28, 2014
    Messages:
    2,690
    dont have them it any more, sorry cant help with this.
     
  8. Volfi

    Volfi Regular Contributor

    Joined:
    Jan 13, 2018
    Messages:
    69
    @Phi Tran - have this problem as well.
    I gave up on AiMesh and am running "node" in repeater mode, changing repeater's 2.4GHz SSID to other name, so that legacy devices do not connect to it.
     
  9. Phi Tran

    Phi Tran New Around Here

    Joined:
    May 27, 2019
    Messages:
    5
    I gave up on this AiMesh for a while too. This thread gave me hope, but the reboot problem shuts down this last hope. Oh well, back to none AiMesh again.
     
  10. Volfi

    Volfi Regular Contributor

    Joined:
    Jan 13, 2018
    Messages:
    69
    AC86U, used as an extender, has no problems when 2.4GHz is disabled via SSH.