What's new

Any help would be nice ! Download speed half the upload speed

  • SNBForums Code of Conduct

    SNBForums is a community for everyone, no matter what their level of experience.

    Please be tolerant and patient of others, especially newcomers. We are all here to share and learn!

    The rules are simple: Be patient, be nice, be helpful or be gone!


New Around Here
So here is whats going on.

I have a r7800 netgear router acting as a wifi router and as a gateway from my ONT box.

I have a 1gbps connection.

Anytime i run a speedtest on my wired connection i always get 800 minimum down and 750 minimum up
Thats fantastic and I am happy with that.

The issue is the wifi. The issue can be replicated on both my sufaceboom and iphone x. And an iphone 8

Standing next to the router on a 5ghz connection i consistently get 280 down and 600 up.

Why is the upload always twice the download.

We know its not a bandwidth issue because on a wired connection speeds are hitting 800 at least. We know the iphone is not the bottleneck because it acheives the correct upload speed.

I have tried toggling QOS on and off. Same with beamforming same with ht160 and changing channels on the 5hz network. Nothing seems to fix this. I am on the lastest software update.

I am tearing my hair out trying to solve this bullsh*t any real help is appreciated
Last edited by a moderator:
I've been hoping to read "the answer". I even studied the Tim Higgin's review, nothing (in fact his downs were slightly faster than ups).

You've already turned off QoS (and anything else that would disable hardware acceleration).

Interestingly Tim saw about 280 Mbps up and down ... about what you're seeing for down. It wasn't until he started playing with 4 x 4 streaming MU-MIMO that he started seeing the 7 to 800 Mbps speeds you see (and, in both directions to boot).

Now I do not know much about MU-MIMO. It stands for Multiple Users - Multiple Inputs/Multiple Outputs. Just as a wild butt guess it sounds like you're getting Multiple Outputs but only a Single Input? Maybe a call to Netgear Tech Support?

[Just as an aside we have 400 x 20 Mbps at work. None (save for one) of our devices, even wired laptops and desktops get the 400; it's more like 200 to 300. We've only one beefed up PC (e.g., cost more than $250 : -); that one gets the full 400.]​
Last edited:
This occasionally happens to me. A reboot of the router and the modem (keeping it off for a few minutes to get a new IP) usually sorts it out. YMMV.

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!