Asus AX58U - W10 can't see my SMB share

  • ATTENTION! As of November 1, 2020, you are not able to reply to threads 6 months after the thread is opened if there are more than 500 posts in the thread.
    Threads will not be locked, so posts may still be edited by their authors.
    Just start a new thread on the topic to post if you get an error message when trying to reply to a thread.

RR2

New Around Here
Hello to all.

I have the following strange problem with my Asus AX58U when trying to connect to it via SMB protocol on Windows 10:

1. If I go to USB Application - Network Place (Samba) Share / Cloud Disk and set the Allow guest login to ON , the SMB share appears in my Network Neighborhood and is fully working , but it really bothers me the exclamation mark in the router page.
2. From the same menu, If I set the Allow guest login to OFF, the SMB share doesn't work, and it doesn't appear anywhere, no matter what I do.

I already followed https://www.asus.com/support/FAQ/1037477 guide...

What am I missing here ?
 

Ronald Schwerer

Very Senior Member
I just started getting this (router not showing up in File Explorer Network places). I think a recent update screwed this up. Anyway, I think I've got it working - or at least a workaround.
  1. Open File explorer. Click "This PC". Then "Add Network Location", "Next", "Next". Should see "Specify the location of your website"
  2. Start to fill-in the browse location with the path to your router... example \\192.168.1.1\ then click Browse.
  3. You should see a list of mount points shared by your router. Select one and click "OK", then "Next". Customize the name if you like, then "Finish"
  4. I was once asked for login info. I used the admin login/password, but it might be possible to use other share credentials created for sharing on the router. I've mapped a drive on a node using the old default admin/admin.
  5. Don't forget to have Windows save the credentials so it doesn't ask every time you attempt to open the drive/partition. BTW, my router's SSD has 3 partitiions, 1 NTFS and 2 EXT4. I have to map each partition using the above procedure.
This maps the drive(s) under "This PC", "Network Locations"
 
Last edited:
  • Like
Reactions: RR2

JarekS2000

New Around Here
Hi would like to bump this up.
I also have the same problem.
Attached a 4tb usb drive to AX88u
It works fine when I have it set up to allow guest access without authorization
I can see the router/drive in Win10 explorer
As soon as I turn guest access off, cannot connect.
I even tried creating a new user/password with r/w permissions and still cannot log in.
I tried the suggestion above, i get as far as the same login page that I would get just by clicking on the router in file explorer, same result
cannot authenticate.
firmware 384_9579

thanks for any suggestions

I also have an older machine with win7 and same issues
 

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top