What's new

Asus Router OpenVPN Server Can't Access LAN

  • SNBForums Code of Conduct

    SNBForums is a community for everyone, no matter what their level of experience.

    Please be tolerant and patient of others, especially newcomers. We are all here to share and learn!

    The rules are simple: Be patient, be nice, be helpful or be gone!


New Around Here
Hi, I am trying to setup an OpenVPN Server on my Asus RT-AX56U running Asuswrt-Merlin 388.2_2. I have setup the server and can connect from my client, however I am unable to access any devices on the LAN. This includes the router itself, I can not ping nor can I navigate to the web GUI at that address.

I have trawled through dozens of forum posts both here and elsewhere, and attempted almost every proposed fix that I could find, with no luck. Weirdly, I had the server up and running without issue on the stock Asus firmware, however since moving to Merlin this issue has persisted. Below is a photo of my OpenVPN configuration (with the server port removed, but it is configured usually):


I've seen similar issues where the user was able to access the router itself once connected to the VPN but no LAN devices behind that, in my case I'm unable to ping or otherwise access anything including the router.

To save everyone some time and effort, here is a list of things I have attempted in order to resolve the issue. All of the attempted resolutions below have since been reverted so if the proposed solution is one of the following PLUS something else, please let me know so that I can reconfigure correctly :)

  • Changed the "Client will use VPN to access" setting from "Lan Only" to "Both"
  • Set "Manage Client-Specific Options" to "No"
  • Disabled static routes
  • Added
    push "route"
    to my OpenVPN custom config
  • Disabled AIProtection
  • Disabled router's firewall entirely
  • Enabled ping router from WAN
  • Enabled "Advertise DNS to Clients"
Any help would be much appreciated as I am well and truly stumped. I've tried everything I can think of, and I've tried to replicate my stock Asus firmware settings that were working prior, however nothing has worked.
Welcome to the forums @ozza1511.

If you did not perform a full reset to factory defaults after flashing the RMerlin firmware, without using a saved backup config file, and without minimally and manually configuring the router to secure it and connect to your ISP, then you need to do so now.


Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!