Asus RT-AC88U w Merlin Ai Protect Blocking Netflix and other sites

  • ATTENTION! As of November 1, 2020, you are not able to reply to threads 6 months after the thread is opened if there are more than 500 posts in the thread.
    Threads will not be locked, so posts may still be edited by their authors.
    Just start a new thread on the topic to post if you get an error message when trying to reply to a thread.

bravesirrobbin

New Around Here
I've had an ASUS RT-AC88U router running Merlin software for over two years and am now having an issue with Netflix, Dark Sky Weather (iPhone), TurboTax Updates, and iPhone OS updates being blocked on all my devices (TV's, phones, computers).

I first thought this was a DNS issue and tried multiple settings (originally had the router point to Google's 8.8.8.8 and 8.8.4.4)

After troubleshooting including upgrading to the latest Merlin software, I found the issue was with the Ai Protection setting (left at default for all of these years). After I disabled this protection, everything is now working (see screen shot).

My question is, why now? I didn't see anything with Ai Protection as part of the firmware upgrades (present and in the past). Also, I'm concerned that this protection is now no longer active.

Has anyone else experienced this type of issue? Any advice would be greatly appreciated (obviously I'm not a network expert).

Thank you.
 

Attachments

  • asus ai protect.jpg
    asus ai protect.jpg
    116.7 KB · Views: 72

L&LD

Part of the Furniture
@bravesirrobbin welcome to the forums.

What firmware are/were you using, specifically? Was it recently updated before the issues appeared? What firmware was installed before this upgrade and were the issues present then?
 

bravesirrobbin

New Around Here
I had the issue on version 384.17 which was updated a while ago, but this issue started I would say a month ago.

I then updated to version 386.1 (most recent version) yesterday and the issue still persisted.

I have no other custom settings related to VPN, and Firewall settings and also turned off any type of DNS Filtering.

All devices are the default IPV4 settings (DHCP and all else 'Auto' detected)
 

ATLga

Senior Member
I had the issue on version 384.17 which was updated a while ago, but this issue started I would say a month ago.

I then updated to version 386.1 (most recent version) yesterday and the issue still persisted.

I have no other custom settings related to VPN, and Firewall settings and also turned off any type of DNS Filtering.

All devices are the default IPV4 settings (DHCP and all else 'Auto' detected)
8936 malicious site blocks from the one thing I can see in the screenshot is a HUGE amount. When you had it turned on, was it up to date on its signatures. It's in the administration, firmware upgrade; you'll see it there. Click it and let it check. Don't have any other ideas except a full reset of the router and configure from scratch not backup file.
 

L&LD

Part of the Furniture
Yes, that 384.17_0 version is quite old now.

But even if you didn't do one when you flashed that old firmware, and you didn't do one when you flashed the router to 386.1_0, then it seems like a reset is in order.

If the following 'Hard Reset' for your model doesn't get your network stable and afterward minimally and manually configuring the router to secure it and connect to your ISP (without using a saved backup file),

[Wireless] ASUS router Hard Factory Reset | Official Support | ASUS Global


Then hopefully the following link will get your router/network back to a good/known state.

Best Practice Update/Setup Router/AiMesh Node(s) 2021
 

bravesirrobbin

New Around Here
Thanks for the replies and advice.

I performed a hard reset on the router (held the WPS button in while turning power on according to the directions in the provided link above).

I manually re-configured the router. The only issue I'm now having is Netflix is still blocked when AiProtection is turned on. This is strange because everything else works.

I verified this is blocked both with my Samsung TV and Laptop.
 

L&LD

Part of the Furniture
If you're still on 384.17 from April of 2020, you may want to flash 386.1_2 to your router first, then follow the suggestions below to fully reset it.

Fully Reset Router and Network


If the router exhibits the same behavior afterward, it is either a hardware issue or something else on your network that is affecting the outcome.

Can you return/exchange it?
 

bravesirrobbin

New Around Here
I should have mentioned this in my previous post, but I did update the firmware to 386.1_2 before performing the factory reset.

I can connect with my Samsung TV to Netflix, but I have to disable AiProtection and DNS based filtering.
 
Last edited:

bravesirrobbin

New Around Here
Just an update. I reverted back to the stock Asus firmware (latest Beta version) and did a factory reset. All of my problems went away plus my wireless speeds are back up to where they should be (always wondered why wireless was so slow (20-30 mbps vs the 50 where up/down speeds should be at).

I've had the Merlin in my router for years, but there is something that happened to the last few versions where I noticed all the above problems mentioned.
 

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top