Entware Can't update Entware package Apache

minhgi

Regular Contributor
There was an update available Entware which I happen to update. However it is stuck trying to update apache in a loop. It constantly said there an update for it and it won't clear out when trying to update it. Does anyone have this problem.

1650033672749.png
 

minhgi

Regular Contributor
yeah..I was able to capture a screenshot of upgrade process. It went by so fast. Something about the package was flagged as being on hold and won't get update. Is there a command which can take the hold off.

1650042902676.png
 

laracroftonline

Regular Contributor
Try rebooting your router and update it again
 

SomeWhereOverTheRainBow

Part of the Furniture
Ah..that did the trick. Ran the code and reran the update script. The update went smoothly afterward. Thanks Dave.
I hope you know now it created the init.d script, which means you have will have apache webserver capable of running as a background process on next reboot. unless you delete (/opt/etc/init.d/S80apache).

Short-story-long for AdGuardHome installer to setup password for adguardhome, the htpasswd is required. The only way to get it is to install apache-utils which subsequently installs apache websever (a requirement to have the apache-utils installed). Well to prevent the " apache webserver" from actually becoming a webserver, it becomes necessary to remove the init.d start script and put those particular packages on hold to prevent their update (which as you guessed, recreates the init.d script.), setting it to user doesn't prevent this or hide the fact that it is installed, the update simply proceeds.
 
Last edited:

worf105

New Around Here
I followed Dave's instruction to allow the updates to complete, and they did just fine. Can here to see if they are any follow-ups and read your post. I have now deleted /opt/etc/init.d/S80apache and rebooted. All looks OK with system. Is this what is required to stop the unwanted web server running.
 

gattaca

Senior Member
^^^ We certainly don't want apache web running by default! If I'd not been following, I would have missed this caveat! That default behavior sure feels like an added security exposure most AMTM users are not going to want... Or maybe I missed some point?

...based on below comments, I'm waiting another day or so before performing this upgrade... so I think hopefully, I won't see the apache 2 package issue... which would probably occur repeatedly with each update? THANKS so much for a much-improved route!!!
 
Last edited:

SomeWhereOverTheRainBow

Part of the Furniture
The obvious flaw is in order to prevent future Apache updates (a.k.a creation of the S80apache) I had to put the package on hold. I need to find some other means of preventing its upgrade. Is there away to remove it from the list entware uses to know whether something is installed? maybe this would be a better fix. I am honestly not sure though. The original method I used was to compile Bcrypt-tools using entwares go-package, but this was to inefficient for most users. now the apache package being on hold has created another delimma. I may just compile and upload the Bcrypt-tools binaries myself and see how that goes.

I got a solution. Taught myself how to use python3-bcrypt. Should eliminate most of this struggle.
 
Last edited:

SomeWhereOverTheRainBow

Part of the Furniture
I followed Dave's instruction to allow the updates to complete, and they did just fine. Can here to see if they are any follow-ups and read your post. I have now deleted /opt/etc/init.d/S80apache and rebooted. All looks OK with system. Is this what is required to stop the unwanted web server running.
yes that is correct, you would have to remove the S80apache, (or add ENABLED=no to the file). Easier just to delete it.
 

JemTheWire

Senior Member
Thanks all for you advice regarding my entware update issue. I ran ‘opkg flag user apache apache-utils’ as requested, and all in now well.

Thanks very much.
 

JemTheWire

Senior Member
Thank you, I had. Now sorted. Thanks again.
 

JTnola

Occasional Visitor
Ummmm … isn’t this whole reason those two packages are marked “hold” — aka, to stop people from updating them, since, by updating them, you create this other problem?

i feel like the process that y’all have described above is the equivalent of removing a speed limiter from a go kart …:

“Hey, did y’all notice that no matter how hard you push on the accelerator, the go cart won’t allow you to push the engine to its full capacity and you can’t reach the dangerous top speeds it’s design should allow it to reach?”

» “Oh yeah—someone put a limiter on it. It’s limiting us. Take it off so there’s no limits. But be sure to be a qualified driver if you take it off—it’s easy to remove the limiter, but driving at top speeds takes real skill.”

“Okay. I’ll remove the limiter and limit myself Since I’m not a professional driver.”

» “too bad there’s not some way to have the limiting done for you, for the majority of us who aren’t professional drivers.”
 

Jeffrey Young

Very Senior Member
In my opinion, the real fix is for Entware packages to check to see if init.d scripts exist or have been altered from the default, and if so, either ask what to do with the script or create a warning and leave the original script/make a copy of the install script in a safe place. Entware packages have gotten better at not rewriting various conf files during upgrade, but they still insist on scrapping any custom changes to the init.d scripts. I have a couple of custom init.d scripts (mostly as the software expects root user as opposed to the router user name, etc.). On every update, I need to backup my init.d scripts/various conf scripts first, run updates, then go back and fix everything.

OK, that is my rant for the day. @SomeWhereOverTheRainBow, great work on this scripts and thanks for introducing a good work around for now.
 

Similar threads

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top