Unbound Entware+386.3

  • ATTENTION! You'll notice a Prefix dropdown when you create a thread. If your post applies to one of the topics listed, please use that Prefix for your post. When browsing the thread list you can use the Prefix to filter the view.
  • ATTENTION! As of November 1, 2020, you are not able to reply to threads 6 months after the thread is opened if there are more than 500 posts in the thread.
    Threads will not be locked, so posts may still be edited by their authors.
    Just start a new thread on the topic to post if you get an error message when trying to reply to a thread.

MatteoPV

Senior Member
I am using GNUton 386.3 on Asus DSL AC 68 U. Everything was fine, but yesterday Entware updated and since then Unbound doesn't work anymore, besides the router does strange things, it seems unstable, at startup it disconnects the wifi which it did not do before. before updating Entware it was fine
 

Adooni

Senior Member
this is the reason we do not have auto Entware update. It is better do not upgrade it if not needed. Now you will need to downgrade it what is a pain (each module need to be done separately) and very often it is faster to do it from 0. Challenge is that you know something is wrong with latest Entware and need to try find alone or what for someone to investigate.

thx for posting I hope more people will read it and will not upgrade Entware at this point.
 

Jeffrey Young

Senior Member
Don't count on it. Entware packages do not always look at any current configuration and simply install defaults. With every update, I have to go in and replace the configs with my custom ones (wireguard, nut, samba). Entware just slaughters them on update. I always keep backups and am ready to replace my configs as I know what is coming.
 

John Fitzgerald

Senior Member
I am using GNUton 386.3 on Asus DSL AC 68 U. Everything was fine, but yesterday Entware updated and since then Unbound doesn't work anymore, besides the router does strange things, it seems unstable, at startup it disconnects the wifi which it did not do before. before updating Entware it was fine
The best way to go about it with regards to Unbound is to STOP Unbound, update Entware, then run 1 Update for Unbound.
The last step should restart Unbound automatically. If not then restart manually. I also do a router reboot on the end.
 

MatteoPV

Senior Member
The best way to go about it with regards to Unbound is to STOP Unbound, update Entware, then run 1 Update for Unbound.
The last step should restart Unbound automatically. If not then restart manually. I also do a router reboot on the end.
I tried to force the Unbound update but then it gives me an error and it doesn't work
 

John Fitzgerald

Senior Member
I tried to force the Unbound update but then it gives me an error and it doesn't work
Maybe another script is making for the headache, just UNINSTALL and REINSTALL UNBOUND. In the end it's faster with less drama. I've had to do it this way multiple times when a hiccup makes it way in that won't resolve.
 

heysoundude

Very Senior Member
The best way to go about it with regards to Unbound is to STOP Unbound, update Entware, then run 1 Update for Unbound.
The last step should restart Unbound automatically. If not then restart manually. I also do a router reboot on the end.
This is The Way...
I wish I had read this post prior to updating entware by rote when amtm notified me, but selecting option 1 in the unbound manager did indeed restart and update the config and Presto! unbound is working. Lost my stats, but meh...they'll repopulate before Merlin releases 386.4
 

langesgnu

Occasional Visitor
I just found this thread and I have similar issues with unbound on an AC88U with 386.3. I do not know if Entware was updated, however unbound was not running anymore for the last week. I tried to update it, and afterwards (as suggested above) uninstalled it completely and tried to reinstall. In both cases I got this error message:

UPDATEing unbound
***ERROR occurred updating Entware package list

Anything that can be done to install unbound again?
 

ryzhov_al

Very Senior Member
Don't count on it. Entware packages do not always look at any current configuration and simply install defaults. With every update, I have to go in and replace the configs with my custom ones (wireguard, nut, samba). Entware just slaughters them on update.
Please, fell free to report about issues you've found, it's quite easy to fix.
We can't to test upgrade on all existing packages, sorry.
 

ebalsumgo

Regular Contributor
by chance are you getting Segmentation faults? I just upgraded to 386.3_2 and all of a sudden everything in Entware is segfaulting
 

langesgnu

Occasional Visitor
after playing a bit and searching through various threads it seems that something in the entware packages is broken and there are segmentation faults. When I try to updated entware the following happens:

Package ca-bundle version 20210119m1 has no valid architecture, ignoring.
ERROR: truncating field 8 <0xf1000> to 4 bytePackage libqrencode version 4.1.1-1 has no valid architecture, ignoring.
Segmentation fault
Package ca-bundle version 20210119m1 has no valid architecture, ignoring.
ERROR: truncating field 8 <0x30ff50> to 4 bytePackage libqrencode version 4.1.1-1 has no valid architecture, ignoring.
Segmentation fault

and probably because of that, I am not able to re-install unbound again. anyone has an idea what can be done here? Or can I really just report the issue and wait?
 

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top