Entware Transmission with proxy

Sptz

Occasional Visitor
Hi everyone,

I've been using Transmission after installing amtm -> Entware and I've noticed in the config file that there's no mention of anything proxy related. I wanted to use this through a proxy from my VPN. Is there a way to do that? Or any other, possibly easier way, to route just this specific pkg through VPN?

Thanks!
 

SomeWhereOverTheRainBow

Very Senior Member
Hi everyone,

I've been using Transmission after installing amtm -> Entware and I've noticed in the config file that there's no mention of anything proxy related. I wanted to use this through a proxy from my VPN. Is there a way to do that? Or any other, possibly easier way, to route just this specific pkg through VPN?

Thanks!
This is a very good question, as I also run transmission locally. I have always pondered this same line of thought.
 

Sptz

Occasional Visitor
This is a very good question, as I also run transmission locally. I have always pondered this same line of thought.
Apparently Transmission has deprecated proxy support which is worrying. Is there a way to route transmission to tunnel through OpenVPN within the router? So, have ONLY Transmission itself tunneled whilst everything else goes through WAN as normally.
 

Martineau

Part of the Furniture
Apparently Transmission has deprecated proxy support which is worrying. Is there a way to route transmission to tunnel through OpenVPN within the router? So, have ONLY Transmission itself tunneled whilst everything else goes through WAN as normally.
Transmission via VPN Client
Doesn't sound dubious at all?:cool:;)
 

Sptz

Occasional Visitor
Transmission via VPN Client
Doesn't sound dubious at all?:cool:;)
Thank you so much!! It's working now, there's only one issue. I don't want to post there as it's a necrothread so you or someone might have an idea?

Basically the Port 51413 is now showing as Closed in Transmission RPC settings. Where as before this it was Open so it's having a harder time finding a broader range of peers.

I already had this in the /jffs/scripts/firewall-start

Code:
iptables -I INPUT -p tcp --destination-port 51413 -j ACCEPT
iptables -I INPUT -p udp --destination-port 51413 -j ACCEPT
I added after that:

Code:
ifconfig br0:0 192.168.1.10 up
Is this an expected behavior due to using OpenVPN? Or is there something I'm missing?

Thanks
 

Martineau

Part of the Furniture
Thank you so much!! It's working now, there's only one issue.

Basically the Port 51413 is now showing as Closed in Transmission RPC settings. Where as before this it was Open so it's having a harder time finding a broader range of peers.

Is this an expected behavior due to using OpenVPN? Or is there something I'm missing?
Most VPN ISPs prohibit unsolicited P2P torrents.
So you may only run Transmission as a passive rather than as an active peer via the VPN.
 

Sptz

Occasional Visitor
Most VPN ISPs prohibit unsolicited P2P torrents.
So you may only run Transmission as a passive rather than as an active peer via the VPN.
I'm using NordVPN which I thought allowed P2P as it states on their website. I've tried changing to another server and still the same thing. Could this have anything to do with the boot up order? Or even, as I stated above in the firewall-start config having the IP aliasing after the port? Could that have anything to do with it?

Since this is a port that is supposedly being whitelisted in the Firewall of the router, shouldn't say Open regardless?
 

Martineau

Part of the Furniture
I'm using NordVPN which I thought allowed P2P as it states on their website. I've tried changing to another server and still the same thing.
upload_2020-1-15_18-6-50.png


Since this is a port that is supposedly being whitelisted in the Firewall of the router, shouldn't say Open regardless
Well as the above is nearly 18-months old they may have in the interim changed their stance, but you could ENABLE the recently added VPN Client feature

upload_2020-1-15_18-18-12.png


but if unsolicited inbound access is being blocked by NordVPN, then the router's firewall rules won't even see the requests.

P.S. I believe NordVPN states they are 'P2P friendly' which is technically true.



 

Sptz

Occasional Visitor
View attachment 20868



Well as the above is nearly 18-months old they may have in the interim changed their stance, but you could ENABLE the recently added VPN Client feature

View attachment 20873

but if unsolicited inbound access is being blocked by NordVPN, then the router's firewall rules won't even see the requests.

P.S. I believe NordVPN states they are 'P2P friendly' which is technically true.



I just bought one month of Mullvad which supposedly supports port opening. Followed the guide here: https://mullvad.net/en/help/asus-merlin-and-mullvad-vpn/

Changed the ports in Transmission and firewall as well etc. Nothing, even with inbound firewall ON. Transmission still reports the now provided port by Mullvad as Closed.

Update: Needed a reboot! It's now fully working!
 
Last edited:

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top