What's new

Fing showing DHCP Proxy WPAD error running Merlin 388.1 on RT-AX86U

  • SNBForums Code of Conduct

    SNBForums is a community for everyone, no matter what their level of experience.

    Please be tolerant and patient of others, especially newcomers. We are all here to share and learn!

    The rules are simple: Be patient, be nice, be helpful or be gone!

jjones7791

Occasional Visitor
This is a longshot and apologies if this isn't the right group, but figured since I'm running Merlin it would work.

I use an application called Fing for network monitoring, basic stuff for the most part. However it has one check related to DHCP Proxy WPAD that is saying I have vulnerability, but I can't for the life of me figure out how or why this is showing. I don't use proxies on my network, so it seems this shouldn't be an issue. I'm really not sure at this point if it has anything to do with the router, as it may be a bug in the Fing software, but throwing it out there in case anyone has any ideas around this. I'm addressing this with Fing as well, but figured it won't hurt to ask for advice here. Thanks!

1675181664277.png


1675181718418.png
 
Does it give any more details as to what it thinks the problem is?

There is already protection against this WPAD vulnerability. You can check that it's enabled with this command:
Code:
# grep wpad /etc/dnsmasq.conf
dhcp-name-match=set:wpad-ignore,wpad
dhcp-ignore-names=tag:wpad-ignore

There's also an option in the GUI that can be toggled depending on which version of Windows you're running.

Tools - Other Settings > Advanced Tweaks and Hacks > dhcpd: send empty WPAD with a carriage return

@RMerlin Note the typo in the above text. The router uses dnsmasq not dhcpd.
 
@ColinTaylor thank you very much! Exactly what I needed! Getting the results above. So long as it's blocked, that's good enough for me. I don't need it, just want to make sure I'm not leaving some vulnerability open.

Also edit to answer your questions:

Does it give any more details as to what it thinks the problem is?
No, nothing. I've even opened a ticket with Fing, and I know others have as well and they have yet to advise what is causing it, or as I've asked, what process or checks they are implementing that is coming to this conclusion. But with what you shared I'm wondering if it's just saying this because WPAD is not allowed, but they have yet to elaborate.

There's also an option in the GUI that can be toggled depending on which version of Windows you're running.

Tools - Other Settings > Advanced Tweaks and Hacks > dhcpd: send empty WPAD with a carriage return
I did try that option, but didn't have any effect unfortunately. And I've tried using the Fing agent on both Win 10 and 11 and it has no effect.


@RMerlin thank you as well! Been using your build for years and can't say thank you enough! Donation sent!
 
Last edited:
@RMerlin Note the typo in the above text. The router uses dnsmasq not dhcpd.
It's not a typo, more that I wanted to specify that this setting affected the DHCP daemon (most people would associate dnsmasq with DNS resolution). I will need to reword the whole sentence if I change that to dnsmasq to specify that this parameter is related to the DHCP daemon.
 
This is a longshot and apologies if this isn't the right group, but figured since I'm running Merlin it would work.

I use an application called Fing for network monitoring, basic stuff for the most part. However it has one check related to DHCP Proxy WPAD that is saying I have vulnerability, but I can't for the life of me figure out how or why this is showing. I don't use proxies on my network, so it seems this shouldn't be an issue. I'm really not sure at this point if it has anything to do with the router, as it may be a bug in the Fing software, but throwing it out there in case anyone has any ideas around this. I'm addressing this with Fing as well, but figured it won't hurt to ask for advice here. Thanks!

View attachment 47602

View attachment 47603

Did you ever find a way to get rid of that warning in Fing? I've disable WPAD in my Windows 11, Mac, and Ubuntu computers but I can't see an option to disable WPAD on the ASUS RT-AX88U, just the option dhcpd: send empty WPAD with a carriage return in Tools>Other settings
 
... but I can't see an option to disable WPAD on the ASUS RT-AX88U, just the option dhcpd: send empty WPAD with a carriage return in Tools>Other settings
I think that option is redundant now. What do you get if you do a nslookup wpad on the device running fing?

@RMerlin I don't think setting (or not) DHCP option 252 has any effect anymore. Since this addition a query for wpad always returns NXDOMAIN.
 
Last edited:
@RMerlin I don't think setting (or not) DHCP option 252 has any effect anymore. Since this addition a query for wpad always returns NXDOMAIN.
That's possible, I'd have to read more thoroughly what these ignore options do, compared to DHCP options which are what gets sent to clients at the time they request a lease.
 
... compared to DHCP options which are what gets sent to clients at the time they request a lease.
Ah, good point. I misremembered what the GUI option was for, to remove the noise coming from Windows 7 machines.
 
Last edited:
Did you ever find a way to get rid of that warning in Fing? I've disable WPAD in my Windows 11, Mac, and Ubuntu computers but I can't see an option to disable WPAD on the ASUS RT-AX88U, just the option dhcpd: send empty WPAD with a carriage return in Tools>Other settings
@Skeptical.me that setting you mentioned that Merlin has in Tools seemed to do the trick. After enabling I no longer get that warning. To be honest I didn't put too much stock in it since Fing was unwilling or unable to explain exactly what it meant and it never caused any issues, just more of an annoyance in Fing.

@ColinTaylor this is the output I get:

Code:
C:\Users\jeffr>nslookup wpad
Server:  RT-AX86U_Pro-69E0
Address:  192.168.50.1

*** RT-AX86U_Pro-69E0 can't find wpad: Non-existent domain
 
Thanks, that's what I would expect. Unfortunately I still can't guess what it is that Fing is complaining about.
Oh no, all thanks is to you and the other amazing folks that make this code happen, and support people like me. Every time I open an app on my phone and the ads are blocked, I smile a little more!
 

Similar threads

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top