YazFi guest network clients not using YazFi subnet

  • ATTENTION! You'll notice a Prefix dropdown when you create a thread. If your post applies to one of the topics listed, please use that Prefix for your post. When browsing the thread list you can use the Prefix to filter the view.
  • ATTENTION! As of November 1, 2020, you are not able to reply to threads 6 months after the thread is opened if there are more than 500 posts in the thread.
    Threads will not be locked, so posts may still be edited by their authors.
    Just start a new thread on the topic to post if you get an error message when trying to reply to a thread.

amoney

Occasional Visitor
Asus Router RT-AC88U: Merlin 386.2
AirMesh Node RT-AC68U: 3.0.0.4.386_41634-g08f88ae
YazFi: v4.2.0

Not sure when this started happening, i just happened to notice it after i applied the 386.2 update. What i found some times is that clients on guest network get the 192.168.1.0/24 subnet. YazFI is configured to use 192.168.2.0/24 (2.4GHz) and 192.168.5.0/24 (5GHz).

If i bound the client to the main router then it would get the correct subnet and ip on the device confirmed that (however the UI still shows the IP addr in 192.168.1.0/24 subnet.) and yazfi cli shows it as a connected client. If the client was bound to the airmesh node ip shown on the device was in 192.168.1.0/24 subnet and i could see dns queries from this device showing up in my local dns server which guest network does not have access to.

I have seen this happen with a couple of devices that always connect to guest network and sometimes they get the ip in the correct subnet and some times they do not.

I have also tried restarting the router and the airmesh node and it did not help. I was curious if any one else has seen this? and if any one has any pointers on how i could fix this.
 

Jack Yaz

Part of the Furniture
YazFi doesn't work on Aimesh nodes. The guest network on the node will be unrestricted
 

amoney

Occasional Visitor
YazFi doesn't work on Aimesh nodes. The guest network on the node will be unrestricted
ah ok that explains why i saw this behavior. I understand with 386.x you could have guest networks use airmesh as well. Will look into how i can disable airmesh for guest network.
 

Jack Yaz

Part of the Furniture
ah ok that explains why i saw this behavior. I understand with 386.x you could have guest networks use airmesh as well. Will look into how i can disable airmesh for guest network.
it's something i want to add, but there's too many issues with guest syncing (protocol is buggy in logs, packet loss etc.) and i dont want to add anything until Asus have fixed it
 

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top