What's new

Help wrt610n and Intel 5100

  • SNBForums Code of Conduct

    SNBForums is a community for everyone, no matter what their level of experience.

    Please be tolerant and patient of others, especially newcomers. We are all here to share and learn!

    The rules are simple: Be patient, be nice, be helpful or be gone!


New Around Here
I have purchased a WRT610N (with latest firmware from linksys) to work with my new laptop (LenovoSL500, Vista Business, Intel 5100 wireless card running latest driver from Intel).

When I setup the card to connect to the "a" band, it connect perfectly in the n-only function (WPA2-aes). When it connect to the "g" band, it will only connect at legacy speed, no "n" speed. I have tried mixed mode and n-only. In mixed mode I have used the wpa-aes (wpa2-aes will not associate) and in the n-only I only get the option of wpa2 and it will not associate.

Any workaround? Should I switch to a Intel 5300?

Go into the network properties for the adapter and change the 802.11n Channel Width (2.4 GHz) setting from 20 MHz to Auto.
Setting is already chosen (I had verified this setting previously). Should I choose the 40 mhz setting?
If you have one. The Intel drivers that I downloaded only has 20MHz and Auto settings.

You could try DD-WRT if you like.
Intel driver I have only have the 20mhz or auto setting also.

Do you have any idea? Can swithching to a 5300 card help?
Let's step back.

What is the connect speed that the client is reporting when connected to 2.4GHz radio with no security enabled?

Have you set the 2.4GHz radio Channel width on the router to 40MHz?

BTW, I don't recommend using 40MHz mode if you have other networks nearby. You will cause interference.
You should at least get a 130 Mbps connect speed.
Check that the 802.11n mode in the adapter settings is enabled.
Also trying changing the Throughput Enhancement setting on the adapter.
Also try using the Windows Wireless Utility instead of the Intel.
802.11n is enable in the adapter.
Throughput Enhancement is set to enable. I will change to disable.
I'm not using the Intel app but Lenovo supplied one.
Glad you got it solved and thanks for reporting the solution.

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!