How do you enable in the Asuswrt firmware so that local devices can run host/nslookup on a local IP and get its hostname that the router has recorded?

domic

Regular Contributor
Hostname decided by router's DHCP table or one decided by the respective devices own settings, however it works.
I can ping Samsung-S22(with and without .local) for example, and get it's IP adress back, but I wish to also get the same DNS name from "pinging" 10.0.0.67, (with whatever commands one uses). But I don't know if and what settings my router needs to setup to allow it. I don't remember much from IT class, but 'reverse DNS' lookup or something?
 

ColinTaylor

Part of the Furniture
I'm not sure I follow what it is you're asking. Is it nslookup?
Rich (BB code):
C:\>nslookup 192.168.1.10
Server:  RT-AX86U.home.lan
Address:  192.168.1.1

Name:    nuc.home.lan
Address:  192.168.1.10
 

domic

Regular Contributor
I only get this output:
Code:
$ nslookup 10.0.0.1
** server can't find 1.0.0.10.in-addr.arpa: NXDOMAIN
 

ColinTaylor

Part of the Furniture
I only get this output:
Code:
$ nslookup 10.0.0.1
** server can't find 1.0.0.10.in-addr.arpa: NXDOMAIN
Try specifying the router's DNS server explicitly.
Code:
# nslookup 192.168.1.10 192.168.1.1
10.1.168.192.in-addr.arpa       name = nuc.home.lan.
 

ColinTaylor

Part of the Furniture
Huh, that works, but why doesn't the first option work as well?
Your client isn't configured to directly query the router DNS servers. In other words, it's a client issue. Try the same thing from a different client running a different OS. I suspect your client is running its own DNS forwarder or using some other form of proxy. An out of the box installation of Ubuntu for example runs its own resolver (systemd-resolved).
 
Last edited:

RMinNJ

Senior Member
I tried this. I do get the name my router has in its device table for most devices such as my roku, my phone, etc... But other devices like my Canon printer do not return the name from the device list. So i think it may somewhat device specific also.
 

torch

Occasional Visitor
Have you tried setting a Domain Name on your LAN? It appears you have it blank or have it set to "in-addr.arpa"
 

domic

Regular Contributor
Have you tried setting a Domain Name on your LAN? It appears you have it blank or have it set to "in-addr.arpa"
I use ".local"

It seems to be some limitation Android devices (with Termux) don't work as well as a Debian based Raspberry Pi OS (and other Desktop OS's) handle. Thanks, everyone, I enjoy asking questions and learning new things. Linux/cross-platform stuff is a wiiiide landscape of knowledge by now for us homelab nerds .
 

domic

Regular Contributor
.local is a no-no - it is reserved https://en.wikipedia.org/wiki/.local Try .lan or .home.
Thanks for sharing. IIRC it's the default on asus routers. Nobody taught me this in IT education, it just felt easier to remember among the myriad of ever-changing names for things. Cloud meant the fluffy things up in the sky once upon a time, etc. LAN works, but when you forget acronyms over the years ".local" is easier to remember. At least for my home environment.
".home" I could look into but I *really* like ".local" for some reason.
 

torch

Occasional Visitor
As it mentions in the Wikipedia page "Any DNS query for a name ending with the label local must be sent to the mDNS IPv4 link-local multicast address 224.0.0.251...", which means that the device with that IP address is required to respond, NOT your router. That is how the zero config/mDNS works. You will have to start really liking a different Domain Name :)
 

dpm

New Around Here
On my AX88U I found that nslookup reports "non-existent" for static v4 ips when there is no manual assignment list and it is disabled. Adding or defaulting a DNS server address has no effect, in either case nslookup reports the right DNS. Once I enabled manual assignment and defined my static devices they showed up with the host name defined in the list.
 

domic

Regular Contributor
The default domain name is left blank. In effect, a null string. As mentioned above, don't use .local.
Good evening Colin, nice to see you again. Hope your week is going well. ☺
By the way, what are the pros and cons of using no domain name, vs using one? (I changed to another for now)
What do you miss out by using one vs not using one?
 

ColinTaylor

Part of the Furniture
Good evening Colin, nice to see you again. Hope your week is going well. ☺
By the way, what are the pros and cons of using no domain name, vs using one? (I changed to another for now)
What do you miss out by using one vs not using one?
I can't think of any advantages of having a null domain name. I've noticed that many home router manufacturers do this and it only leads to confusion. To be clear, it is not the case that there is no domain name, rather the domain is a null string. So to lookup the FQDN of a host you would enter nslookup mypc. (notice the trailing dot).
 

torch

Occasional Visitor
I would assume that if the router's DHCP/DNS server (dnsmasq?) cannot find that "mypc." it would send it to an upstream DNS server (etc...) which would also not find it...
 

ColinTaylor

Part of the Furniture
I would assume that if the router's DHCP/DNS server (dnsmasq?) cannot find that "mypc." it would send it to an upstream DNS server (etc...) which would also not find it...
The default setting for "Forward local domain queries to upstream DNS" is No.
 

Similar threads

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top