What's new

iomega StorCenter ix2 w/ built in Mozy?

  • SNBForums Code of Conduct

    SNBForums is a community for everyone, no matter what their level of experience.

    Please be tolerant and patient of others, especially newcomers. We are all here to share and learn!

    The rules are simple: Be patient, be nice, be helpful or be gone!

sbutts

New Around Here
I just saw the post about the new iomega StorCenter ix2 NAS. The details seem to be very slim right now regarding the Mozy feature, but it does mention MozyHome Online backup in the sellsheet PDF.
Does anyone know if the Mozy SW runs on the NAS or on the PC/Mac?

I've been eagerly awaiting a NAS with some sort of built in online storage backup ability, and I'm hoping this one finally provides that. But I have a bad feeling it doesn't actually run on the NAS box.
 
Sorry, don't have any further details at this point.

Given similar offerings from other vendors, my guess is that it is probably is just a bundle of the service, like the Retrospect backup.
 
cons

Cons • Drives not user-replaceable

this is where i stopped reading.
 
no energy saving

I got two of the 2TB boxes, first impression: "What? Only 870GB?", second impression "That thing is LOUD!"

Then I found out that there is no powersaving and I realy doubt that the harddisks are of a sort made for 24/7 operation and they get uncomfortably warm.
Shutdown is only available through the webinterface hidden in settings ->device, pulling the plug is never a good idea.
Power on is only possible via a small button on the back, no WoL capability.

Since the drives are not user serviceable, the Storcenter needs backup even in RAID1 configuration. This is only possible over ethernet, there is no function to backup to an attached USB HDD.

I haven't tried the backup software, I use timemachine on my Macs and TimeVault on my Linux netbook and desktop, but I don't think a device like this is a usefull backup medium.

I can't recomend the Iomega Storcenter ix2 for home use, much louder than a usual notebook, need of another external drive for backup, slow backup due to limited speed, no powermanagement and shutdown and power on are uncomfortable at least.

I've got some 100 DVDs with pictures, amateur photographer that I am ;-), and I think I'll use one Storcenter in a hierarchical storage environment, i.E. copy the DVDs to the Storcenter, save new pictures to DVDs as usual and the Storcententer, remove seldom used pictures from local HDDs and access them from the Storcenter. When it breaks, I won't bother getting it repaired.
 
Question to the author of the review

Hi,

I bought the ix2 1TB unit in last boxing day, and I've been trying to get ssh and root access to the box ever since - to do a number of tweaks I have in mind. There is a open source project "Open Protium" that supplies a different firmware for Iomega StorCenter, but it does NOT work on the ix2 1TB unit because it switched to a different embedded processor, so I have been stuck on this so far.

So anyways, the following statement from the review REALLY caught my attention, that is exactly what I wanted to do!

"Long story, short, I found that the ix2 did, in fact, have this vulnerability. Not only was I able to submit commands, but could have them reference a script that I stored on an ix2 share. By modifying the script, I was able to find daemons for both SSH and Telnet, enable a commented-out startup script for SSH, create a new privileged user, reboot, and get Linux shell root access that was persistent across reboots."

And I checked the firmware version of my box, it is 1.1.17.34772, so I should be able to do this. Just wondering if the author can give some hints as to how to do this, assuming I have basic-to-intermediate Linux command line literacy. Thanks!


James
 
Re: Questions to the author of the review

James - I don't have the box anymore, but the following are my original notes. Basically, I just put my usual "BlahBlah`reboot`BlahBlah" into the search form to test for a hole, and then when I found it, I wrote and referenced a script to make the changes.

Good Luck!
Jim


I entered a search string of /sbin/reboot in the form surrounded by the "back-tics" that an OS shell would interpret. Then I hit the submit button. Shortly thereafter, my browser complained that the box was unreachable. Bingo! I had a hole. And since the reboot command worked, it also meant that the command was being run with root privileges. I was in.

Once I knew I could issue commands to the underlying OS as root, I created my own script on a share and verified I could cause it to be executed by referencing the script from the search form. Using my script, I started poking around to see what was available. I found daemons for both secure shell and telnet, but nether was being used. There was a startup script for ssh, but the critical section was commented out. Once I fixed that, created a new privileged user and rebooted, I was in!
 
Thanks a lot Jim!

I got root && ssh access to the box!

My work is too demanding recently so I have to wait a bit b4 proceeding with further tweaks, but getting here is already exciting! Will post back my progress of the following list:

1. Get the box to boot from a usb stick with Slug/OS.
2. Put another 500G external USB drive in and make RAID5 working
3. Compile a hacked kernel on Slug/OS so that it understands reiser4 file system (transparent high compression without losing performance)

If I can manage to do all that, I effectively get 3~4 TB storage out of this box with data redundancy, even after adding the cost of the external USB, I'd say it is one sweet buy!

James
 
Replace drives, not easy- but possible.

I found a way to replace the drives. Also was able to get ssh access in the process. The process requires putting the drive into a windows box, ghosting the first partition, extracting and changing the config file. Putting it back into the ghost image. ghosting to the new drives. resetting the hard drives with the iomega web page. getting in with shell access and resetting the mirror with mdadm. once rebuilt you can reset from the web page and bingo, gold. Took a few days for me to get it working, but I now have a 1.5TB mirror.
 
Please post detailed Instructions to replace drives

I love this NAS, but the capacity is too small and replacing the drives with bigger ones would make it much more usable. If could take the time to post more detailed instructions I would be very grateful. Thanks
 
Problems with subfolders security access

I'm using it with Active Direction. When I create a subfolder it keeps the same security access as the main folder (the same users have access). I can´t modify the permissions of the subfolder, but the messasge dosen´t say why. Anybody knows why?
 

Support SNBForums w/ Amazon

If you'd like to support SNBForums, just use this link and buy anything on Amazon. Thanks!

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top