iPad & iPod failing to connect to Asus Router

  • ATTENTION! As of November 1, 2020, you are not able to reply to threads 6 months after the thread is opened if there are more than 500 posts in the thread.
    Threads will not be locked, so posts may still be edited by their authors.
    Just start a new thread on the topic to post if you get an error message when trying to reply to a thread.

OpenBroadcast

New Around Here
I've got two older iOS devices that are both failing to connect to my new Asus RT-AX58U (running duel band) immediately without any error. I am using the Smart Connect on the router and every other device I've got has not had any issues connecting aside from a laptop running MacOS that sees a lot of connectivity issues - not sure I could easily deactivate this feature without causing other issues.
  • Verified the password, even tried connecting manually with no luck.
  • Running the latest version of iOS available for the devices (depreciated at this point.)
  • Connecting to an individual hotspot does work.
  • Tried resetting the network settings on the devices with no change.
Anyone else had a similar situation? Any suggestions?
 

bbunge

Part of the Furniture
Are you running WPA2/ WPA3? If so my solution was to set a guest wifi with just WPA2 for the older iPod touch
 

OpenBroadcast

New Around Here
Are you running WPA2/ WPA3? If so my solution was to set a guest wifi with just WPA2 for the older iPod touch
Yes! Even when connecting to the router manually I selected WPA2. I was hoping to avoid using the guest network as I have other devices for work I pass through using it and I was hoping to keep personal devices on the main network for the added benefit of being able to access other IOT devices. Wondered if there were even any suggestions on trying to debug this very odd situation or if there is a backward way to add a device into the network and keep it working.
 

bbunge

Part of the Furniture
Yes! Even when connecting to the router manually I selected WPA2. I was hoping to avoid using the guest network as I have other devices for work I pass through using it and I was hoping to keep personal devices on the main network for the added benefit of being able to access other IOT devices. Wondered if there were even any suggestions on trying to debug this very odd situation or if there is a backward way to add a device into the network and keep it working.
Use guest 2 or 3 and allow Intranet access. Will then do what you want.
 

Moabdave

Regular Contributor
Are you using the "Smart Connect" feature? I used to have all kinds of problems with Smart Connect and Apple devices. It was to the point I had to disable it as some Apple devices just would not stay connected. However, a year or two later I made some major changes to my Wi-Fi network (upgraded main router, added new mesh nodes, etc.) and of course both router and Apple devices had multiple firmware upgrades in that time. But for kicks I enabled Smart Connect again, and now it works great with my Apple devices. So no idea which of all those changes fixed the problem, but something did.
 
Last edited:

sfx2000

Part of the Furniture
I've got two older iOS devices

If they are older iOS devices that do not support 802.11ac, WPA3 can be a problem...

WPA3 is supported on the following Apple devices:

  • iPhone 7 or later
  • iPad 5th generation or later
  • Apple TV 4K or later
  • Apple Watch series 3 or later
  • Mac computers (late 2013 on, with 802.11ac or later)
 
Similar threads

Similar threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top