Is it possible to search/find filename via ssh?

  • ATTENTION! As of November 1, 2020, you are not able to reply to threads 6 months after the thread is opened if there are more than 500 posts in the thread.
    Threads will not be locked, so posts may still be edited by their authors.
    Just start a new thread on the topic to post if you get an error message when trying to reply to a thread.

KsWoodsMan

Regular Contributor
If the OS doesn't have locate or whereis
I've often used
Code:
 alias locate="du -ah / 2>&1 | grep "
locate myfile
when I'm looking for a file with a known extension I can use locate "my\.file" to look for my.file

This works extremeley well for me when in a small file system such as in router firmware or a PiBox .
Your Mileage May Vary
 

Jack Yaz

Part of the Furniture
Code:
find /opt/ -name "ca.crt"
 

elorimer

Very Senior Member
im trynig to find the file ca.crt thats located in http://192.168.2.4/ca.crt

but i just cant seem to download it

i have to fin it and opy it somewhere so i can download it
All these live in /opt/var/cache/pixelserv.
Plus, that link will download it too.
 

fearz

Senior Member
All these live in /opt/var/cache/pixelserv.
Plus, that link will download it too.


Ok, I went to /opt/var/cache/pixelserv. downloda ca.cert
ran it on my PC

but still neither 19281.68.2.1 nor router.asus.com is secured...

what am i diong wrong?
 

fearz

Senior Member
umm
Here are some sreenshots that shows ive installed the ert on the PC and on chrome:

but stil router.asus.com wont go HTTPS (Non0Secure)
 

Attachments

  • RzCap-20210112181215.jpg
    RzCap-20210112181215.jpg
    71.3 KB · Views: 18
  • RzCap-20210112181149.jpg
    RzCap-20210112181149.jpg
    58.6 KB · Views: 18
  • RzCap-20210112181130.jpg
    RzCap-20210112181130.jpg
    50.8 KB · Views: 17
  • RzCap-20210112181125.jpg
    RzCap-20210112181125.jpg
    52.5 KB · Views: 15
  • RzCap-20210112181120.jpg
    RzCap-20210112181120.jpg
    52.5 KB · Views: 18

dave14305

Part of the Furniture
umm
Here are some sreenshots that shows ive installed the ert on the PC and on chrome:

but stil router.asus.com wont go HTTPS (Non0Secure)
It should be secure if you browse to the name in the cert... https://router.asus.com/

Pixelserv generated certs aren't as flexible to include IPs in the Subject Alternate Name field. The router's own /usr/sbin/gencert.sh can do that, but it's self-signed.
 

fearz

Senior Member
It should be secure if you browse to the name in the cert... https://router.asus.com/

Pixelserv generated certs aren't as flexible to include IPs in the Subject Alternate Name field. The router's own /usr/sbin/gencert.sh can do that, but it's self-signed.
Nope,

don't happen, httos://router.asus.com loads a blank page now, http://router.asus.com loads but no-secure....
npt really sure whats wrong....
.
id appreciate your help
 

Mutzli

Very Senior Member
im trynig to find the file ca.crt thats located in http://192.168.2.4/ca.crt

but i just cant seem to download it

i have to fin it and opy it somewhere so i can download it
On PC's I simply use the Windows 10 File Explorer\Network to get files off the router:

1610482246758.png
 

Mutzli

Very Senior Member
I used the same and got the file...insalled it;....but still not secure

question:

do you have http:///192.168.1.1 as HTTP (secured?) so doe https:router.asus.com ?
I had the same problem. It could be that the certificate is rejected because it's valid for 10 years. A certificate can't be valid for more than 39 months to be validated by your browser. I solved it by following the original instructions for pixelserv certificates which creates a certificate with the shorter validity. Here is the command to create it from the pixelserv website:

Install certificates for Router WebGUI to JFFS (needs to be renewed after JFFS format):
sh -c "$(wget -qO - https://kazoo.ga/pixelserv-tls/config-webgui.sh)"

Follow the instructions and install the new certificate on your browser. I also use the same certificate for the router UI by loading it in the DDNS section of the router:

1610552971384.png
 

Wisiwyg

Regular Contributor
WinSCP. Enable on SSH on the router. You should be able to log in and browse in the GUI.
 

fearz

Senior Member
I had the same problem. It could be that the certificate is rejected because it's valid for 10 years. A certificate can't be valid for more than 39 months to be validated by your browser. I solved it by following the original instructions for pixelserv certificates which creates a certificate with the shorter validity. Here is the command to create it from the pixelserv website:

Install certificates for Router WebGUI to JFFS (needs to be renewed after JFFS format):
sh -c "$(wget -qO - https://kazoo.ga/pixelserv-tls/config-webgui.sh)"

Follow the instructions and install the new certificate on your browser. I also use the same certificate for the router UI by loading it in the DDNS section of the router:

View attachment 29475
Can you scrrentsjot me pocs of https 192.168.x.x
 

Similar threads

Top