Just got fiber but can't get upload speed above 60 Mbps on RT-AC86U with 386.3_2

  • ATTENTION! As of November 1, 2020, you are not able to reply to threads 6 months after the thread is opened if there are more than 500 posts in the thread.
    Threads will not be locked, so posts may still be edited by their authors.
    Just start a new thread on the topic to post if you get an error message when trying to reply to a thread.

Slapdaddy

New Around Here
Are jumbo packets enabled on your computer NIC? If so, disable it - causes more trouble than its worth. Toggle the switch for jumbo packets on and off again on the router just to be sure it is off.
 

Morris

Senior Member
If you are running AI Mesh, then the router node must have the fastest radio as it's settings will be propagated to the other nodes. The router node must have enough CPU and memory for the client load, link speed, QOS and add ons. WiFi 6 is the present and definitely the future. 6E is very expensive and it's best use is for backhall if you can't do ethernet.

Top of the Asus dual radio routers that run Merlin: RT-AX 86U, RT-AX 86U
Nice mid price dual radio router: RT-AX 3000
 

John Davis

Regular Contributor
reflash back to current merlin, then use amtm to install spdmerlin and run that on the router (you'll need a usb drive plugged back in to install it and for a swap drive)

SpdMerlin will help you tell if the issue is the router-ont connection or the router-pc connection - at the moment you have no way of knowing where the fault lies

You won't be able to saturate a 1gb/1gb link running speedtest-cli (via spdmerlin) on an ac86u, but it should be able to do >60mbps - here's what I get on my own ac86u running spdmerlin against a local test node on a 950/450 connection

Code:
Starting speedtest using auto-selected server for WAN interface


     Server: Spark NZ - Christchurch (id = 26747)
        ISP: Spark New Zealand
    Latency:     1.63 ms   (0.34 ms jitter)
   Download:   557.34 Mbps (data used: 677.2 MB)
     Upload:   453.27 Mbps (data used: 554.7 MB)
Packet Loss:     0.0%
 

zaxcom

Regular Contributor
The latest firmware has speed test built in. This is my results on a RT- AX86.
Screen Shot 2021-08-14 at 7.58.19 PM.png
 

dvohwinkel

Senior Member
Sounds like a handshaking issue between the ethernet port on your computer and the router. In your computer can you go into the ethernet settings and manually enable 1000baseT, Flow Control off, and Full Duplex?

Also make sure your MTU is 1500
Yep tried forcing all these, same issue.
 

dvohwinkel

Senior Member
Are jumbo packets enabled on your computer NIC? If so, disable it - causes more trouble than its worth. Toggle the switch for jumbo packets on and off again on the router just to be sure it is off.

No, no jumbo packets.
 

dvohwinkel

Senior Member
Same question, do you have another computer to test the speeds with, so we can rule out the ethernet adapter on the computer not liking the ethernet interface on the 86u? Did you try the manual settings?

I had a laptop that was giving some crazy speeds on it's ethernet.. like upload was 90Mbit, and upload 930Mbps

You are right, I used my old gaming PC and it was able to get 930Mbps up and down. So now it's just figuring out what my RT-AC86U doesn't like about my ASUS X570 Aura's Intel I211 Gig Ethernet NIC.
 

dvohwinkel

Senior Member
Using Intel PROSet Adapter Configuration Utility and turning off every adapter setting I was able to get 930Mbps down and 300Mbps up. This is an improvement but not the full 930. I'm running out of ideas on what to try.
 

John Davis

Regular Contributor
Using Intel PROSet Adapter Configuration Utility and turning off every adapter setting I was able to get 930Mbps down and 300Mbps up. This is an improvement but not the full 930. I'm running out of ideas on what to try.

does pro set have a setting for eee ( energy efficient ethernet) - if so make sure it’s off

if it doesn’t you can try turning it off on the router end by sshing in and typing pwrctl —eee off (though on Merlin at least eee is already off by default)

Other thing I’d try is a small basic switch between your desktop and the ac86u
 

Morris

Senior Member
Using Intel PROSet Adapter Configuration Utility and turning off every adapter setting I was able to get 930Mbps down and 300Mbps up. This is an improvement but not the full 930. I'm running out of ideas on what to try.
Get yourself a decent USB NIC and move on or use wireless.

Morris
 

dvohwinkel

Senior Member
does pro set have a setting for eee ( energy efficient ethernet) - if so make sure it’s off

if it doesn’t you can try turning it off on the router end by sshing in and typing pwrctl —eee off (though on Merlin at least eee is already off by default)

Other thing I’d try is a small basic switch between your desktop and the ac86u

Yep, it's off. I also have tried with a switch in between and no help.. I really liked the switch idea as I hoped that would clean up whatever it didn't like.. nope.
 

dvohwinkel

Senior Member
does pro set have a setting for eee ( energy efficient ethernet) - if so make sure it’s off

if it doesn’t you can try turning it off on the router end by sshing in and typing pwrctl —eee off (though on Merlin at least eee is already off by default)

Other thing I’d try is a small basic switch between your desktop and the ac86u

Ok now that command is pretty interesting. I turned off "Switch deep green mode" (dgm) and turned off "Ethernet auto power down"(ethapd) and "Energy Efficient Ethernet"( eee) was off like you said it would be in Merlin.. and.. SUCCESS!!!

Actually, I'm getting slightly faster uploads than downloads.

So that search engines can find this answer..

My config is...
Gigabyte X570 Aorus motherboard with built-in Intel i211 Gig Nic connecting to an ASUS RT-AC86U . We needed to turn off
some pwrctl stuff on the router. See above.
 

dvohwinkel

Senior Member
I just wanted to say THANK YOU for all the help and suggestions. I really appreciate it. This has been a crazy 2.5 days of pulling what hair I have left out.
 

dvohwinkel

Senior Member
Is there a way of setting those pwrctl's if I decide to use the RT-AC86U as an ai-mesh node? I guess they really wouldn't be needed.. but I use the ethernet backhaul on aimesh nodes and then sometimes connect stuff to it hardwired.
 

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top