Merlin 384.5 vlan DHCP problem?

  • ATTENTION! As of November 1, 2020, you are not able to reply to threads 6 months after the thread is opened if there are more than 500 posts in the thread.
    Threads will not be locked, so posts may still be edited by their authors.
    Just start a new thread on the topic to post if you get an error message when trying to reply to a thread.

Bill Lee

New Around Here
Greetings all. Newly joined after reading for a while. Bought an ASUS RT-AC86U B2 and have been mucking around trying to create a separate vlan with it's own DHCP.

robocfg works, and I can create the interface and assign it a .1 IP that I can successfully ping within the SSH session. However, I cannot get a DHCP server to hand out IPs on the new vlan that match the new subnet IP. I have included iptable statements for the DHCP

Code:
iptables -I INPUT -i vlan10 -m state --state NEW -j DROP
iptables -I INPUT -i vlan10 -p tcp --dport 53 -j ACCEPT
iptables -I INPUT -i vlan10 -p udp -m multiport --dport 53,67 -j ACCEPT

And then set up dnsmasq

Code:
interface=vlan10

dhcprange=vlan10,192.168.5.100,192.168.5.254,255.255.255.0,86400s
dhcpoption=vlan10,3,192.168.5.1
dhcpoption=vlan10,6,192.168.5.1,8.8.8.8

I noticed in the Merlin version I installed that the "dhcp range" part is missing the "-" (dhcp-range, dhcp-option) that I see in previous posts. The version I am using won't take those settings unless I remove the "-", but I don't know if that is a modification that hooks up properly on the back-end. All I know is that the DHCP never properly assigns an IP for the subnet.

Any thought on addressing the problem is appreciated.

Edit: I am doing all this at the CLI for now until I can get it to work, then will try adding scripts.
 

Bill Lee

New Around Here
Well, I restored stock firmware, tried again, and still no-go. So must be something I am leaving out in the commands/setup. Also, the stock firmware likewise does not accept "dhcp-range" and "dhcp-option", but only the setting names without the "-".
Soldiering on with more research on proper commands and syntax....
 

Bill Lee

New Around Here
Got it working. Separate vlan on port with DHCP assignments from specified range. Just need to add it to /scripts and /configs.
If you are new to this (as am I) I would recommend using WinSCP (even if in VM) - it is just easier (IMO).
 

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top