Multiple VPN Clients

  • ATTENTION! As of November 1, 2020, you are not able to reply to threads 6 months after the thread is opened if there are more than 500 posts in the thread.
    Threads will not be locked, so posts may still be edited by their authors.
    Just start a new thread on the topic to post if you get an error message when trying to reply to a thread.

Radleydm

Occasional Visitor
I have an Asus RT-AC2900 and an Asus RT- AC66U B1 as AiMesh both with the latest firmware Asuswrt 386.2_2.

I have Nord VPN on the AC2900 under Client 1. I live in Portugal and have a Portuguese VPN server. I sometimes have limited supply so I would like to have a German or English VPN as an easy alternative.



I have tried without any success to put a German VPN on Client 2 and an UK VPN on Client 3.

I have been through all scenarios with Nord (who have been very helpful)

I have done as they suggest but with no success but here is the situation:



Client 1 with PT50 working perfectly.

Client 2 (now German900) with new file de900 uploaded – no success.

I then uploaded de900 to Client 1 – no problem !!

WAN checked and is as should be.

With Clients 2,3 etc. the static key and certificate authority will not save. They return to empty.



The latest email from Nord is:

Regarding configurations not saving properly within the router itself, we could suggest factory resetting the router, or trying out a different version of the firmware available for it although you say you have the latest firmware but the problem was the same with the earlier version.

As the issue seems related to the router itself, we would recommend contacting Asus themselves.


I contacted Asus who said that they do not support asuswrt-merlin and suggested that I factory reset the AC2900 which I did.

I have then been through the whole setup again with the same results. Basically static key and certificate authority configurations will not save except in Client 1.

Help would be most appreciated.
 

Alfsu

Regular Contributor
@Radleydm

Check files in /jffs/openvpn/ after importing an ovpn file.

As a workaround, you may be able to manually load up the certificates (using WinCP or similar), content should look similar to this:

Capture.PNG


The files above have survived Asuswrt-Merlin firmware updates and upgrades for a few years now on an AC86U.
 

Radleydm

Occasional Visitor
Hello Alfsu. Thank you for your response but am feeling a bit idiotic. I have done another factory reset and am with asuswrt 386.2_2.
I uploaded a UK opvn file to Client 1 - all working well.
Tried to upload a Portuguese opvn file to Client 2. No success and again there is no static key and certificate authority.
The idiotic bit - where do I find the files in /jffs/openvpn/?
Normally the OpenVPN Servers are off. Have tried to put them to on but am now lost.
Advice would be appreciated as to where I am getting stuck.
 

Similar threads

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top