Network Status shows "Disconnected"?

trevorklat

Occasional Visitor
I have an Asus RT-AC5300 router (FW 81981) in AiMesh mode with an RT-AC86U (FW 81992) and under GENERAL==>NETWORK MAP the globe icon at the top says "Internet Status: Disconnected".

However, the Internet is connected and I can ping and browse all over the Internet.

It used to work and would show my WAN IP address.

The side bar on the same page shows all my WAN settings correctly and my lease time is several days of uptime. Is this a known bug?
 

bbunge

Very Senior Member
I have an Asus RT-AC5300 router (FW 81981) in AiMesh mode with an RT-AC86U (FW 81992) and under GENERAL==>NETWORK MAP the globe icon at the top says "Internet Status: Disconnected".

However, the Internet is connected and I can ping and browse all over the Internet.

It used to work and would show my WAN IP address.

The side bar on the same page shows all my WAN settings correctly and my lease time is several days of uptime. Is this a known bug?
Network Monitoring uncheck both DNS Query and Ping
Known issue.
 

trevorklat

Occasional Visitor
Network Monitoring uncheck both DNS Query and Ping
Known issue.
Where is that located on the stock AsusWRT? I don't have a page called "Network Monitoring"? I find no place to even check both DNS Query or Ping. What am I missing?
 
Last edited:

jsbeddow

Senior Member
Administration tab on left panel, then System tab at top, then scroll to middle of page for Network Monitoring settings (in Basic Configuration), uncheck both.
 

trevorklat

Occasional Visitor
Administration tab on left panel, then System tab at top, then scroll to middle of page for Network Monitoring settings (in Basic Configuration), uncheck both.
Thanks, I found it and unchecked both. I rebooted but still no luck. Icon continues to show "Internet Status: Disconnected" even when it really is connected.

UPDATE: Although my search in this subforum yielded no results, my search in the Asuswrt-Merlin subforum showed that many are having this same problem. None of the suggested solutions (unchecking both Network monitoring boxes, specifying DNS servers, unchecking "Connect to DNS Server automatically") worked for me. I could check the Network monitoring "ping" box to ping Amazon and it would work...once. Then, it would just go back to showing "Internet Status: Disconnected".

My personal feeling is that this bug has been introduced in one of the later official Asuswrt firmware closed-source portions. (I never had this problem in much earlier versions.) I also believe that it affects the official Asuswrt and Merlin's version of the firmware.

I hope Asus will fix this in a new release of firmware.
 
Last edited:

L&LD

Part of the Furniture
@trevorklat in the WAN settings, don't use automatic DNS, instead use 1.1.1.1 and 1.0.0.1 (or your preferred DNS).

This will bypass the ISP's DNS defaults and stock that message from appearing for you.
 

trevorklat

Occasional Visitor
@trevorklat in the WAN settings, don't use automatic DNS, instead use 1.1.1.1 and 1.0.0.1 (or your preferred DNS).

This will bypass the ISP's DNS defaults and stock that message from appearing for you.

Thanks L&LD but I am already using the DNS settings for OpenDNS:
208.67.222.222 & 208.67.222.220 so I am not connecting automatically.

Still, get the Internet Status:Disconnected icon though.
 

L&LD

Part of the Furniture
Okay, but did you try 1.1.1.1 and test with a reboot too? :D
 

trevorklat

Occasional Visitor
Okay, but did you try 1.1.1.1 and test with a reboot too? :D
Yes, I did that as well. Still the same problem. At this point, I'm thinking I will have to do a factory reset and load all my customized settings again. That will have to wait though until I have a free day. I'll just live with the erroneous icon until then.
 

L&LD

Part of the Furniture
@trevorklat, when you do the full reset, be sure to test with the 'safe' M&M Config defaults first, before manually inputting your custom settings. :)

That will give you one more data point to ponder.
 

trevorklat

Occasional Visitor
I finally did the factory default reset and went through the pain of reloading all custom settings and manual DHCP reservations. PROBLEM SOLVED!
 

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top