What's new

Odd wired slow speed issue with RT-AC3100

  • SNBForums Code of Conduct

    SNBForums is a community for everyone, no matter what their level of experience.

    Please be tolerant and patient of others, especially newcomers. We are all here to share and learn!

    The rules are simple: Be patient, be nice, be helpful or be gone!


Senior Member
I have an RT-AC3100 running the latest Merlin firmware. If I run a wireless speed test on my MacBook Air I get around 400 mbps.
I have a Moca bridge connected to port 6 on the router and if I run a wired speed test from my Mac with a usb-c to ethernet adapter connected to a switch on a second Moca 2.0 bridge I get around 475 mbps.

If I plug the Mac directly into the router though I get around 290 mbps which makes absolutely no sense. I tried two different ports with the same result. The web page is reporting both the Moca Bridge and the Mac are using a Gbps connection.

How is it possible to get much faster speeds running through the Moca bridge connected to the router than connecting directly to the router?

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!