Open VPN client routinely disconnecting

Geeum

Occasional Visitor
Hi guys,

I'm running a VPN through Open VPN and it works perfectly. Only problem is that the connection drops on a regular basis, after 10-12 hours. Hard to say exactly when, but basically if I turn the VPN on, I have no problem for several hours, but if I come back the next day, it's very likely that the connection will have dropped and when I log on the router I see the following error:

OpenVPN Client 1 - Error connecting - Authentication failed.

Then I manually turn it back on (with the 'Service State' button) and it works again.
Any idea what this could be? Is there a way to run a 'turn off/turn on' script that would reset the connection every night at 3 am? I feel this could be a good workaround.

Geeum
router: RT-AC68U
firmware: 380.66_4(second to last version, will update to the latest today)
 

CaptainSTX

Part of the Furniture
Hi guys,

I'm running a VPN through Open VPN and it works perfectly. Only problem is that the connection drops on a regular basis, after 10-12 hours. Hard to say exactly when, but basically if I turn the VPN on, I have no problem for several hours, but if I come back the next day, it's very likely that the connection will have dropped and when I log on the router I see the following error:

OpenVPN Client 1 - Error connecting - Authentication failed.

Then I manually turn it back on (with the 'Service State' button) and it works again.
Any idea what this could be? Is there a way to run a 'turn off/turn on' script that would reset the connection every night at 3 am? I feel this could be a good workaround.

Geeum
router: RT-AC68U
firmware: 380.66_4(second to last version, will update to the latest today)

I assume you are running a VPN client. If yes, who is your provider?

Settings for you to confirm are ON is Start VPN with WAN and you probably want to disable restarting your router automatically though if you have the Start VPN with WAN option enabled this might solve your problem by rebooting your router everyday at 3 AM.

A simplier solution than creating a script might be for you just to find a new provider. I seldmon or ever have issues with either Astrill VPN or StrongVPN.
 

Geeum

Occasional Visitor
My provider is .... myself. I lease a VM and installed open VPN on it. Works like a charm and gives me much higher download speeds than any of the services I tried, and it's cheaper.

As for rebooting, I have set the scheduler to reboot twice a week, Sunday and Thursday 2:30 am

I'll try moving to a daily reboot and set 'start VPN with WAN' to YES (it's at NO right now)

Thanks!
 

RMerlin

Asuswrt-Merlin dev
Add "auth no-cache" to your configuration.
 

RMerlin

Asuswrt-Merlin dev
Correct, sorry (was going from memory).
 

Geeum

Occasional Visitor
Awesome, thanks guys. As an fyi here's what my config looks like now (what was there before was copy/pasted from a tutorial)

setenv FORWARD_COMPATIBLE 1
server-poll-timeout 4
dev-type tun
ns-cert-type server
reneg-sec 604800
sndbuf 100000
rcvbuf 100000
setenv PUSH_PEER_INFO
auth-nocache
 

Geeum

Occasional Visitor
No luck. I have this error on the VPN status page:

OpenVPN Client 1 - Error connecting - Authentication failed.
 

Jack Yaz

Part of the Furniture
No luck. I have this error on the VPN status page:

OpenVPN Client 1 - Error connecting - Authentication failed.
What does your VPN server logs (on your VM) show out of interest?
 

Geeum

Occasional Visitor
What does your VPN server logs (on your VM) show out of interest?
I don't know. I should take a look but I've set this up a long time ago following a tutorial so not quite sure how to check the logs. I'll look for a tutorial (unless someone can point me out how to do this).

Anyone else have an idea?
 

CaptainSTX

Part of the Furniture
Here are my settings. I have no stability issues with PIA

client
dev tun
proto udp
remote us-xxxxxx.privateinternetaccess.com 1198
resolv-retry infinite
nobind
persist-key
persist-tun
cipher aes-128-cbc
auth sha1
tls-client
remote-cert-tls server
auth-user-pass xxxxxxxxxxxxxxx
auth-nocache
comp-lzo
verb 1
reneg-sec 0
sndbuf 524288
rcvbuf 524288
fast-io
;crl-verify crl.rsa.2048.pem
;disable-occ
 

Similar threads

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top