What's new

OpenVPN client limited by Fusion functionality

  • SNBForums Code of Conduct

    SNBForums is a community for everyone, no matter what their level of experience.

    Please be tolerant and patient of others, especially newcomers. We are all here to share and learn!

    The rules are simple: Be patient, be nice, be helpful or be gone!


New Around Here
I have a GT-AC2900 ROG router, and the openvpn client is a bit limited by the fusion system. I want this router to connect to my openvpn server, linking other networks, and the router needs to get a couple networks added to the routing table. The problem is the fusion configuration includes "route-noexec" which means the router doesn't pick up any pushed routes, and then I can't access the other networks.
I've tried adding the "ipchange" script option using the custom nvram variable, but it is ignored. I haven't found any other way to run a modified client on the router. Has anyone had luck doing this, or is there a way to run a script out of /jffs on boot?
(if I could run a script on boot, I would just start the openvpn client directly and bypass the GUI, which I've verified works fine)
Guess this is not something anybody else has ran in to... I ended up running openvpn from the command line, and using monit from another computer to make sure it stays running. A bit complicated... but it works.
Hello CompJones, welcome,
Are you running the factory FW or Merlin?
Merlin's code for the GT-AC2900 gives you a choice of keeping the fusion style interface or changing the the original blue/gray Asus/Merlin configuration/sections (also removes the irritating flashing red light every time you click on an option).

The GT-AC2900 is about the same as the RT-AC86; I run both models, and have always had great performance, especially since we run two symultaneous OpenVPN configs/tunnels on router client #1 and #2. You may find Merlin's FW easier to work with, less flashiness; for me I've found it's more secure, stable and fast. Hope this helps, good luck! S.
I'm running stock FW. I'll probably switch over to Merlin. I've ran it on older routers and have no complaints. Just wish the stock FW had a way to run a script on start up.

Thanks for the suggestion.
Glad to be of service.
The new if v386.12..4 downloads as a 142 meg locked file After downloading & unlocking, unzip it and you'll see two images, the regular Merling build is the smaller ubi file, the larger 'rog' build lets you maintain the look of the factory build, so you may want to try it, though it's heavier on your memory load. Sincxe I run two concurrent OpenVPN clients, the regular build takes up less memory.. I tried the rog build but the regular build is easier to navigate, and after so many years of running it IMHO, Merlin's is the superior FW in all ways. Some disagree so you be the judge. CXheck the hash, included in the unzipped folder, and also shown on the sourceforge site.

If you have anything loaded into the factory build, sceengrabs of the crucial parts, with a text file with server URLs, MACs etc, make setting things up fairly easy. For several years, there are many who perform 'dirty' flashes but I don't reckomend it when you're upgrading, and do download the Asus rescue file. I haven't had to use it in for a few years, but never say never. Depending on how much free RAM is showing before you upgrade to Merlin, if you poer down the router or just reboot from the stock firmware, after it comes back up when you log bacxk in let it settle down for a few minutes before you upgrade and you should have no problems. I tend to default all settings and turn off Wi-Fe before upgrading. {ost and let us know how it goes, and best of luck!

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!