What's new

Problem flashing Merlin firmware on Asus rt ax56u

  • SNBForums Code of Conduct

    SNBForums is a community for everyone, no matter what their level of experience.

    Please be tolerant and patient of others, especially newcomers. We are all here to share and learn!

    The rules are simple: Be patient, be nice, be helpful or be gone!


Regular Contributor
I've just bought an rt ax56u. It came with Asus fw which appears to be the latest version from Asus. I've tried to flash merlin rt ax56u-3004-386.6.0 (the very latest available). During the flashing process the message is "updating plse wait" or similar. At the end of the process (no progress indicator) but after about 10 minutes. When I again login in to the router, it still show as still having having orininal the Asus fw. So effectively it won't accept the merlin firmware. I'm using a usb/ethernet adapter to connect my pc to the rt ax56u.

Why is the fw update not occurring? Is there a solution?
Which version is this router? I think merlin is not compatible with the v2.
Solved. The problem occurred when using the usb/ethernet adapter. Later I tried with a direct connection to my laptop ethernet port and the flash was successful.

Similar threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!