Recommended Wi-Fi settings for IoT devices that randomly disconnect / reconnect? Doorbells, bulbs, TVs, thermostats, etc.

theirongiant

Regular Contributor
I have only found a couple of posts here related to smart home devices connected to Wi-Fi that like to randomly disconnect and reconnect.

The device that prompted me to investigate this was my Logitech Circle View Doorbell. Apple HomeKit helpfully notifies me that the doorbell goes offline, then comes back online a few minutes later. Sometimes the doorbell's connection flaps on/off a few times per minute before stabilizing. Each flap fires a notification to all the phones in our home, so my wife thinks the doorbell is defective somehow. It's annoying nonetheless.

I alos remember this happening with my Nest thermostat a lot on a previous router (Netgear R7000). Nest's own KB articles include a note about some Wi-Fi routers that had default settings which could cause the Nest to become disconnected. They recommended calling support for advice, but acknowledged that in some cases the router would have to be replaced for a different model. At one point, they had a list of certified routers from the major manufacturers.

I figured it would help to have a thread that could be found easily by searching the forums or from Google, so I'm including the most common terms and an excerpt from my own logs.

Many IoT devices may not need to maintain an active connection to the Wi-Fi, and will power down their antennas to save a little bit of energy. Consequently, the Wi-Fi router may drop the device to maintain higher performance for other devices. These types of devices include LiFx and Hue light bulbs, doorbell cameras, smart thermostats, smart TVs, etc.

Here are some examples of posts from this forum, listed in chronological order:

- https://www.snbforums.com/threads/3...ted-because-sending-station-is-leaving.61555/
- https://www.snbforums.com/threads/deauthenticated-because-sending-station-is-leaving-ac68u.62451/
- https://www.snbforums.com/threads/random-disconnects-every-few-minutes.63376/
- https://www.snbforums.com/threads/new-ax86u-node-and-iot-devices.71002/

The following are selected options in the Wireless and Professional menus of the Asus router. I've linked to articles where I could find some. I do not know which of these could have the most impact on idle IoT devices, so I'm asking for the community's input. Which Wi-Fi settings should be adjusted to minimize or eliminate the random disconnects?

- Smart Connect (dual-band)
- 802.11ax / Wi-Fi 6 mode
- Wi-Fi Agile Multiband (link 1, link 2)
- Target Wake Time
- Protected Management Frames (link 1, link 2)
- Channel Bandwidth (20/40)
- Control Channels (Auto, Fixed)
- Extension Channels (Auto, Fixed)

Professional Settings:
- Roaming Assistant (enable, set RSSI threshold)
- RTS AMPDU
- Airtime Fairness
- 802.11ax/ac Beamforming (aka Explicit Beamforming - link 1, link 2)
- Universal Beamforming (aka Implicit Beamforming - link 1, link 2)

The syslog on my AX88U shows a sequence of events (example below) occurring multiple times per day, and they coincide with Apple HomeKit notifying me that the doorbell has gone offline and then back online.

Code:
2021-08-08T12:54:40+00:00 RT-AX88U-27B8-464C3A0-C hostapd: eth6: STA 44:73:d6:21:a1:56 WPA: group key handshake completed (RSN)             
2021-08-08T13:17:14+00:00 RT-AX88U-27B8-464C3A0-C wlceventd: wlceventd_proc_event(505): eth7: Auth 44:73:D6:21:A1:56, status: Successful (0)
2021-08-08T13:17:14+00:00 RT-AX88U-27B8-464C3A0-C wlceventd: wlceventd_proc_event(515): eth7: ReAssoc 44:73:D6:21:A1:56, status: Successful
(0)                                                                                                                                         
2021-08-08T13:17:14+00:00 RT-AX88U-27B8-464C3A0-C hostapd: eth7: STA 44:73:d6:21:a1:56 IEEE 802.11: associated                             
2021-08-08T13:17:14+00:00 RT-AX88U-27B8-464C3A0-C wlceventd: wlceventd_proc_event(486): eth6: Disassoc 44:73:D6:21:A1:56, status: 0, reason:
 Disassociated because sending station is leaving (or has left) BSS (8)                                                                     
2021-08-08T13:17:14+00:00 RT-AX88U-27B8-464C3A0-C wlceventd: wlceventd_proc_event(486): eth6: Disassoc 44:73:D6:21:A1:56, status: 0, reason:
 Disassociated because sending station is leaving (or has left) BSS (8)                                                                     
2021-08-08T13:17:14+00:00 RT-AX88U-27B8-464C3A0-C hostapd: eth6: STA 44:73:d6:21:a1:56 IEEE 802.11: disassociated                           
2021-08-08T13:17:14+00:00 RT-AX88U-27B8-464C3A0-C hostapd: eth6: STA 44:73:d6:21:a1:56 IEEE 802.11: disassociated                           
2021-08-08T13:17:14+00:00 RT-AX88U-27B8-464C3A0-C hostapd: eth7: STA 44:73:d6:21:a1:56 RADIUS: starting accounting session 8123EE0286CE1735
2021-08-08T13:17:14+00:00 RT-AX88U-27B8-464C3A0-C hostapd: eth7: STA 44:73:d6:21:a1:56 WPA: pairwise key handshake completed (RSN)         
2021-08-08T13:22:35+00:00 RT-AX88U-27B8-464C3A0-C wlceventd: wlceventd_proc_event(469): eth7: Deauth_ind 44:73:D6:21:A1:56, status: 0, reaso
n: Disassociated due to inactivity (4)                                                                                                     
2021-08-08T13:22:35+00:00 RT-AX88U-27B8-464C3A0-C hostapd: eth7: STA 44:73:d6:21:a1:56 IEEE 802.11: disassociated                           
2021-08-08T13:22:38+00:00 RT-AX88U-27B8-464C3A0-C wlceventd: wlceventd_proc_event(505): eth7: Auth 44:73:D6:21:A1:56, status: Successful (0)
2021-08-08T13:22:38+00:00 RT-AX88U-27B8-464C3A0-C wlceventd: wlceventd_proc_event(534): eth7: Assoc 44:73:D6:21:A1:56, status: Successful (0
)                                                                                                                                           
2021-08-08T13:22:38+00:00 RT-AX88U-27B8-464C3A0-C hostapd: eth7: STA 44:73:d6:21:a1:56 IEEE 802.11: associated                             
2021-08-08T13:22:38+00:00 RT-AX88U-27B8-464C3A0-C hostapd: eth7: STA 44:73:d6:21:a1:56 RADIUS: starting accounting session 9A8D52D724E69ABD
2021-08-08T13:22:38+00:00 RT-AX88U-27B8-464C3A0-C hostapd: eth7: STA 44:73:d6:21:a1:56 WPA: pairwise key handshake completed (RSN)         
2021-08-08T13:54:40+00:00 RT-AX88U-27B8-464C3A0-C hostapd: eth7: STA 44:73:d6:21:a1:56 WPA: group key handshake completed (RSN)             
2021-08-08T14:04:37+00:00 RT-AX88U-27B8-464C3A0-C wlceventd: wlceventd_proc_event(469): eth7: Deauth_ind 44:73:D6:21:A1:56, status: 0, reaso
n: Disassociated due to inactivity (4)                                                                                                     
2021-08-08T14:04:37+00:00 RT-AX88U-27B8-464C3A0-C hostapd: eth7: STA 44:73:d6:21:a1:56 IEEE 802.11: disassociated                           
2021-08-08T14:04:38+00:00 RT-AX88U-27B8-464C3A0-C wlceventd: wlceventd_proc_event(505): eth7: Auth 44:73:D6:21:A1:56, status: Successful (0)
2021-08-08T14:04:39+00:00 RT-AX88U-27B8-464C3A0-C wlceventd: wlceventd_proc_event(505): eth6: Auth 44:73:D6:21:A1:56, status: Successful (0)
2021-08-08T14:04:39+00:00 RT-AX88U-27B8-464C3A0-C wlceventd: wlceventd_proc_event(534): eth6: Assoc 44:73:D6:21:A1:56, status: Successful (0
)                                                                                                                                           
2021-08-08T14:04:39+00:00 RT-AX88U-27B8-464C3A0-C wlceventd: wlceventd_proc_event(486): eth7: Disassoc 44:73:D6:21:A1:56, status: 0, reason:
 Disassociated because sending station is leaving (or has left) BSS (8)                                                                     
2021-08-08T14:04:39+00:00 RT-AX88U-27B8-464C3A0-C wlceventd: wlceventd_proc_event(486): eth7: Disassoc 44:73:D6:21:A1:56, status: 0, reason:
 Disassociated because sending station is leaving (or has left) BSS (8)                                                                     
2021-08-08T14:04:39+00:00 RT-AX88U-27B8-464C3A0-C hostapd: eth6: STA 44:73:d6:21:a1:56 IEEE 802.11: associated                             
2021-08-08T14:04:39+00:00 RT-AX88U-27B8-464C3A0-C hostapd: eth7: STA 44:73:d6:21:a1:56 IEEE 802.11: disassociated                           
2021-08-08T14:04:39+00:00 RT-AX88U-27B8-464C3A0-C hostapd: eth7: STA 44:73:d6:21:a1:56 IEEE 802.11: disassociated                           
2021-08-08T14:04:39+00:00 RT-AX88U-27B8-464C3A0-C hostapd: eth6: STA 44:73:d6:21:a1:56 RADIUS: starting accounting session 7F7EA0124CDE6663
2021-08-08T14:04:39+00:00 RT-AX88U-27B8-464C3A0-C hostapd: eth6: STA 44:73:d6:21:a1:56 WPA: pairwise key handshake completed (RSN)         
2021-08-08T14:04:39+00:00 RT-AX88U-27B8-464C3A0-C dnsmasq-dhcp[29131]: DHCPREQUEST(br0) 192.168.11.215 44:73:d6:21:a1:56                   
2021-08-08T14:04:39+00:00 RT-AX88U-27B8-464C3A0-C dnsmasq-dhcp[29131]: DHCPACK(br0) 192.168.11.215 44:73:d6:21:a1:56
 

Tech9

Part of the Furniture
Which Wi-Fi settings should be adjusted to minimize or eliminate the random disconnects?

I'm assuming your IoT devices use 2.4GHz network. I would set it this way:

In Wireless - Professional:
Roaming Assistant - disabled (let devices connect at any possible signal level)
Preamble Type - Long (may improve connection in high interference environments)
Enable TX Bursting - disabled (applies for 802.11g clients only, non standard)
Enable WMM APSD - disabled (may cause issues with some devices)
Modulation Scheme - 802.11n (Turbo/NitroQAM is non standard specs)
Airtime Fairness - disabled (most IoT are inactive for long periods of time)
User MU-MIMO - disabled (doesn't apply for 802.11n at 2.4GHz)
Explicit Beamforming - disabled (no 802.11n device supports it)
Universal Beamforming - disabled (non standard attempt with no device feedback)
TX Power Adjustment - Performance (max power possible for max range)
 
Last edited:

Tech9

Part of the Furniture
In Wireless - General:
SmartConnect - disabled (separate SSID for 2.4GHz and 5GHz)
Wireless Mode - Auto
Channel Bandwidth - 20MHz (don't use 20/40 in dense Wi-Fi environments)
Control Channel - Fixed (select the channel with higher available bandwidth, not necessarily 1-6-11)
Authentication Method - WPA2 Personal (WPA3 needs PMF enabled and few IoT devices support WPA3)
WPA Encryption - AES
Protective Management Frames - disabled (may not be compatible with all devices)
 

theirongiant

Regular Contributor
It sounds like separate networks might be the most sane way to go here without killing performance for every other 5GHz device. I have very few devices left that only use 2.4GHz, and all of them are smart things / IoT. It will be mildly annoying to reprogram them.

Did anyone else have a similar experience after disabling Smart Connect?
 

BreakingDad

Very Senior Member
Or use mac filter to block them all off 5ghz, that's what I do with google speakers. Stops the annoying log errors as well.
 

thiggins

Mr. Easy
Staff member
First, devices with low data rates or using "legacy" standards (11a/b/g) do not significantly affect performance of faste, more current devices. So routers/APs would have no reason to disconnect them for performance reasons.

But your logs do show deauths "due to inactivity" after 5 minutes, then after 10 minutes. I don't know what controls this or why the router would do this. I also don't know why you are getting RADIUS accounting messages. Are you using WPA2 professional security for any devices?

How did you end up solving your Nest thermostat disconnects?
 

theirongiant

Regular Contributor
Google has a comprehensive KB about dealing with "Nest is Offline."

They also have an article with recommended Wi-Fi settings, and a list of incompatible routers. My old router was similar to one of the ones listed. As soon as I replaced it, the problem went away. I believe the problem was related to a lack of "Power Save" mode (i.e.: WMM APSD).

If you intentionally disabled WMM APSD, try turning it back on.

All of this goes out the window if your HVAC system does not have a C-wire, which supplies 24V to the thermostat. Without this wire, Nest batteries may drain themselves or struggle to maintain a charge when the system is not used very much.
 

Ironcobra80

Occasional Visitor
My axe11000 does the same thing, I fully regret buying Asus as there seems to be no solution for smart devices.
 

albinoman887

Regular Contributor
anyone ever figure out a solution to this? i'm having the same issue with some govee lights and a thermostat and i think my logitech harmony hub as well. i tried the settings above as well as a lot of my own testing and ive tested multiple firmware , merlin and stock... all the same .. what did the one poster mean by segraggating them onto thier own network? like with another router? or you mean give the two different bands each their own ssid ?
 

L&LD

Part of the Furniture
I think 'no response' is the answer.
 

qzip

Occasional Visitor
I was having the same problems and for the life of me I couldn't get anything to work. Turns out my smart devices don't play well when I have wifi 6 enabled. I had It disabled for 2.4 and enabled for the 5ghz and it was still giving me problems. When I turned off wifi 6 all they sudden they work magically. My solution was just grabbing one of my old routers turning that one into an AP and disabled 5ghz band and just keeping the 2.4ghz enabled on the AP for my smart devices. I also went ahead and disabled 2.4ghz on my Asus mesh
 

Lilhunter76

New Around Here
My router has modulation scheme up to 11 MCS. I have issues with a few IoT devices disconnecting randomly. I have multicast turned on under IPTV, I've tried IGMP snooping on and off. Airtime fairness is turned off. I've been told to change multicast rate to CCK 5.5, and I've been told to turn of TX Boosting on the 2.4. If any of these setting changes make a difference I will let you know, but so far no setting has changed this issue for me.
 

sfx2000

Part of the Furniture
Airtime Fairness - disabled (most IoT are inactive for long periods of time)

This was the first thing I was thinking of, but that seems to be covered already as noted by the OP...

There was an interoperability issue with Broadcom and Espressif ESP chips, where AirTime Fairness could be an issue (normally, this is a good thing to enable, however...)

DTIM is something to look at - try adjusting that, 2 is a good place to start, but some devices wake up slow, so 3 can be a good one.
 

JagoUK

Regular Contributor
Try fixing your 5ghz to 36-48.

Some devices like Amazon Firesticks and LG tvs don't work on certain channels.

I had to fix mine on 36-48 to get a consistent connection. (Yes there were other people using these channels too)

 

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top