Solved [RT-AC68U/386.4] curl segmentation fault when using -u

Huib

Occasional Visitor
Hi,
Is anyone else running into an issue when using the stock curl with -u and getting a "Segmentation fault"? I'm using it for dynamic dns:
Code:
curl -k -u "user:password" "https://updates.dnsomatic.com/nic/update?hostname=all.dnsomatic.com"
Doesn't matter whether you use the correct credentials or not.
I'm running on a RT-AC68U, firmware: 386.4, build: Sat Jan 1 18:42:21 UTC 2022 [email protected]
stock curl -V:
Code:
curl 7.79.1 (arm-unknown-linux-gnu) libcurl/7.79.1 OpenSSL/1.1.1m
Release-Date: 2021-09-22
Protocols: file ftp ftps http https imap imaps mqtt pop3 pop3s smb smbs smtp smtps
Features: alt-svc HSTS IPv6 Largefile NTLM SSL TLS-SRP UnixSockets
After I install curl from opkg it works. curl -V from opkg:
Code:
curl 7.80.0 (arm-openwrt-linux-gnu) libcurl/7.80.0 OpenSSL/1.1.1l zlib/1.2.11
Release-Date: 2021-11-10
Protocols: file ftp ftps http https imap imaps mqtt pop3 pop3s rtsp smtp smtps tftp
Features: alt-svc HSTS HTTPS-proxy IPv6 Largefile libz SSL
 
Last edited:

Huib

Occasional Visitor
I marked it solved because it has to do with my configuration somehow, most likely because of something else I installed via opkg. On a stock RT-AC68U/386.4 I have no issues with the same command.
 

Huib

Occasional Visitor
Final update for whoever finds this thread in the future: NTP had died and that caused a whole slew of issues, including SSL not working. The log was showing that NTP was tainted. Not sure what got corrupted but I was forced to do a complete reset and reconfigure my router but things are fine now.
 

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!

Members online

Top