RT-AC87U keeps locking up

  • ATTENTION! As of November 1, 2020, you are not able to reply to threads 6 months after the thread is opened if there are more than 500 posts in the thread.
    Threads will not be locked, so posts may still be edited by their authors.
    Just start a new thread on the topic to post if you get an error message when trying to reply to a thread.

Stevemcclure

Regular Contributor
OMG, I participated in this thread, thinking it was bandwidth analyzer or firmware related etc... eventually, I would end up with a locked up router... however, reading your post... I have two kids both ROBLOX fans.... my situation has got to the point where I reverted back to my isp provided router which doesn't lock up like my asus 87u So right now I'm tempted to say you are onto something...

you have essentially described my household usage... anything else goes fine but my kids play alot on the same game... I have a friend who also reported malware and viruses on their PC and thought it was that game and ever since they removed it, issues went away.
I can picture some very unhappy children right now as you proceed to hook up you AC87 and tell them no more ROBLOX haha. I had mine just go play mine craft instead, that seems ok.
Maybe worth trying tho even if it's just for 5 days or something, and then get them to play it again. Would be interesting to know the outcome. As previously said traffic analyser and QOS were turned off, also NAT acceleration and it still crashed. But 14 days uptime so far is a record in this household. Will see how it goes.


Sent from my iPhone using Tapatalk
 

Revelstone77

Regular Contributor
I'm running Merlin 378.55_0

I have a fan under the unit to keep it cool (ambient temps are high here)

A few times a day, randomly it seems, my RT-AC87U seems to lock up. The lights continue to blink but it no longer responds to pings on LAN/WIFI, cannot surf the internet, cannot access the admin panel etc.

I have my ISPs DSL modem set to bridge mode and the RT-AC87U grabs a public IP through that. It only gets a 1 hour lease it seems.

I've been having a lot of problems with my ISP lately and keep losing connection or having other strange issues. It seems that when this happens, the whole ASUS router just locks up and the only way to get it going again is to turn it off and on.

I've checked the system log but can't see anything obvious. I tried the 30/30/30 thing and did a completely fresh setup, it made no difference.

Does anyone have any ideas?
I was have a similar problem, usually once a day. since putting my 87U on a reboot schedule no lockups. I'm wondering if it could be a memory leak. I may try the new beta and see if it helps without the reboots.
 

stinkybum

Occasional Visitor
I was have a similar problem, usually once a day. since putting my 87U on a reboot schedule no lockups. I'm wondering if it could be a memory leak. I may try the new beta and see if it helps without the reboots.

I can't put into words how angry it makes me that their solution to the crashing AC87U is to add a scheduled rebooter to the firmware. I mean that's literally the definition of giving up on your product.

You know that expensive router you bought? Well we can't work out why it keeps locking up so what we recommend is that you turn all of the advanced features off and then schedule it to reboot every 24 hours.

Seriously. WTF @ ASUS.
 

VANT

Very Senior Member
I write many Times. On .55 FW i have same problem.
I test oficial FW 9177, 9313 and problem is gone.
 

iiaXeii

Occasional Visitor
I write many Times. On .55 FW i have same problem.
I test oficial FW 9177, 9313 and problem is gone.

What is the 9313?

I have loaded the very latest stable FW from merlin, 56_2 which I believe from change log is based on 9177
Factory default reset and switched back from my ISP's router... so my 87U is back online.

I also re-enabled all features, QoS, net monitoring all of it... at this point if it locks up... it's not different than my ISP's and no point using it still if it does.

I have not prevented the kids from playing ROBLOX (yet), I want to see first if the FW fixes the issue. then if it does, My first troubleshooting steps will be to stop the kids playing roblox and blacklist the domain... and see the results over a full 2 weeks...

I'll report back here.

I didn't manage to for more than 4-5 days without lock up before, Merlin to stock firmware... so this is my router's last chance lol (not laughing really... cause it's a $300 piece of garbage if it still locks up)
 

VANT

Very Senior Member
9313 i mean oficial frimware from ASUS RT-AC87U Firmware version 3.0.0.4.378.9313.I use this fw without any lock up with uptime one month and above
 

iiaXeii

Occasional Visitor
Nope, not even 24 hours re-installing my router on 56_2, router just locked up. I let my kids playing ROBLOX and it just crashed. Now onto to removing the game for the time being.
 

Stevemcclure

Regular Contributor
Nope, not even 24 hours re-installing my router on 56_2, router just locked up. I let my kids playing ROBLOX and it just crashed. Now onto to removing the game for the time being.
It's a strange one I must say, all I done was removed the software from both devices and still going strong now.
Am also on 56_2, wouldn't mind giving the official firmwares a go as VANT suggested but they don't support my Vlan, but to be honest if it stays working like it is then it's probably best not to touch it.
Let us know how you get on with ROBLOX uninstalled.


Sent from my iPhone using Tapatalk
 

iiaXeii

Occasional Visitor
As of today and ever since my last post, the router has not crashed, not once since I removed and stopped my kids from playing Roblox.
 

iiaXeii

Occasional Visitor
If one of you Gurus of the coding world can figure out what this game does to the router it would be nice, for now, I'll seperate the internet into two routers, one wifi for the kids to resume their games and AC87 for the rest... this isnt ideal but I just don't get why the AC87 crashes when they play that game and not any other routers, or atl least not the Segcomm from my ISP
 

Stevemcclure

Regular Contributor
As of today and ever since my last post, the router has not crashed, not once since I removed and stopped my kids from playing Roblox.
Good news, think uptime on mine is 40 days now. Would be nice to know what causes it, I will upgrade to 380.57 when I get a chance and see if the problem still exists.


Sent from my iPhone using Tapatalk
 

iiaXeii

Occasional Visitor
I upgraded to 380.57 this weekend and have let my kids play Roblox all weekend, no issues thus far... 3 days uptime.

I would not last 24 hours before this upgrade... its a good sign...
 

shdwkeeper

Occasional Visitor
Right I think i have narrowed down what is causing this issue for me. I kept noticing the router was going tits up when the kids were playing on either my PC or laptop, they like these little online kids games. So for 5 days i said no games, and for 5 days router was fine. So i said right go and fire up your games, 10 minuets later router crashes. Reset it and again 10 minuets later crashes again. The game in question that has been causing the router to crash is a game called Roblox, I have since wiped this game from PC and laptop, and uptime is now 14 days.

I have no idea what the trigger is in this game to cause the problems, I think the game just looks for an open port and uses whatever it can find, is that uPNP or NAT or something? I don't know much about these sorts of things. I was even thinking it may be some little sh*t DDOS'ing from the game somehow, but surely the router protects against this? I dont know.

Thats exactly the issue I was having for a long time, Kids playing Roblox. You can see my issues here: http://www.snbforums.com/threads/does-ac68u-and-ac68p-hang-for-anyone-else.25701/#post-193704 and here:
http://www.smallnetbuilderforums.co...re-wan-disconnections.8433/page-9#post-193936

So I basically got rid of the 2 ASUS routers I had and got an R7000, it worked flawlessly with the stock firmware as well as dd-wrt. I installed Xwrt-Vortex (http://xvtx.ru/xwrt/) on the R7000 and BINGO, it locked up again, just like it did with the ASUS Routers. Kids playing Roblox. There has got to be some sort of connection here somewhere. The only way to get Router back to normal is to reboot it. I love this firmware but I cannot live with these lockups .

Love to see someone fix this.
 

shdwkeeper

Occasional Visitor
Thats exactly the issue I was having for a long time, Kids playing Roblox. You can see my issues here: http://www.snbforums.com/threads/does-ac68u-and-ac68p-hang-for-anyone-else.25701/#post-193704 and here:
http://www.smallnetbuilderforums.co...re-wan-disconnections.8433/page-9#post-193936

So I basically got rid of the 2 ASUS routers I had and got an R7000, it worked flawlessly with the stock firmware as well as dd-wrt. I installed Xwrt-Vortex (http://xvtx.ru/xwrt/) on the R7000 and BINGO, it locked up again, just like it did with the ASUS Routers. Kids playing Roblox. There has got to be some sort of connection here somewhere. The only way to get Router back to normal is to reboot it. I love this firmware but I cannot live with these lockups .

Love to see someone fix this.

Does anyone else experience this?
 

Similar threads

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top