RT-AX86U Router crashing when using IPSec and VPN director

amok666

New Around Here
Hello Everyone

I have a bit of a complex setup which works in theory but its causing the router to become unresponsive.

I have an OpenVPN client connection setup on the router and I direct certain local clients over it using VPN director. This works and its fine. The next step is to allow external clients (coming from WAN) to VPN inside my network and then use my existing OpenVPN connection. Initially, I had an OpenVPN Server running so my client device would establish an OpenVPN connection to my router and then traffic would be forwarded to the other OpenVPN client connection. This has been working for months

Now it seems that my telecom provider blocked access from 4G network to my OpenVPN server (on router) so I am unable to establish this connection. I then tried to setup an IPSec server and the connection worked fine. I followed the same process and directed the client IPs coming in from the WAN IPSec into the OpenVPN client connection and what happens is that it works for 1-2 min but then the router freezes and the entire WIFI network goes down.

I am not sure if I am triggering a bug in the firmware however in theory my setup should work (as it worked with OpenVPN server but doesn't with IPsec)

Has anyone faced a similar issue or can recommend a fix where the router doesn't crash?
Thanks !
 
Last edited:

eibgrad

Part of the Furniture
I don't use IPsec, so it's hard to speculate, but perhaps dumping the underlying data structures might reveal the problem.

Code:
ifconfig
ip route show table main
ip route show table ovpnc1
ip route show table ovpnc2
ip route show table ovpnc3
ip route show table ovpnc4
ip route show table ovpnc5
ip rule
iptables -t nat -vnL --line-numbers
iptables -t mangle -vnL --line-numbers
iptables -vnL --line-numbers
cat /tmp/etc/openvpn/client1/config.ovpn
cat /tmp/etc/openvpn/client2/config.ovpn
cat /tmp/etc/openvpn/client3/config.ovpn
cat /tmp/etc/openvpn/client4/config.ovpn
cat /tmp/etc/openvpn/client5/config.ovpn
cat /jffs/openvpn/vpndirector_rulelist

Yes, it's a lot of stuff, but then I don't know exactly where the problem might be. We need to spread the net as wide as possible right now.

P.S. In the future, anything that involves Merlin's firmware is best reported in that forum.
 

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top