RT-N66U - Constant "Authentication Required" prompts

  • ATTENTION! As of November 1, 2020, you are not able to reply to threads 6 months after the thread is opened if there are more than 500 posts in the thread.
    Threads will not be locked, so posts may still be edited by their authors.
    Just start a new thread on the topic to post if you get an error message when trying to reply to a thread.

IlChengis

New Around Here
Hello Gents.
Whenever I go to the config page of my ancient RT-N66U (Merlin LTS fork) to do something, the page keeps on popping the "Authentication Required" dialog box, constantly.

Authenticating will give me an autonomy of maybe 45 seconds, only to interrupt my work (and concentration) with a new authorization request.

I've checked the "Auto Logout" setting and determined that changing it to any arbitrary value doesn't seem to make any difference.

Has anyone seen anything similar before?

Thanks in advance.
 

eibgrad

Very Senior Member
How long has it been since that router's firmware has been updated/installed or set to factory defaults? These routers often work themselves into a bad state over time. And all kinds of weirdness ensues. It's like the old Windows OS from the '90s. Sooner or later, you just knew you'd have to reinstall and start fresh to get things back to normal.
 

eibgrad

Very Senior Member
P.S. Also wouldn't hurt to clear your browser cache or try another browser. Sometimes they get out-of-sync and you get weird problems.
 

dave14305

Part of the Furniture
I used to see it happen on a mobile browser like Safari on iOS when switching tabs away from the router GUI, the tab would be suspended and not keep sending the needed keepalive request to the router's httpd server. This would result in a timeout and have to login again. You can try setting this nvram variable to larger values (in seconds) until it stops prompting in most cases.
Bash:
nvram set http_disc_timeout=300
nvram commit
service restart_httpd
I used to have mine set to 900 seconds.
 

IlChengis

New Around Here
Thank you both for your replies.

How long has it been since that router's firmware has been updated/installed or set to factory defaults? These routers often work themselves into a bad state over time. And all kinds of weirdness ensues. It's like the old Windows OS from the '90s. Sooner or later, you just knew you'd have to reinstall and start fresh to get things back to normal.
P.S. Also wouldn't hurt to clear your browser cache or try another browser. Sometimes they get out-of-sync and you get weird problems.
I updated recently and reset all settings at the same time. I also switched to a different browser, actually for this very reason... couldn't stand the router tab stealing focus every few seconds on my main browser.

I used to see it happen on a mobile browser like Safari on iOS when switching tabs away from the router GUI, the tab would be suspended and not keep sending the needed keepalive request to the router's httpd server. This would result in a timeout and have to login again. You can try setting this nvram variable to larger values (in seconds) until it stops prompting in most cases.
Bash:
nvram set http_disc_timeout=300
nvram commit
service restart_httpd
I used to have mine set to 900 seconds.
Very helpful, thank you Dave. I just SSHed, but I can't see the current value, looks like I don't have that variable in my settings. I poked around, however, and found this:

Bash:
http_autologout=30
Unfortunately, that's in 'minutes', and the default value (visible in the web GUI) is clearly not making any difference. Hmmm...
 
Last edited:

Similar threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top