[SOLVED] Asus access point with 2 asus repeaters - reconnect issue

Skiron

Occasional Visitor
I have an Asus RT-N66U running as an access point using the latest and final Merlin firmware. I also have two Asus RT-N12E's running Asus stock firmware set as repeaters (static IP). Topology as follows:

Repeater #1 ---------5 metres (west) -------- Access point ------- 7 metres (east) --------------Repeater #2

Repeater #1 covers my kitchen area. Repeater #2 covers my two bedrooms, and the access point in the middle covers the living room. In this scenario all works great... BUT...

... if I reboot the AP both repeaters go AWOL with the wireless network light flashing really fast - they both stay like this no matter how long I wait. I have two Raspberry Pi's connected to repeater # 1, but if I connect to those over wireless (they reconnect to the AP straight away), even the ethx ports on the repeater are down. Now, if I reboot one of the repeaters (doesn't matter which), the other almost immediately reconnects to the AP (with nothing in the logs) and both are back on line again.

The only thing I can think of is either one or the other connect to the other repeater while the AP is down, and both get stuck in limbo. I have poked around around the file system on the repeaters over SSH to see if I can hard code my network BSSID (like on my Pi's wifi set-up) to no avail.

Remember, every thing works perfectly otherwise. Any ideas anyone?
 
Last edited:

eibgrad

Part of the Furniture
I don't know why, but for some reason I find many such devices can NOT recover from the loss of the AP to which they are presently connected. Therefore, whenever I configure a repeater or other wireless bridge, I *always* include a watchdog script to reboot the device (I may even have it send an email notification). The watchdog is nothing fancy. It simply pings a local IP (e.g., the primary router's LAN ip), and should it fail after three (3) attempts, automatically reboot itself. I've been doing this for many years. I know in the case of some third-party firmware, such watchdog features are built-in (e.g., dd-wrt). But worst case, if you're using third-party firmware, you typically can add a watchdog pretty easily.

IOW, trying to determine the *why* behind this behavior may be more trouble than it's worth. I long ago decided it's a problem that's NOT going away, and simply rely on the watchdog.
 

Skiron

Occasional Visitor
Interesting, thanks for the reply. I have even messed on reducing wifi strength via SSH and committing to NVRAM, but all that does is make my network unstable and also messing with the 'roaming assistant' feature that supposedly drop a wifi connection if it is greater that -70dB, but that is just totally pants (Wife moans why her Alexa echo doesn't work :-D ).

Maybe I will have to live with it, I mean it isn't often I reboot the AP.
 

Skiron

Occasional Visitor
I sort of got around this issue - if I know I have to reboot the access point, I turn off one of the repeaters. The other repeater then reconnects to the AP as soon as it's UP, then restart the second the repeater and everything is all back reconnected.

Strange - really seems like the two repeaters connect to each other if the AP is not available and get 'stuck' together. I just wish I could find a way to force them to only connect to the AP BSSID.
 

Skiron

Occasional Visitor
I have found a solution to this:


I rebooted the AP twice this morning after making the changes to the repeater wifi network names (no other changes needed, it can be be done easily on the 'network map->system status' page/tab), and sure enough they go off-line while the AP reboots and then reconnect to it when it's up and not each other and then go AWOL. It's a bit of a PITA to add the the repeater network names to any roving devices in my home (only my Wife's tablet and the grandchildren's stuff when they come around), but other than that, it works well!
 

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top