Strange behaviour w 2 wireless APs

  • ATTENTION! As of November 1, 2020, you are not able to reply to threads 6 months after the thread is opened if there are more than 500 posts in the thread.
    Threads will not be locked, so posts may still be edited by their authors.
    Just start a new thread on the topic to post if you get an error message when trying to reply to a thread.

tiwing

New Around Here
1611624522740.png


Hi all, I just recently bought a second (used) Mist access point to extend coverage. I currently have one Mist AP41 and one Mist AP43 in my deployment of a small office. I am experiencing frequent reboots.

My network is set up with two pfsense firewalls and have worked flawlessly for well over a year. I have main network and guest network on separate physical interfaces with separate switches for each network. The Mist APs have two network interfaces each and support multiple SSIDs that can be directed down either physical network connection. A single AP works perfectly.

Please note the blue and green connections as I believe this is where my issue lies. When everything is connected EXCEPT for the dashed blue line, both APs are rock solid as I would expect. As soon as I connect the guest switch to ETH1 of the AP41, both APs lose connectivity every 10 to 20 minutes and reboot themselves. This happens continuously until I disconnect the cable.

I was going to run the APs in a mesh, so I have installed firmware 0.7.20383 on both APs. However, this situation occurs whether or not mesh is enabled.I also tried the 0.8.xxxx firmware and had the same result. I have tested multiple network cables without any change in behaviour. I've also tried a different switch on guest with no success.

I have one primary SSID directed through the Eth0+POE ports, and two guest SSIDs directed through ETH1. For now, I am running my primary SSID on both APs, and limiting my guest SSIDs only to the AP43, with the dashed blue cable disconnected for the AP41. However for proper coverage I do need guest SSID's broadcasting through both APs. I prefer not to use VLAN tagging on eth0 because I'd have to modify my entire network structure and revise all my firewall rules. It is set up this way for legacy reasons.

I've contacted mist support but hope someone here can helpe also figure this out!

What else do you need to know?

Thanks, in advance.
 

degrub

Very Senior Member
Not familiar with their gear, but the only time i saw that kind of behavior was when i had an ethernet loop. Do the APs talk to each other and might they be trying to arbitrate by rebooting ?

To run mesh, do you have to force the AP43 to act like a 41 ?
 

tiwing

New Around Here
An Ethernet loop. Interesting thought. I'll have to poke around tomorrow and confirm my wiring. Luckily it's 99pct exposed. Right now they are not set up in mesh mode so I presume they don't talk to each other. But there's lots going on that I just don't understand too!

I've read with the correct and matching firmware that mesh should work, but I'm trying first to get them working without mesh.. Tty to keep as simple as I can to trouble shoot.

Thanks for the loop idea.
 

tiwing

New Around Here
Just to close on this, I replaced the "guest switch" with a managed switch and the APs are stable. I suspect it was some sort of loop, as suggested, caused by a very cheap consumer switch.

Thanksnfor your help!
 
Similar threads
Thread starter Title Forum Replies Date
M Strange network issue, faulty switch or possible other issue? Other LAN and WAN 4

Similar threads

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top