Surfshark VPN refusing to start.

  • ATTENTION! As of November 1, 2020, you will not be able to reply to threads 6 months after the thread is opened. Threads will not be locked, so posts may still be edited by their authors.

stagger321

Occasional Visitor
Hiya.
On my Merlin f/w 384.19 Asus RT-AC86u I have been running with privateinternetaccess VPN for a while now.
It expires this week, and have decided to try Surfshark.
Followed the instructions on the site for ASUS and Merlin configs, but no joy when installing different .ovpn files.
Have also been through this with the Surfshark admin via chat for a looooong time and he see no issue with my config, nor the Surfshark credentials (which I have tried regenerating).
I have tried using the 'Connect to DNS automatically' setting on the WAN page, and also tried inputting the DNS servers Surfshark recommend. No joy.
It says its connected - but no internet for clients.
Has anyone got Surfshark working on one of these routers, and if so, were there any specific hoops you had to jump through??
Thanks
 

stagger321

Occasional Visitor
An update. So I have completely flattened the router and reconfigured and got it back on the internet - with no VPN.
When I try and import the Surfshark .ovpn file, it does not fill in the Certificate and Static key in the 'Keys and Certificates' panel, despite them being in the .ovpn file.
So I manually insert these, and hit save. When I then hit Apply on the VPN Client page and look back in the 'Keys and Certificate' panel, its empty ??? WTF?
 

Mr Tvardovsky

New Around Here
Hi there, I am a Surfshark subscriber and have 3 servers configured on my RT-AC66U B1 (which I use occasionally). I confirm I can connect to them without issues and all my clients can access internet. Also the Certificate and Static Key are correctly visible in the 'Keys and Certificates' panel.

The only kinda strange thing in my setup is associated with the DNS settings. I use the NextDNS CLI app (this one is permanently enabled) and it seems to override to VPN Client settings no matter what option I choose in "Accept DNS configuration". Even when I set it to "Exclusive" which (as far as I understand) should force all clients to use the Surfshark servers, the page https://surfshark.com/dns-leak-test shows I am still on NextDNS. When I disable the NextDNS in CLI, then there is no "leak" and I am on Surfshark DNS servers. But this seems to be a different story than yours and probably more related to NextDNS.
 

stagger321

Occasional Visitor
Hi Mr Tvardovsky.
Thanks for the reply.
So after much messing and a few reboots, I finally have the Keys/certificate panel filled and it will finally save. Phew.
Looks like the empty datasets were getting cached to the router.... maybe, a one if the reboots fixed it.
Anyway I have the Surfshark setup in place, although at this point it's quite flakey, up and down speedwise. We'll see how it goes over the next few days.
I haven't looked into the DNS leak side of things, but will bear what you say in mind.
Last week after buying 2years subscription to Surfshark, I did get it running, but the whole router config was not good, often requiring a reboot, hence I did a router reset today.
I did see DNS leaks last week, to my ISP, and I assume I will see these again, when I check.
Thanks.
 

JT Strickland

Senior Member
Their instructions for configuration with merlin leaves a lot to be desired, but surfshark has been very stable and consistent with me. I switched to them long before my windscribe ran out. They went downhill very fast with me, but surfshark has been a solid performer for more than 3 months.
 

stagger321

Occasional Visitor
Thanks. That's good to know @JT Strickland
From what I can see the instructions for Merlin are wrong in places. I assume they are old and need upgrading.
One question - what do you have in your VPN Client config, and did you follow the instructions for Merlin on the SUrfshark website, or just load the .ovpn file and add your username and password?
As you note, the instructions are wrong/different and for instance what is shown on for the 'Custom Configuration' at the bottom of the page is completely different to what the config file automatically populates.
Thanks in advance.
 

JT Strickland

Senior Member
I loaded the *.opvn file and filled in username and password. At first I was trying too hard to follow it like a cookbook, but the only parameters that are critical are the four or so that they have highlighted or marked. They should have said that somewhere. A lot of the settings are up to the user as to what works best.
 

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top