Trying to keep my wifi speed high

  • ATTENTION! As of November 1, 2020, you are not able to reply to threads 6 months after the thread is opened if there are more than 500 posts in the thread.
    Threads will not be locked, so posts may still be edited by their authors.
    Just start a new thread on the topic to post if you get an error message when trying to reply to a thread.

Jeff Tran

New Around Here
Hello everyone
Been lurking for a few days but cannot quite find or understand the answer to my question so I figured I post about and start a discussion.

posting here because it is a wifi issue using multiple branded routers.

Some background (attached a PDF of my setups as a visual).
Home is prewired for CAT cables all the around house with the main hub being in the closest in the master bedroom (upstairs).
3 routers in the home: ATT Motorola BGW210 (router modem combo), Asus AC5300, Asus RC68U.
I have ATT gigabit internet. 1gb up and down speeds.

Original issues:
I have deadzones and weak connection issues. So I am trying to use all 3 routers in a way so I can expand my coverage, have seamless connection (roaming), while maintaining the highest level of speed

1st, I tried to see if i can live with just 1 router. ATT router/modem combo in the middle of the home.
Did not work, created deadzones and weak connections issues.

2nd, put the ATT router/modem back in the closet with its WIFI off and used the ATT router/modem combo as the main lan router. Hardwired the ATT router/modem to the Asus AC5300 router in the middle of the home.
Did not work, created deadzones and weak connections issues.

3rd, put the ATT router/modem back in the closet with its WIFI off and used the ATT router/modem combo as the main lan router. Hardwired the ATT router/modem to the Asus AC5300 then used the Asus RC68U as an wireless AP (AiMesh). Wifi roaming worked flawlessly.
Worked but not optimally. The Asus routers were limited in speed, they were both cut down to 100mpbs, 10% of my actually full speed. did not like this. Still had 1 area of the house not fully covered.

What I believe the best solution is to use the ATT router/modem combo as the main router (wifi on) and use both the Asus AC5300 & Asus RC68U as an hardwired APs.

So I began setting this best solution up.
I put the ATT router/modem back in the closet and hardwired my Asus RC68U. set up the Asus RC68U as an AP. however, there is a Wifi Roaming issue. currently connected to the ATT router via wifi. as I walk away from the ATT router and walk towards the Asus RC68U. the connection between my devices (tablet and phone) are very weak with the ATT router. speeds at <1 mbps. at this point, I am standing right next to the Asus RC68U yet the wifi does not switch over.

the SSID and password is exactly the same between the ATT router & Asus RC68U.

any ideas on what I should do? or if I did anything wrong?

need help...

(side note: I did not try the Asus AC5300 because all my smart devices are connected to it. I am not gonna change it and screw up my whole house network until i know it will work.)
 

Attachments

  • wifi diagram.pdf
    121.9 KB · Views: 95

degrub

Very Senior Member
the client determines when the switch occurs between access points, not the AP.. the behavior you saw is normal.
You can reduce the power in the ATT box to help this occur sooner.
You may want to use only 5GHz band if all your clients support it. Turn off 2.4 GHz unless you have to have it. Too much interference from nearby APs.
 

DTam

New Around Here
I have a similar setup with AT&T combo modem/router and 2 personal routers(RT-AC86U and R7000).
What I did was disable the wifi on the att device. The att modem combo is wired directly into the 86U wan port. Nothing else is connected to the modem other than the 86U.
The R7000 is setup as AP which is wired directly into the 86U. Within the 86U I have the ability to release the client if the signal drops below a set threshold. So when walking way from the 86u devices should drop off and connect to the R7000 AP.
 

Jeff Tran

New Around Here
the client determines when the switch occurs between access points, not the AP.. the behavior you saw is normal.
You can reduce the power in the ATT box to help this occur sooner.
You may want to use only 5GHz band if all your clients support it. Turn off 2.4 GHz unless you have to have it. Too much interference from nearby APs.
I have a similar setup with AT&T combo modem/router and 2 personal routers(RT-AC86U and R7000).
What I did was disable the wifi on the att device. The att modem combo is wired directly into the 86U wan port. Nothing else is connected to the modem other than the 86U.
The R7000 is setup as AP which is wired directly into the 86U. Within the 86U I have the ability to release the client if the signal drops below a set threshold. So when walking way from the 86u devices should drop off and connect to the R7000 AP.

for me to do your option, i would need to buy another ASUS router and put that in the closet too and set the new ASUS as the AiMesh router/main router. and the other ASUS (hardwired) to be AP's. I would hate going because that means i would have to sell out another $100+ for a router. why do that when i have a perfectly new one (att router/modem) sitting in that exact spot.

reason why i have to use the closet is because all the rooms... the wires all meet in the closet. grand central station for trains. and sadly, the closet/hub/grand central station is NOT in the middle of the house.

anyone know how to set the threshold on the ATT gateway router/modem?
 

DTam

New Around Here
for me to do your option, i would need to buy another ASUS router and put that in the closet too and set the new ASUS as the AiMesh router/main router. and the other ASUS (hardwired) to be AP's. I would hate going because that means i would have to sell out another $100+ for a router. why do that when i have a perfectly new one (att router/modem) sitting in that exact spot.

reason why i have to use the closet is because all the rooms... the wires all meet in the closet. grand central station for trains. and sadly, the closet/hub/grand central station is NOT in the middle of the house.

anyone know how to set the threshold on the ATT gateway router/modem?
Do you need 3 full routers? both your existing asus wont be adequate? From reading people's experience aimesh isn't that great. You are better off using the old wired AP method if possible.
 

Jeff Tran

New Around Here
Do you need 3 full routers? both your existing asus wont be adequate? From reading people's experience aimesh isn't that great. You are better off using the old wired AP method if possible.

Ya, I tried the 2 router method in my home. it leaves weak/slow connections in some places and 1 of the rooms a deadzone.

the 3 routers really works best. how do i know? I tested coverage with 3 different routers, 3 different wifi SSID's. each time I manually connect to the closest router. speed and signal strength is very high. speeds are above 300mbps.

So I tried the old wired AP method with the ATT router/modem and Asus RC68U.
Roaming/wifi switching is not working. even if i am standing right above the Asus RC68U, the device is still connected to the ATT router/modem, very weak though. any idea on how to change the threshold?
 

DTam

New Around Here
Ya, I tried the 2 router method in my home. it leaves weak/slow connections in some places and 1 of the rooms a deadzone.

the 3 routers really works best. how do i know? I tested coverage with 3 different routers, 3 different wifi SSID's. each time I manually connect to the closest router. speed and signal strength is very high. speeds are above 300mbps.

So I tried the old wired AP method with the ATT router/modem and Asus RC68U.
Roaming/wifi switching is not working. even if i am standing right above the Asus RC68U, the device is still connected to the ATT router/modem, very weak though. any idea on how to change the threshold?
I looked thru my menu on the BG210. It's very limited. That's one reason I disabled the wifi and used an external router to have more control.

Perhaps you can try 2 routers again but play with the broadcast channels to get a better signal?
 

det721

Part of the Furniture
I looked thru my menu on the BG210. It's very limited. That's one reason I disabled the wifi and used an external router to have more control.

So your doing a double NAT.
 

DTam

New Around Here
So your doing a double NAT.
Yes, this is true. Never had problems so I never enabled passthru on the BGW210.

There's only 1 ip assigned from the AT&T modem combo. And that's my ASUS 86u router.
Within the 86u I am assigning ip's in the range of 192.168.50.x. From any computer on my network I can get to the AT&T router using 192.168.1.254 then also get to my 86u using 192.168.50.1. The R7000 setup as a wired AP has a static IP of 192.168.50.100. I can also get to that directly from any device on the network as well.
 
Last edited:

det721

Part of the Furniture
Understand. it's just unfortunate that ATT does not supply a full bridge mode to prevent double Nat using your own better router. If you have there fiber you can bypass the gateway and take it out of your network all together.

Been doing that here for over a year.
 

DTam

New Around Here
I don't think I'll be getting the fiber option anytime soon. I'm on the 50Mbps plan with dual lines sync'd at 30 and 29. According to the tech I am also maximum distance from the box for the 50Mbps profile. Only other option is comcast but the upload speeds are horrible.


Anyways back to the OP.. How big is your house and what is the layout?

I've helped friends setup similarly in 2500sq ft+ 2 story houses and the wifi is pretty acceptable using combinations of 2 normal $100-$150 range AC routers. One as router and the secondary as a wired AP.
 

det721

Part of the Furniture
I hear you bro. Good luck i use to have there uverse DSL before they upgraded to FTTH. I was on the 25/10 plan it worked ok never had it go down.
 

det721

Part of the Furniture
From your pdf file: "Gigabit wifi range but not at gigabit speed"
Close to Gigabit WiFi only with 4x4 AC client and 10ft around the router with no obstacles.
Real life expectations explained here - https://www.duckware.com/tech/wifi-in-the-us.html

I agree with that article. I have gigabit service but over wifi 5 Ghz i can only max 520 mbps max. I believe a lot of the slow down is client devices and interference. Sometimes only get upper 400's but that to me is acceptable for wifi.
 

L&LD

Part of the Furniture
It's not the '100' difference in the class. It's the AC vs. newer AX and other differences too (even with AC clients).
 

K-2SO

Very Senior Member
It's not the '100' difference in the class. It's the AC vs. newer AX and other differences too (even with AC clients).

It was a joke. We'll never see 3Gbps from those routers. You know how router class marketing works.
 

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top