Unable to port forward (specifically port 80 and 443) on RT-AX58U

  • ATTENTION! As of November 1, 2020, you are not able to reply to threads 6 months after the thread is opened if there are more than 500 posts in the thread.
    Threads will not be locked, so posts may still be edited by their authors.
    Just start a new thread on the topic to post if you get an error message when trying to reply to a thread.

cxmachi

New Around Here
I'm on an RT-AX58U and on asuswrt-merlin 384.19. I also tried on stock firmware and from a factory reset. Same issues.

I'm trying to port forward the following:

1604389731595.png


Before anyone asks why I'm forwarding these, it's for a reverse proxy (a LetsEncrypt+nginx docker on my NAS). It's for accessing a couple of dockers/apps remotely. Not really interested in changing my setup, so hopefully we can stick to getting the port forwarding working. This works perfectly fine on my old router that I'm looking to replace with the AX-58U (mostly for better wifi performance on my Wifi 6 devices).

Things I've checked:

- the WAN IP is definitely my real external/public IP, not behind a CGNAT
- 192.168.1.101 is the NAS hosting the docker containers and the correct IP to be redirected to
- ports 80 and 443 is NOT blocked by my ISP (as mentioned, the port forwarding works fine in my old router)
- AiCloud is NOT turned on. I even made sure to change the port its using to not use 443, but I doubt it matters since it's not on
- AiProtection and all the extra features are NOT turned on
- Enable Web Access from WAN is disabled
- Firewall is enabled (defaults)
- DMZ is disabled (defaults)
- Just to try something random I even set the webUI to use port 81 and it didn't help
- It appears that the router will just not release and let me do any port forwarding on these two ports
- uPnP is working fine (my Plex server is accessible remotely for example)
- Tried reflashing the stock firmware
- Tried a factory reset from the webUI
- Also tried a physical factory reset with the button on the back

I'm kind of at my wit's end here and would love to get some help. For now, I've reverted back to using my old router and the ports are properly forwarded there and working correctly. Searching the forum, I've also seen this issue posted 2 years ago, but there was never any actual solution: https://www.snbforums.com/threads/rt-ac86u-will-not-fwd-wan-port-80-443-to-lan.48926/
 
Last edited:

L&LD

Part of the Furniture
When you tried a factory reset, did you minimally and manually configure the router (M&M Config)?

Depending on what answers you get, you may want to also try the latest Alpha 2 for your router based on 386.1 code base.

 

cxmachi

New Around Here
Yup, after the factory reset, all I did was go through the initial setup, change the IP and DHCP range, then port forward the 2 ports. (new here so I'll assume that's what you meant)
 
Last edited:

ColinTaylor

Part of the Furniture
If you set the external ports to something other than 80 and 443 (perhaps something above 1024) does that work? In other words, can you not forward any ports?

Have to tried forwarding a port to something other than the NAS?
 

det721

Part of the Furniture
When you tried a factory reset, did you minimally and manually configure the router (M&M Config)?

Depending on what answers you get, you may want to also try the latest Alpha 2 for your router based on 386.1 code base.


There is no 386.1 for the AX58U
 

L&LD

Part of the Furniture
@det721, yes, not currently. But it should become available in the next few hours or a couple of days (my guess). :)

Btw, I need it too...
 

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top