Unable to upgrade from 386.x to 386.x

  • ATTENTION! As of November 1, 2020, you are not able to reply to threads 6 months after the thread is opened if there are more than 500 posts in the thread.
    Threads will not be locked, so posts may still be edited by their authors.
    Just start a new thread on the topic to post if you get an error message when trying to reply to a thread.

Morac

Senior Member
I figured rather than pollute the 386.1 thread I’d create a new one and see if anyone had any ideas.

I had been running Merlin 384.19 on my RT-AC88U and upgraded to 386.1. I got a couple of lockups so I decided to do a factory reset, clear NVRAM and JFFS and set things up from scratch.

Things were well until I tried to upgrade to 386.1_2, which failed because the router said the firmware was invalid, so it failed whatever check ASUS on a firmware upgrade. It did the same thing when I tried to upgrade to the 386.2 alpha. It succeeded when I re-flashed to 386.1, which was already installed.



I tried all the following with the same result:
  1. Removing USB thumb drive and rebooting.
  2. Factory reset through the UI, clearing NVRAM and JFFS and skipping setup and going to upgrade page.
I then decided to try flash the official ASUS firmware from https://www.asus.com/us/Networking/RT-AC88U/HelpDesk_BIOS/ which is currently 9.0.0.4.386.41994. That also failed.

At this point I decided to use the Rescue Tool and flash 9.0.0.4.386.41994 which worked. I then tried flashing 386.1_2 which failed, but so did trying to flash 386.1_0, which had previously worked. I also tried factory resetting and that still failed.

On a whim, I flashed 384.19 which worked! I was then able to flash 386.1_2 successfully.

As such it seems like the only way to flash a new version of 386.x on my RT-AC88U is to downgrade to 384.19 first, but I have no idea why that would be.

I don‘t use QOS or any of the Trend stuff. I also don’t use any advanced features of the router or have any custom scripts or anything else installed.

I normally have at least 378 MB memory free.

Any idea what’s wrong?
 
Last edited:

noah way

Regular Contributor
68U / 384.19 froze on boot after 386.1 update. Had to reset twice to get it working. Now it's running smooth and fast. Looks like the connection increased > 50 Mbps.
 

Morac

Senior Member
68U / 384.19 froze on boot after 386.1 update. Had to reset twice to get it working. Now it's running smooth and fast. Looks like the connection increased > 50 Mbps.
Doesn’t seem related to my issue as I have no issue upgrading from 384 to 386. The problem I have is 386 to 386.
 

PeterR

Regular Contributor
Adding to this thread, yesterday I had a similar problem with 'Invalid Firmware Upload 'upgrading an AC68U from 386.1 to 386.1_2. I double checked the firmware download was correct and the checksum and tried a different browser - tried both Vivaldi (Chrome) and Firefox; I was using a laptop running Archlinux. I decided to put the task aside, in the hope that maybe somebody would add some information to this thread.

Today I tried to upgrade again using a laptop running Windows 10 & Firefox, it went without a hitch.
 

Morac

Senior Member
The computer I was using was a Windows 10 laptop. I tried both Firefox and Edge.
 

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top