What's new

USB issue

  • SNBForums Code of Conduct

    SNBForums is a community for everyone, no matter what their level of experience.

    Please be tolerant and patient of others, especially newcomers. We are all here to share and learn!

    The rules are simple: Be patient, be nice, be helpful or be gone!


New Around Here
Running the lastest version of Merlin on my Asus RT-AC3100. Runs well but having an issue with a new USB drive. Picked up a cheap ($30) 2 drive USB 3.0 enclosure to handle a couple extra drives I had lying around. Thought it would work well to run media on one of them and backups or something on the other. Not running RAID or anything fancy, just shows up as 2 unique drives when you plug it into a computer.

I plugged it into my router and it just keeps refreshing the admin page. Also seems to be running the CPU high, so something seems to be happening. Wondering if this is just not supported or is there some setting I need to change or what? It seems like it's trying to do something as once in a while I will see the drive mount and it will have a dropdown option to toggle between the drives. I can't do anything as the page refreshes a few seconds later and the drive is no longer mounted. Would be really cool to figure this out. Appreciate any help the community can offer.
Hi, sounds like a power issue or a wrongly initialized disk (could be unsupported or corrupted file system also). Do the enclosure have a separate power supply ? is it connected ? once discarded the lack of power possibility, next I would do is initialize/format the disk/enclosure in a PC with a supported file system and try again to plug it in the router port.
That was it! Primary drive came right up, now how to get them both to mount? Thank you!
OK, so now I think I found the issue but no idea how to fix it. I plugged the drive back into my computer, ran check disk a few times and reformatted both drives just for fun. Seems fine on my computer but when I plug it back into the router, I get this in the error logs.

Jun 5 22:07:48 kernel: sd 1:0:0:1: [sdb] Unhandled error code
Jun 5 22:07:48 kernel: sd 1:0:0:1: [sdb] Result: hostbyte=DID_ERROR driverbyte=DRIVER_OK
Jun 5 22:07:48 kernel: sd 1:0:0:1: [sdb] CDB: Read(10): 28 20 00 00 00 00 00 00 08 00
Jun 5 22:07:48 kernel: end_request: I/O error, dev sdb, sector 0
Jun 5 22:07:48 kernel: Buffer I/O error on device sdb, logical block 0

Any ideas?
My guess would be that the hardware is simply not compatible. It can't even read sector 0 of sdb. Presumably the first disk is still mounting OK as sda?
It is. Kinda odd but ok. I'll see if I can swap disks around or try just the single drive to see if that works.
Not sure if it we are experiencing the same thing but I to have a couple SATA3 drives that I'd like use to serve media around the apartment. So I plugged my powered USB 3.0 docking station up to the my RT-N66R and everything worked kind of fine. I think I was changing some settings and rebooted the router and got nothing, the media server was activated in the menu but not present on the network. After banging my head against the wall changing settings and rebooting the router and reflashing FW and testing everything I could think of, I finally ejected the drive from the Asus menu, powered off the hub/dock so the drives were completely powered off. Then I rebooted the router and let it fully boot, once it was fully booted, I powered the drives up and bingo the media server popped up on all my network devices.
Maybe the router needs all the resources available to get the server going and it fails because its competing with other settings like vpn and ad blocking ect. There is probably a script that could be run at boot to delay launching the media daemon and usb scan until after all other boot up processes are complete. Not saying I right just mentioning it for those that have the expertise to chime in. Have a good one.
Also had to put all my music closer to the root of the drive.
Seems that the router makes a /tmp/mnt/path to media....... a couple more layers to the database that minidlna could not handle. Its funny cause it worked the first time like a charm then after a reboot everything went to ish.

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!