What's new

ZenWifi XT12 HW issue ?

  • SNBForums Code of Conduct

    SNBForums is a community for everyone, no matter what their level of experience.

    Please be tolerant and patient of others, especially newcomers. We are all here to share and learn!

    The rules are simple: Be patient, be nice, be helpful or be gone!

Ola Malmstrom

Regular Contributor
About a week ago, one of my PCs started to have problems connecting to the internet. After switching it on, it takes about 30-90 seconds until it connects correctly. This is a large difference since it used to be almost instantaneous.

At first I thought there was something with the wifi connection - so I tried to find something there - but to no avail.

However, today I experienced exactly the same behavior on my other PC - which is connected to the router with an Ethernet cable.

There is nothing in the log files that looks suspicious, ie lost WAN connection or similar. The router seems to transmit the SSIDs correctly.

Could there be a HW issue in the router?

I still have the old router and can easily replace the XT12 - however does anyone else have similar experiences?
The latest Merlin firmware - 3004.388.5. Downloaded and installed on December 4th.

I'm pretty sure the issue appeared before the upgrade. I thought it was a temporary glitch of some kind on my portable PC.
Have you tried the latest stock firmware 24177?
Reason I ask is the latest GPL merged into Merlin was 23588 so I don't think his firmware has the fixes in the latest stock 24177.
Last edited:
Thanks for the suggestion!f

No, I haven't tried it yet.

However I replaced the XT12 with the old router running Merlin 388_2.2. It took only a couple of minutes. This seems to work fine for now.

Update: The morning after, the PCs still connect immediately as they should. However channel 128 had been changed to 36 although the transmit signal strength is now 14 instead of 23 as it used to be on the XT12.

So it might be the FW, it might be the router HW. I'll wait until the next Merlin release, then update the XT12 with the new FW and replace the old router with the newly updated XT12. This way, I don't need to do a complete reset of the XT12. If it works as it should then, it was the FW.
Install stock then reset and manually setup again.
Do not use any backup config from Merlin firmware.
OK thanks! The issue seems to be gone......

I tested the router after installing the new stock FW and BEFORE doing the reset.

It seemed to work fine, so I left it. Everything seemed to work except my two OpenVPN servers. Guess I need to see if I can live with one of them for a while until there is a new Merlin version based on 24177.
Last edited:
So.... it happened again. Couldn't connect my PC with ethernet connection to the router. It took several minutes to connect correctly. In the meantime, all other clients lost internet.

This is the same problem as before..... Is this an indication that I have a HW problem or is there something else going on?

As I wrote before, I am now using stock FW 24177.

The ONLY thing I can see in the log files is a notification about "RT throttling" about 20 lines from the bottom. As far as I understand, this may be caused by some kind of network problem.

The router is connected to 2 switches. One 2.5 Gbps, one 1 Gbps. Only clients supporting 2.5 Gbps are connected to the 2.5 Gbps switch.

I have about 30 clients connected in total. Some 2.4, some 5 GHz, some ethernet. WAN speed is 1000/1000.

To avoid the problem I have switched back to my trusted old AX88U.

I have performance set to max on channel 128 with 80 MHz bandwidth. For the XT12, this means 25 dBm (316 mW), for the AX88U I get 21 dBm (125 mW) measured with the analiti tool. But.... why this should affect the connection with an ethernet cable is beyond me.

So now to my question..... should I take the XT12 back to the supplier and request something else? Maybe an AX86U Pro or an AX88U Pro if they are still available? Or should I just return the XT12 and get my money back? Maybe get a BE router next summer or so instead?
Aha.... searched some more, both within this forum and otherwere. Seems like a known issue. RT Throttling means Real Time throttling. No wonder it affects all connections since it has to do with the CPUs getting overloaded. Still haven't found a solution though.
Did this issue get fixed with newer merlin?
It disappeared. I put the XT12
back and installed new Merlin fw when it became available. Has worked very well since then.

Latest threads

Support SNBForums w/ Amazon

If you'd like to support SNBForums, just use this link and buy anything on Amazon. Thanks!

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!