Zyxel NWA210AX

RacerX330

Regular Contributor
I finally took the plunge and bought a 2.5gbit POE switch and the Zyxel NWA210AX for the new house. Boy am I sorry that i did. This is truely THE WORST WAP I have ever used or tried to configure in my life. It is utterly unintuitive and maddenly frustrating. Refuses to netgotiate a 2.5gbit link, with high quality cable and less than a 25ft run. Constantly blinking green led, even though the default WIFI settings are not active. If you configure it even ONCE on nebula, the absolute horror show or getting it back into standalone mode would infuriate even the most patient human. I absolutely hate this thing.
 

Tech Junky

Very Senior Member
Well, that's disappointing. I have one and have none of those issues. @tgl also has one. Using nebula isn't the preferred method sincr there's a subscription tied to it after the first year.

Just default it using a paperclip on the back and it's will go back to standalone mode. If it doesn't then login to nebula and remove it from the dashboard and try again.

As to the port speed set the speed manually and make sure it's in the right port on the back being the yellow one. Being that it's not a consumer AP it's not going to be point and click beyond basic settings. Once it's up and running though you can dive into the web GUI and tweak things under settings.
 

RacerX330

Regular Contributor
I managed to finally remove it from the nebula config online. Reverting is back to standalone mode, but it was a pain. I do not see anywhere to set the link speed manually, and yeah it's plugged into the yellow socket. The constant green led blink is extremely annoying. There are entirely new security, radio, and ssid profiles, so nothing is default.
 

RacerX330

Regular Contributor
turns out if the string "default" is in the ssid profile name it thinks it's part of the default wifi setup and the led blinks, so that problem is solved. gonna have to make another cable tomorrow and try to solve the link speed problem. if it still can't negotiate 2.5gbit, then i'm just gonna send it back. The switch I purchased is the trendnet 2.5gbit unmanaged 5-port poe switch (TPE-TG350). It's having no issues negotiating a 2.5gbit link speed to the LAN interface on the pfsense box.
 

Tech Junky

Very Senior Member
Green light should just be solid or you can turn it off completely.
Blue light indicates 5ghz looking at DFS

Anyway... look in the logs to see if there's an issue with something.

I find it easier to manage things on it from the CLI over SSH though. You can pick apart the config and slim it down to only what's needed. You can also set the port speed manually from there.

Code:
port status UPLINK
 speed 2500

or 

port status lan1
 speed 2500

There's a whole lot less clutter in the CLI than through the GUI. The GUI is just nice for glancing at the overall status or setting the basics and then editing from the CLI. There tends to be a lot of macros though that clutter up the CLI config that can be cleaned out. I took the running-config and put it into notepad++ and then stripped it down to the basics and saved it to the AP through the GUI and apply it when things go sideways in the past with firmware updates.

Currently running:
firmware version: V6.40(ABTD.6)
build date : 2022-07-14 04:02:31
1664686669173.png

 

Tech Junky

Very Senior Member
Looking at the GUI there's no option to manually set the link speed which could pose a problem, Though the manual setting of it in the CLI removes the negotiation BS you have with most switches.

1664687003436.png


Upper right side of the GUI has the CLI link provided by its internal server but that's limited to some basic show commands vs opening a SSH session with putty or some other terminal program.

Code:
configure terminal
port status UPLINK
 speed 2500
end
copy running-config startup-config

Also, you can change the login credentials to something you'll use vs the basic admin / password account it comes setup with.
 

RacerX330

Regular Contributor
yeah it's solid green now, thank goodness lol.

yeah very strange that the GUI is reporting that lan1 is 1000mbit, but that port is not plugged in, and i doubl checked it. the yellow plug labeled uplink is plugged in.
 

RacerX330

Regular Contributor
nevermind, under Network Status, is says UPLINK.


so I just put those 3 lines in the conf files and reupload them? the order of the commands in the configs doesn't matter?
 

RacerX330

Regular Contributor
Looking at the GUI there's no option to manually set the link speed which could pose a problem, Though the manual setting of it in the CLI removes the negotiation BS you have with most switches.

View attachment 44539

Upper right side of the GUI has the CLI link provided by its internal server but that's limited to some basic show commands vs opening a SSH session with putty or some other terminal program.

Code:
configure terminal
port status UPLINK
speed 2500
end
copy running-config startup-config

Also, you can change the login credentials to something you'll use vs the basic admin / password account it comes setup with.
when i run this code in ssh putty it gives me a parse error after word UPLINK
 

Tech Junky

Very Senior Member
when i run this code in ssh putty it gives me a parse error after word UPLINK
Then use

port status lan1
speed 2500

If you do a show running-config it will give you the names of the ports.

It's a bit dumb that they don't just use the port names vs named ports.
 

RacerX330

Regular Contributor
it added it to the running-config though, weird

Code:
port status lan1
 loopguard
 pvid 1
 speed 2500
!

can i just do configure terminal and then the copy comands and reboot?
 

RacerX330

Regular Contributor
yeah that didn't work, it still negotiated a 1gbit link speed so i manually downloaded the startup config and added

port status UPLINK
speed 2500
!

then reuploaded and rebooted

and it completely barfed and reverted back to the old config

this is disappointing because when i originally set it up it did connect at 2.5 and now it just refuses
 

Tech Junky

Very Senior Member
Ok... do a "show running-config" and then just add the "speed 2500" under the interfaces that start with "port status"

Might help to reboot the switch.

Instead of DL / UL the config just do it from putty. Once you have a working config then save a copy.
 

RacerX330

Regular Contributor
yeah the only "port" entry in the running-config is:

Code:
port status lan1
    loopguard
    pvid 1
    speed 2500
!

I have powered down and powered up the switch multiple times and that doesn't seem to help at all, it just keep negotiating at 1gbit.

I may have to just make another cable and see if that is the problem, which seems odd since it has connected over this cable at 2.5gbit before. The other issue is that the existing cable (WAP to switch) was laid when the house was built, so changing it out will be a huge pain in the ass. I don't know why it's not cooperating, it's about a 35ft run on CAT6E 600Mhz, which should be just fine.
 

Tech Junky

Very Senior Member
Why not take a shorter cable to just test before diving into rewiring the house?

I just use a cat6 and no issues. It's not supposed to negotiate anything though when you set the speed on the AP. That's the point of doing so.

Do you have a mGIG port on something else to test with besides the switch? I use a 5GE NIC and also have a 5GE USB dongle for testing and normal file copy duties. Always nice to have backups for testing. It really does seem to be the cable though for whatever reason. Maybe try cleaning the connectors to see if there's maybe some gunk on them preventing the desired speed.
 

RacerX330

Regular Contributor
I examined the sockets of the switch and the WAP, and the connectors on both end of the cable, and I didn't see anything in there or on them. I cleaned them off just in case as well.

Yeah I am making another cable just for test purposes right now.

I tried setting the link speed in the running-config. Maybe I'm not doing it right?

Here is the entire running-config

***REMOVED-FOR-SECURITY***
 
Last edited:

RacerX330

Regular Contributor
Hmmmm

I ran "show port setting" on SSH and here was the output
Code:
Router> show port setting
Status      Name     Port VID    Negotiation Duplex Speed
===============================================================================
Active      UPLINK   n/a         auto        full   1000
Active      lan1     1           disable     full   2500

Here's the output from command "show port status"
Code:
Router> show port status
Port Status     TxPkts     RxPkts     TxBcast    RxBcast    Colli.  TxB/s      RxB/s      Up Time      PVID       TxBytes              RxBytes
=================================================================================================
1    1000M/Full 135349     367041     813        9          0       2634       8011       00:12:32     1          12409023             532227047
2    Down       0          0          0          0          0       0          0          00:00:00     1          0                    0
 

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top