What's new

2.4ghz and 5ghz clients cant communicate with each other

  • SNBForums Code of Conduct

    SNBForums is a community for everyone, no matter what their level of experience.

    Please be tolerant and patient of others, especially newcomers. We are all here to share and learn!

    The rules are simple: Be patient, be nice, be helpful or be gone!

To confirm that this issue was not a problem with my laptop/WiFi network adapter I managed to get hold of a very old laptop using the 2.4GHz band only, and now I can see that this is seeing issues communicating to some of the 5GHz devices. I also installed "Ping IP" on an Android tablet using the 2.4GHz band, again I have issues pinging some of the 5GHz devices. My new laptop on the 5GHz band has no issues communicating to 5GHz devices, but cannot see any 2.4GHz devices when the problem occurs.

The only way for me to get all 2.4GHz and 5GHz devices to see each other continually/without issues is to reboot regularly as tbrig1 has suggested earlier.

One thing I noticed, Amazon Echo Dots do not reply to pings at all on both 2.4/5 GHz, this is the only device in the house that doesn't reply.
 
Some devices don’t allow icmp as a part of their software so that unfortunately can be a false positive but thanks for confirmation otherwise
 
I also have to report the same kind of issue: randomly I can't reach devices on the 2.4G wifi side of the router RT-AX86U (with 388.6 firmware). I can ping the device from the router itself, but I can't from 5G wifi or LAN. So I can ping 5G from LAN and reverse but I can't ping from 5G or LAN to 2.4G. After a router reboot, everything will work for a few hours then issue is back. I already tried the advices found here (like explicit/universal beamforming, isolated AP, airtime fairness) with no luck. Not sure when it started exactly (maybe 2-3 firmware ago) but i had no issue for years.
 
Try this.

Use the suggested solution from sfx2000,

& a Guest network (2), 2,4 GHz for the other clients, like a printer etc,
 
Last edited:
I've just tried to upload a photo from my Canon Powershot camera (which only has 2.4 GHz connectivity) to my laptop on the 5 GHz band, but the camera couldn't find my laptop on the network. The only way I was able to do it was to temporarily connect my laptop to the 2.4 GHz band, so there is definitely something amiss with the firmware at the moment.
 
I tried to report this to ASUS a few minutes ago. I wasn't too impressed with their support as I was told that I could not initiate a support request unless I had the serial number of the router to hand. The agent, who was very unhelpful, told me that I could obtain the router's serial number through the ASUS app, which doesn't seem to be the case. Also, he told me I had reported this to another agent, which I hadn't (and he then contradicted himself, because he said he couldn't see the details of my previous contact with the other agent!). The other annoying thing was, he wasn't interested for me to pass on a link to this thread, so that whoever picked up the case could review what we had already tried on this forum. I told the agent that it was probably a waste of time trying to report this matter as someone on this forum had already reported it and got nowhere.
 
Reminds me of the time I bought a (apparently factory wrapped) box of Sony "floppy" diskettes. 6 of them had little penciled Roman Numerals in the labels. It was the 6 installation disks for Windows 3.11, which was current at the time. Not a fan of MS but thought they'd be interested. Nope. Not a care in the world and nary a thanks for the heads-up. Nearly got castigated for the bother.

As a possibly pertinent point of reference I quite recently (this week) altered a radio setting on my router and found my thinkpad on 2.4 AX. Got ballpark 400 Mbps realized to any and every thing on any 5GHz radios I tried, and vice versa. Latest Merlin(s) on XT8s and a GT-AX6000.
 
I've set both networks to have the same SSID and so-far devices can communicate as normal.
 
Yeah, I'm not "meshing" but instead "AP"ing, using "same" SSID 2.4/5/5-1. No intercommunication issues yet noted.
 
I tried to report this to ASUS a few minutes ago. I wasn't too impressed with their support as I was told that I could not initiate a support request unless I had the serial number of the router to hand. The agent, who was very unhelpful, told me that I could obtain the router's serial number through the ASUS app, which doesn't seem to be the case. Also, he told me I had reported this to another agent, which I hadn't (and he then contradicted himself, because he said he couldn't see the details of my previous contact with the other agent!). The other annoying thing was, he wasn't interested for me to pass on a link to this thread, so that whoever picked up the case could review what we had already tried on this forum. I told the agent that it was probably a waste of time trying to report this matter as someone on this forum had already reported it and got nowhere.
Update: I've managed to get the serial number of my router, so I've just opened a support ticket with ASUS. I've also included a link to this thread in case they are interested in using any of this information to help them diagnose the problem. I'll post an update when I've had a response.
 
I did a roll-back to 388.2.2 and will wait until firmware is fixed, i can't live with a half broken network

Report it in Asuswrt-Merlin release threads so @RMerlin can take a look.

I personally can't reproduce the issue on RT-AX86U model. This is perhaps something Pro models specific.
 
It happens on official firmware and Merlin. Not sure if Merlin works directly with ASUS engineering but a roll back or reboot schedule seems like all we can do for now
 
Last edited:
It happens on official firmware and Merlin. Not sure if Merlin works directly with ASUS engineering but a roll back or reboot schedule seems like all we can do for now
Or perhaps do what I and others have done and set both SSIDs to have the same name. That has resolved my issue. I've also added a Wireless MAC filter so that only devices that cannot use the 5 GHz band are allowed to connect to the 2.4 GHz band. That keeps everything else than can connect to the 5 GHz band from straying onto the 2.4 GHz band.
 

Attachments

  • Wireless MAC Filter (2.4 GHz).jpg
    Wireless MAC Filter (2.4 GHz).jpg
    61.4 KB · Views: 27
Thanks for that. It’s still unclear to me why this would make a difference. I’ll set it up on my LAN and try it anyway.
 
I noticed that instead of restarting the router, just turn off and turn on WiFi 2.4 (enalbe radio option in the professional tab). You can also configure a schedule for turning Wi-Fi off and on (Enable wireless scheduler). Of course, this is not a long-term solution.
 
Or perhaps do what I and others have done and set both SSIDs to have the same name. That has resolved my issue. I've also added a Wireless MAC filter so that only devices that cannot use the 5 GHz band are allowed to connect to the 2.4 GHz band. That keeps everything else than can connect to the 5 GHz band from straying onto the 2.4 GHz b

Or perhaps do what I and others have done and set both SSIDs to have the same name. That has resolved my issue. I've also added a Wireless MAC filter so that only devices that cannot use the 5 GHz band are allowed to connect to the 2.4 GHz band. That keeps everything else than can connect to the 5 GHz band from straying onto the 2.4 GHz band.
Actually, it's only partially resolved the issue, because my Canon camera (on 2.4 GHz) has stopped connecting to my laptop again when my laptop is on the 5 GHz (it was working a few days ago) and yet my laptop (when connected on 2.4 GHz) can still communicate with my Canon printer on the 5 GHz band.
 
Must be infuriating... I, myself, have yet to be so plagued, but not recalling which models / firmware this pertains to I may never see such behavior.
 

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top