5GHz radio is disabled regardless of settings on my RT-ACRH12

  • ATTENTION! As of November 1, 2020, you are not able to reply to threads 6 months after the thread is opened if there are more than 500 posts in the thread.
    Threads will not be locked, so posts may still be edited by their authors.
    Just start a new thread on the topic to post if you get an error message when trying to reply to a thread.

datoda

New Around Here
I got the RT-ACRH12 a little over two months ago. It performed fine up until a couple of weeks ago, when I noticed that I couldn't get the higher 5GHz speed. I finally got a chance to troubleshoot today, and here's what I found:
1. The 5GHz WIFI LED on the router is OFF.
2. The system log reports "5GHz radio is disabled".
3. There's no wireless 5GHz Mac address for the router in the "System Status" panel.

I tried the following and the issue persists:
1. Reboot (many many times, both the 'reset' button approach and the WPS button approach)
2. Factory reset (many times)
3. Flip ON/OFF the 5GHz network (many times)
4. Upgrade/Downgrade firmware
5. Enable/disable QoS (some google result showed that doing this fixed a 5G issue for someone)

At this point, I am out of idea of what action could revive the 5GHz network on my router. Any bright mind here have any suggestion? Thanks.
 

det721

Part of the Furniture
Sounds like hardware failure your 5GHz radio is likely dead.
 

datoda

New Around Here
Sounds like hardware failure your 5GHz radio is likely dead.
Thanks. That's what I was afraid of. I chatted with Asus support and they issued an RMA. It appears to me that RMA would be at my own expense, though. I wonder what folks here think about Asus's repair service, and if it's going to worth my while (I paid $45 for the router and the shipping cost for the RMA will be around $15). Perhaps I should just leave it alone as an expensive 2.4 GHz only router? :)
 

L&LD

Part of the Furniture
I would not get it repaired at those prices for shipping alone.

Put your money towards a better router instead.
 

datoda

New Around Here
A quick update: I got the RMA for the router set up. Meanwhile, I got a $90 TP-Link router since and it's been much more stable and faster with wider coverage. I recently found Pirate Ship as a cheap way to send packages through USPS, and was able to price the RMA of this ASUS router for around $4 using 1st class package. Given that it's so cheap, I thought I'd give the RMA a chance. Before I packed it up, I gave the router one last try to make sure it's indeed broken. Surprise! The 5GHz light lit up 10 seconds after I plugged it in. I further confirmed that indeed the 5GHz wireless network was alive and kicking! One thing I did differently this time from when I first tried to diagnose/fix the issue was that I didn't have the WAN line input when I plugged in the power; I inserted the WAN line after the router was boot up (i.e. when both 2.4GHz and 5GHz lights were on). I suspected that the WAN input somehow screwed up the initialization of the router in my case.

To summarize the lessons I learned here:
1. Unplugged the WAN input when rebooting you ASUS router.
2. Use Pirate Ship (pirateship.com) to price the packages you are shipping. Disclaimer: I am not affiliated with pirateship.com. I used their service for the first time last week and am loving the clean web UI, great customer service, and the excellent pricing!

Hope these help!
 

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top