What's new

AC3100 5GHz not working

  • SNBForums Code of Conduct

    SNBForums is a community for everyone, no matter what their level of experience.

    Please be tolerant and patient of others, especially newcomers. We are all here to share and learn!

    The rules are simple: Be patient, be nice, be helpful or be gone!


New Around Here
Hello, just a lurker around here and finally registered to ask if anyone has seen a similar issue.

I've had an ASUS AC3100 sitting unused in the box for 2 years! Finally got around to getting this up and running on DD-WRT.

It was running fine for about 3 weeks before the 5GHz Wifi seems to have quit working properly. Multiple wireless devices no longer will connect to the 5GHz AP, when the 2GHz AP works well.

I have tried the following.
  1. used telnet to erase nvram and rebooted (same issue with 5GHz)
  2. updated to DD-WRT v3.0-r40167 std (06/30/19) (same issue with 5GHz)
I figured I'd try Merlin firmware, however, I cannot get it to install at all.
  • used DD-WRT GUI Firmware Upgrade page to flash Merlin firmware with .bin as the filename extension (boots back into DD-WRT)
  • used Recovery Mode web GUI to flash Merlin firmware (boots back into DD-WRT)
  • used TFTP to flash Merlin firmware when router is placed in Recovery Mode (boots back into DD-WRT)
  • used ASUS Firmware Restoration utility to try to flash Merlin firmware (the program just shows: The wireless router is not in rescue mode.)
I saw a thread where someone suggested flashing Merlin 378.55 first because it was under 32MB or something (it appears the oldest firmware I can find for download is Merlin 380.57).

I don't know what Bootloader CFE version the router is on. Would anybody like to point me in the right direction? Perhaps the 5GHz Wifi is damaged, in which case I would be willing to ship this router to whoever could put it to use since the Wifi is the main reason I bought it.
I'm going to go against my better judgement and bump this. On the plus side, I've learned to not let Asus Routers go past the warranty period before deploying them...

Sent from my Pixel XL using Tapatalk
So I have two of these routers on the same version of DD-WRT.

I just don't think the routers are good with DD-WRT since I've had some issues. I want to try Merlin firmware, but I seriously have no clue how to get them off of DD-WRT.

At this point, I would just give these units to a forum user (I would ask they cover shipping) if they are interested. That way the units could benefit humanity more than just by collecting dust on a shelf [emoji23]

If somebody wants to provide advice on how to recover these back to stock I am all ears. Otherwise, I'm happy to get these shipped off to a forum member!

Sent from my Pixel XL using Tapatalk
Nice, your solution worked! I think what was happening was that the firmware didn't want to update from ASUS recovery. I monitored traffic and noticed that the upload to the router would stop short of the entire file. After multiple tries, the firmware update uploaded in it's entirety.

So it appears that I am correct in my assertion that the 5Ghz WiFi on one of the routers isn't working properly. Even after flashing the latest stable Merlin firmware, the behavior I was getting on DD-WRT with 5Ghz still occurs. 2.4Ghz seems fine.

Basically the 5Ghz SSID will only broadcast some of the time. It's intermittent as far as I can tell. 5Ghz won't connect with the WiFi clients I tried.

Note that I hard reset after flashing ASUS stock, and I hard reset again after flashing Merlin.

The main reason I got these routers was for the 5Ghz WiFi. I expect that it would make an excellent router for wired use. The 2.4Ghz should be good though. Perhaps the 5Ghz WiFi could be fixed [emoji848]

I plan on using the unit that has working WiFi for now. I didn't think I could get off DD-WRT!

I'm happy to ship you the unit with the 5GHz issue for free. You can cover shipping costs if you like, but I'll let that be up to you to decide. I suggest testing the unit out for a while to make sure you can put it to use. I can provide my PayPal or whatever is easy if you decide to cover shipping.

Just send a PM with a ship-to address and I'll get this out the door ASAP [emoji106]

Sent from my Pixel XL using Tapatalk
Tarassippo, I probably should have quoted you in my post above just so you know that I was referring to shipping router to you.

Sent from my Pixel XL using Tapatalk
Hey, no wo worries, pleasure to help !

You may use the defective router for spare parts...

Which option worked, 1) or 2) ?
Hey, no wo worries, pleasure to help !

You may use the defective router for spare parts...

Which option worked, 1) or 2) ?
Right on, thanks for the help. Just had to flash the stock firmware TRX file with ASUS recovery.

It took several tries, but finally worked. I tried this before without success, but I found it worked when uploading the firmware file with as little delay as possible upon entering the recovery.

I looked at a teardown of the AC88U, it doesn't look like the WiFi can be repaired without replacing the whole board. Oh well...

Sent from my Pixel XL using Tapatalk

Similar threads

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!