1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
Dismiss Notice

Welcome To SNBForums

SNBForums is a community for anyone who wants to learn about or discuss the latest in wireless routers, network storage and the ins and outs of building and maintaining a small network.

If you'd like to post a question, simply register and have at it!

While you're at it, please check out SmallNetBuilder for product reviews and our famous Router Charts, Ranker and plenty more!

AC58u seems to be bricked after firmware update

Discussion in 'ASUS Wireless' started by bestly510, Apr 26, 2019.

  1. bestly510

    bestly510 New Around Here

    Joined:
    Apr 26, 2019
    Messages:
    1
    Hi there,
    I tried to update my ac58u's firmware yesterday, and after the update, all indicators stop lighting except the power one.
    I then tried to use ASUS's rescue tool, it always success, however, still got no change, only the power indicator shinning

    Is there any other way to do?

    Thanks