What's new

AiMesh Nodes intermittently disconnect and then reconnect at random

  • SNBForums Code of Conduct

    SNBForums is a community for everyone, no matter what their level of experience.

    Please be tolerant and patient of others, especially newcomers. We are all here to share and learn!

    The rules are simple: Be patient, be nice, be helpful or be gone!

The Cool Dude

Occasional Visitor
Hello everyone.

Hopefully someone can help shed some light on this weird issue.

I have a RX-AX89X connected directly to my cable modem in the basement.

I have two RT-AX92U routers set as my nodes. One on the main floor and on on the second floor. They are both hard wired with CAT6 Ethernet.

Everything has been working great for several years now.

The problem:

One night this past week I was poking around on the Asus Router app on my phone and noticed that both of my nodes have been disconnecting and then reconnecting at random. When the nodes disconnect, all the wireless devices connect to the RX-AX89X, then when the RT-AX92U nodes reconnect, slowly the wireless devices reconnect to the nodes. Sometimes one node is connected and looks fine while the other is offline and vice versa. Sometimes they are both offline, or both online.

So thinking that something is wrong I rebooted the nodes and then they came back up no problem but a short time later they dropped off again. So then I rebooted the RX-AX89X and again.... same issue.

Then I checked the web interface of my RX-AX89X and it looks like this:

1701560524084.png


Sometimes one node is up and the other is down so it looks like this:

1701561260301.png


Then I tried resetting the nodes to factory settings and then set them up as nodes again. Same issue. Then I reset the RX-AX89X to factory and set everything up again but the issue persists.

Thinking that perhaps something is wrong with the CAT 6 ethernet runs to my other floors, I took one of the RT-AX92U routers to the basement and connected it directly to the RX-AX89X and the issue persists.

I'm thinking that the problem is either with the RX-AX89X or the RT-AX92Us. I'm running the latest firmware on all three routers.

RX-AX89X is on 3.0.0.4.388_32407.

The RT-AX92U routers are both on 3.0.0.4.388_23630.

Could this be a problem with the firmware on these routers?

Anything else I could be missing?

Any help or suggestions would be greatly appreciated.

Thanks everyone!
 
If you have Ethernet Backhaul Mode enabled in AiMesh/System Settings disable it. Let the router and nodes detect the Ethernet connection automatically.
Make sure you have WPS enabled. Also use the default WIFI settings. The WIFI settings should not matter with Ethernet backhaul but...
Likely not your cable unless you use a switch between the router and nodes.
 
Hello everyone.

Hopefully someone can help shed some light on this weird issue.

I have a RX-AX89X connected directly to my cable modem in the basement.

I have two RT-AX92U routers set as my nodes. One on the main floor and on on the second floor. They are both hard wired with CAT6 Ethernet.

Everything has been working great for several years now.

The problem:

One night this past week I was poking around on the Asus Router app on my phone and noticed that both of my nodes have been disconnecting and then reconnecting at random. When the nodes disconnect, all the wireless devices connect to the RX-AX89X, then when the RT-AX92U nodes reconnect, slowly the wireless devices reconnect to the nodes. Sometimes one node is connected and looks fine while the other is offline and vice versa. Sometimes they are both offline, or both online.

So thinking that something is wrong I rebooted the nodes and then they came back up no problem but a short time later they dropped off again. So then I rebooted the RX-AX89X and again.... same issue.

Then I checked the web interface of my RX-AX89X and it looks like this:

View attachment 54604

Sometimes one node is up and the other is down so it looks like this:

View attachment 54607

Then I tried resetting the nodes to factory settings and then set them up as nodes again. Same issue. Then I reset the RX-AX89X to factory and set everything up again but the issue persists.

Thinking that perhaps something is wrong with the CAT 6 ethernet runs to my other floors, I took one of the RT-AX92U routers to the basement and connected it directly to the RX-AX89X and the issue persists.

I'm thinking that the problem is either with the RX-AX89X or the RT-AX92Us. I'm running the latest firmware on all three routers.

RX-AX89X is on 3.0.0.4.388_32407.

The RT-AX92U routers are both on 3.0.0.4.388_23630.

Could this be a problem with the firmware on these routers?

Anything else I could be missing?

Any help or suggestions would be greatly appreciated.

Thanks everyone!

I notice the AX89X has lots of LAN ports... maybe a bank of them is wigging out. Try moving your backhauls to the other bank of 4 ports(?)

Any Ethernet disconnection clues in the router Logs?

OE
 
Hello again and thanks for the responses.

Here is some more info that may help.

Since I have reset to factory defaults, Ethernet Backhaul Mode is still disabled. I never had it enabled before the reset either. WPS is currently enabled. WIFI settings are all currently at default.

I was using a switch between the RX-AX89X and the two RT-AX92U routers but have since moved them to connect directly to the RX-AX89X as I thought perhaps my switch was the problem. It isn't.

I've moved the ports for the two RT-AX92U routers on the RX-AX89X but no difference.

I had a look at the System log but I don't see anything that helps. Perhaps I just don't understand what's happening or what I'm reading in the logs. Here is a snip of the logs.

Dec 2 17:52:52 kernel: [30493.046587] wlan: [809:I:ANY] WLAN-NSS: VAP NSS ops initialized
Dec 2 17:52:52 kernel: [30493.047581] wlan: [809:I:ANY] VAP device ath0 created osifp: (b5513500) os_if: (b2588000)
Dec 2 17:52:53 kernel: [30494.465674] eth4: PHY Link up speed: 10
Dec 2 17:52:54 kernel: [30495.466076] sfp_phy_link_change_notify[165]:INFO:SFP+ running.
Dec 2 17:52:54 kernel: [30495.466097] sfp_read_status[125]:INFO:SFP+ link-down.
Dec 2 17:52:54 kernel: [30495.466418] eth0: PHY Link up speed: 1000
Dec 2 17:52:55 kernel: [30496.178955] wlan: [1665:I:ANY] ol_ath_set_config_param: 1654: set TXBF_SND_PERIOD: value 100 wmi_status 0
Dec 2 17:52:55 kernel: [30496.345710] wlan: [0:I:ANY] ol_ath_set_config_param: 2406: Disconnect_timeout value: 10
Dec 2 17:52:55 kernel: [30496.388567] wlan: [0:I:ANY] ol_ath_set_config_param: 2412: Reconfiguration_timeout value:60
Dec 2 17:52:55 kernel: [30496.465956] eth4: PHY Link is down
Dec 2 17:52:55 kernel: [30496.505849] eth2: PHY Link up speed: 100
Dec 2 17:52:56 kernel: [30497.112592] wlan: [2089:I:ANY] ol_ath_set_config_param: 1654: set TXBF_SND_PERIOD: value 100 wmi_status 0
Dec 2 17:52:56 kernel: [30497.291874] wlan: [0:I:ANY] ol_ath_set_config_param: 2406: Disconnect_timeout value: 10
Dec 2 17:52:56 kernel: [30497.339295] wlan: [0:I:ANY] ol_ath_set_config_param: 2412: Reconfiguration_timeout value:60
Dec 2 17:52:58 roamast: ROAMING Start...
Dec 2 17:52:58 kernel: [30499.865967] eth5: PHY Link up speed: 2500
Dec 2 17:53:01 kernel: [30502.015089] wlan: [2618:E:ANY] wlan_set_param: 756: wlan_set_param: ShortGI setting 1 not allowed
Dec 2 17:53:01 kernel: [30502.219659] wlan: [2645:I:ANY] wlan_set_param: 3031: HE MU BFER already set with this value =0
Dec 2 17:53:01 kernel: [30502.300801] wlan: [2654:I:ANY] ol_ath_vap_set_param: 2240: VDEV params:HE su_bfee:0|su_bfer:0|mu_bfee:0|mu_bfer:0|dl_muofdma:1|ul_muofdma:0|ul_mumimo:0|dl_muofdma_bfer:0
Dec 2 17:53:01 kernel: [30502.300824] wlan: [2654:I:ANY] ol_ath_vap_set_param: 2253: he_bf_cap=0x10
Dec 2 17:53:01 kernel: [30502.381043] wlan: [2663:I:ANY] wlan_set_param: 2897: HE UL MU OFDMA already set with this value =0
Dec 2 17:53:01 kernel: [30502.445882] wlan: [2672:I:ANY] wlan_set_param: 2878: HE UL MU MIMO already set with this value =0
Dec 2 17:53:01 kernel: [30502.457320] wlan: [2704:I:ANY] DES SSID SET=TheDeltaFlyer
Dec 2 17:53:01 kernel: [30502.659340] wlan: [2354:I:ANY] wlan_cfg80211_do_acs: 3717: vap-0(ath1):ACS Params
Dec 2 17:53:01 kernel: [30502.659354] wlan: [2354:I:ANY] wlan_cfg80211_do_acs: 3720: ht_enabled:1|ht40_enabled:1|vht_enabled:1|hw_mode:29|chwidth:40|
Dec 2 17:53:01 kernel: [30502.770735] wlan: [2774:E:ANY] wlan_set_param: 756: wlan_set_param: ShortGI setting 1 not allowed
Dec 2 17:53:02 kernel: [30502.972458] wlan: [2801:I:ANY] wlan_set_param: 3031: HE MU BFER already set with this value =0
Dec 2 17:53:02 kernel: [30503.035466] wlan: [2810:I:ANY] wlan_set_param: 2897: HE UL MU OFDMA already set with this value =0
Dec 2 17:53:02 kernel: [30503.094335] wlan: [2819:I:ANY] wlan_set_param: 2878: HE UL MU MIMO already set with this value =0
Dec 2 17:53:02 kernel: [30503.100594] wlan: [2823:I:ANY] DES SSID SET=TheDeltaFlyer
Dec 2 17:53:02 kernel: [30503.352944] wlan: [2354:I:ANY] wlan_cfg80211_do_acs: 3717: vap-1(ath0):ACS Params
Dec 2 17:53:02 kernel: [30503.352957] wlan: [2354:I:ANY] wlan_cfg80211_do_acs: 3720: ht_enabled:1|ht40_enabled:0|vht_enabled:1|hw_mode:30|chwidth:20|
Dec 2 17:53:02 rc_service: rc 2883:notify_rc restart_qca_lbd
Dec 2 17:53:02 rc_service: waitting "restart_wireless" via ...
Dec 2 17:53:02 mcastds: Entering evloopRun
Dec 2 17:53:02 rc_service: skip the event: start_cfgsync.
Dec 2 17:53:03 QCA LBD: daemon is stopped
Dec 2 17:53:03 QCA LBD: daemon is started
Dec 2 17:53:05 kernel: [30506.084326] wlan: [5811:I:ANY] vap-0(ath1): ACS result PCH 11 freq 2462, SCH 7 freq 2442, hw_mode 1 chwidth 40, vht_seg0 9 freq 2452, vht_seg1 0 freq 0
Dec 2 17:53:05 kernel: [30506.095774] wlan: [2354:I:ANY] DES SSID SET=TheDeltaFlyer
Dec 2 17:53:05 kernel: [30506.095789] wlan: [2354:I:ANY] wlan_cfg80211_chan_to_phymode: 1238: band:0 width: 2 channel_cfreq: 2462 center_freq1: 2452 chandef.center_freq2: 0 flags: 0
Dec 2 17:53:05 kernel: [30506.095887] wlan: [2354:I:ANY] ieee80211_ucfg_set_freq_internal: 553: Channel is configured already!!
Dec 2 17:53:05 kernel: [30506.096016] wlan: [0:I:ANY] ieee80211_disable_legacy_rates: 1609: ieee80211_disable_legacy_rates:MSG: User has disabled the previously set modified rate for beacon.
Dec 2 17:53:05 kernel: [30506.096021] wlan: [0:I:ANY] ieee80211_disable_legacy_rates: 1610: ieee80211_disable_legacy_rates:MSG: Hence going for the lowest available basic rate for beacon: 0 (Kbps)
Dec 2 17:53:05 kernel: [30506.199439] wlan: [0:I:CMN_MLME] vdev[0] ieee chan:11 freq:2462
Dec 2 17:53:05 kernel: [30506.199608] wlan: [0:E:FILS discovery] wlan_fd_set_valid_fd_period: 607: Invalid FD Interval : 0. Valid range is 20 - 100ms.
Dec 2 17:53:05 kernel: [30506.199608] FD Interval should be a factor of BI.
Dec 2 17:53:05 kernel: [30506.199608] Disabling FD
Dec 2 17:53:05 kernel: [30506.199688] wlan: [0:E:FILS discovery] wlan_fd_set_valid_fd_period: 607: Invalid FD Interval : 0. Valid range is 20 - 100ms.
Dec 2 17:53:05 kernel: [30506.199688] FD Interval should be a factor of BI.
Dec 2 17:53:05 kernel: [30506.199688] Disabling FD
Dec 2 17:53:05 kernel: [30506.199726] wlan: [0:I:ANY] vdev[0]: Mgt Rate:6000(kbps)
Dec 2 17:53:05 kernel: [30506.199740] wlan: [0:I:ANY] ol_ath_vap_set_param: 1452: Now supported CTRL RATE is : 6000 kbps and rate code : 0x10000003
Dec 2 17:53:05 kernel: [30506.199762] wlan: [0:I:ANY] vdev[0]: Mgt Rate:6000(kbps)
Dec 2 17:53:05 kernel: [30506.199773] wlan: [0:I:ANY] ol_ath_vap_set_param: 1452: Now supported CTRL RATE is : 6000 kbps and rate code : 0x10000003
Dec 2 17:53:06 kernel: [30506.987265] wlan: [2354:I:ANY] wlan_cfg80211_set_ap_chanwidth: 569: wlan_cfg80211_set_ap_chanwidth: freq:2462 hw_value:11 ch_width:1
Dec 2 17:53:10 kernel: [30511.333242] wlan: [5811:I:ANY] vap-1(ath0): ACS result PCH 149 freq 5745, SCH 157 freq 5785, hw_mode 2 chwidth 80, vht_seg0 155 freq 5775, vht_seg1 0 freq 0
Dec 2 17:53:10 kernel: [30511.350894] wlan: [2354:I:ANY] DES SSID SET=TheDeltaFlyer
Dec 2 17:53:10 kernel: [30511.350912] wlan: [2354:I:ANY] wlan_cfg80211_set_phymode: 1214: desired hw mode: 30
Dec 2 17:53:10 kernel: [30511.351053] wlan: [2354:I:ANY] ieee80211_ucfg_set_freq_internal: 553: Channel is configured already!!
Dec 2 17:53:10 kernel: [30511.351300] wlan: [0:I:dfs] WLAN_DEBUG_DFS_ALWAYS : dfs_set_current_channel_for_freq: 879: dfs_curchan already updated
Dec 2 17:53:10 kernel: [30511.682831] wlan: [0:I:CMN_MLME] vdev[1] ieee chan:149 freq:5745
Dec 2 17:53:10 kernel: [30511.683064] wlan: [0:E:FILS discovery] wlan_fd_set_valid_fd_period: 607: Invalid FD Interval : 0. Valid range is 20 - 100ms.
Dec 2 17:53:10 kernel: [30511.683064] FD Interval should be a factor of BI.
Dec 2 17:53:10 kernel: [30511.683064] Disabling FD
Dec 2 17:53:10 kernel: [30511.683179] wlan: [0:E:FILS discovery] wlan_fd_set_valid_fd_period: 607: Invalid FD Interval : 0. Valid range is 20 - 100ms.
Dec 2 17:53:10 kernel: [30511.683179] FD Interval should be a factor of BI.
Dec 2 17:53:10 kernel: [30511.683179] Disabling FD
Dec 2 17:53:10 kernel: [30511.683223] wlan: [0:I:ANY] vdev[1]: Mgt Rate:6000(kbps)
Dec 2 17:53:10 kernel: [30511.683256] wlan: [0:I:ANY] vdev[1]: Mgt Rate:6000(kbps)
Dec 2 17:53:12 kernel: [30513.476809] wlan: [4622:I:ANY] ol_ath_vap_set_param: 1334: Now supported MCAST RATE is 6000(kbps) and rate code: 0x10000003
Dec 2 17:53:12 kernel: [30513.507080] wlan: [4619:I:ANY] ol_ath_vap_set_param: 1334: Now supported MCAST RATE is 6000(kbps) and rate code: 0x10000003
Dec 2 17:53:12 roamast: ROAMING Start...
Dec 2 17:53:27 LBD: [ath1]: try to steer 88:66:5A:26:FC:D8 by legacy
Dec 2 17:53:32 rc_service: watchdog 1708:notify_rc start_cfgsync
Dec 2 17:53:33 CFG_MNT: report band 1 unavailable channel list [52,56,60,64,100,104,108,112,116,120,124,128,132,136,140,144]
Dec 2 17:53:47 hostapd: ath0: STA f0:f6:c1:c8:36:64 IEEE 802.11: did not acknowledge authentication response
Dec 2 17:53:52 roamast: [EXAP]Deauth old sta in 0 0: 8A:96:AC:F9:33:35
Dec 2 17:53:52 roamast: ath1: disconnect weak signal strength station [8a:96:ac:f9:33:35]
Dec 2 17:54:00 roamast: ath1: remove client [8a:96:ac:f9:33:35] from monitor list
Dec 2 17:54:07 LBD: [ath1]: try to steer B8:3A:9D:B1:6E:A0 by legacy
Dec 2 17:54:18 roamast: [EXAP]Deauth old sta in 1 0: 3A:CE:DA:1A:F9:9F
Dec 2 17:54:18 roamast: ath0: disconnect weak signal strength station [3a:ce:da:1a:f9:9f]
Dec 2 17:54:18 roamast: ath0: remove client [3a:ce:da:1a:f9:9f] from monitor list
Dec 2 17:54:20 hostapd: ath1: STA b8:3a:9d:b1:6e:a0 IEEE 802.11: did not acknowledge authentication response
Dec 2 17:54:56 LBD: [ath1]: try to steer F0:F6:C1:51:6F:9C by legacy
Dec 2 17:56:01 LBD: [ath1]: try to steer 8A:22:C7:20:23:2A by BTM

Any help or suggestions would be greatly appreciated.

Thanks everyone!
 
They just updated the firmware on the 89X in late October. You could rollback to the previous firmware, run it for awhile and see if it is any better. If nothing else, it could tell you if they broke something in this latest update or rule it out if it keeps disconnecting.
 
Hello everyone and thanks for all the replies and suggestions.

Looks like Brad was correct. I downgraded my RX-AX89X from ASUS RT-AX89X Firmware version 3.0.0.4.388_32407 to 3.0.0.4.386_47468 and now my two RT-AX92U routers set as my nodes are showing up just fine again.

1701750286079.png


Thanks again everyone.

One more thing... Does Asus read these posts? Any idea if they will see this and try and fix the node issue with ASUS RT-AX89X Firmware version 3.0.0.4.388_32407?

Thanks again.
 
Happy to hear it is working again. I doubt ASUS will see this thread but you could use the Feedback feature at the very bottom of the router's administration page to let them know.
 
Thought as much. Good call. Thanks again!
 
Hello.
I have one ax89x with 3 nodes tuf-ax-5400 and dont have this problems.
All works fine with the last firmware, from this firmware was released.

But, previously i bouth the ax-5400 as nodes, i had ax92u and i have a lot of problems. Constant disconects, constant resets, and i must restored the ax92u in some times.
Because i had this problem, i returned the ax92u to amazon and bought the ax-5400. This was my solution 2 years ago aprox.

I understand that your problem is only with the last firmware, but i want to share my experience with you.

Now this firmware is some kind of final version and I think a new release will give a long time to release.
You must open a ticket in assus support and try to report logs and more information, maybe they will fix in a new beta version and share with you to test if this solve the problem.
 
I think The Cool Dude is jumping to a conclusion too quickly. if you experience a problem does not mean that you know where the problem is. I'm using the latest firmware (407) with a wired node (RT-AX86U) without a problem and have never even booted the RT-AX89X since installation (48 days up).
 
Since I have reset to factory defaults, Ethernet Backhaul Mode is still disabled. I never had it enabled before the reset either. WPS is currently enabled. WIFI settings are all currently at default.

Any help or suggestions would be greatly appreciated.

Thanks everyone!
This part of your post has me curious from my own experience setting up the AX89X on more than one occasion. When I setup the AX89X with two AX88Us as nodes, I hooked up the Cat 5e ethernet cables and went through the AI Mesh setup for both nodes. I never saw the Ethernet Backhaul Mode setting that first time, so I never touched it. I noticed later that any wireless client connected to the AX89X was only connecting at 2.4GHz. It was because even with the cables hooked up, the AX89X was still using the 5Ghz band for the backhaul. As soon as I enabled the Ethernet Backhaul Mode, the AX89X wireless clients started connecting at 5Ghz.

So, I'm curious if didn't enable the ethernet backhaul if you're actually running wireless, which could be leading to your drop outs. Are your wireless clients connecting to the AX89X at 5Ghz?

I've used a ton of different firmware versions on the AX89X and never had AI Mesh issues. Even as I expanded my network to add two AX58Us to accompany the two AX88Us.
 
Hi Everyone.

Thanks for your thoughts....

I've reached out to Asus Support via the feedback section. No response yet.

Since I've rolled back my firmware to 3.0.0.4.386_47468 everything has been solid.

I never enabled the Ethernet Backhaul Mode in AiMesh/System Settings. It's always detected the two RT-AX92U routers as being on Ethernet all by itself.

1702077833140.png


In the management settings I've always left it on Auto.

1702078071050.png


I wonder if maybe there is a compatibility with ASUS RT-AX89X Firmware version 3.0.0.4.388_32407 and having two RT-AX92U routers on 3.0.0.4.388_23630. Doesn't seem like anyone in this thread has this combination except me.
 

Similar threads

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top